Jump to content
BJY1991

R7 360 Low performance

10 posts in this topic

Recommended Posts

I use WhateverGreen.kext and  FakeID 665C1002 get R7 360 working with QE/CL.

But it's very Low performance even compare with intel HD4600.

I found out that GPU frequency is very low stuck at 150MHz.

What can I do to fix it ?

thanks

Share this post


Link to post
Share on other sites
Advertisement

I'll take a look when I get home.

 

But I think that @MaLd0n can give you a good help with your ACPI patching, with just one DSDT you can have all the necessary patches. ;)

Share this post


Link to post
Share on other sites

Remove all the flags at boot-arg section, and all the things related to the video.

Let only WhatEverGreen and Lilu do the job.

 

Do this test.

Share this post


Link to post
Share on other sites

Without FakeID video card will not have QE/CL should I add device id into kext ?

Also macOS display video card as  unknown 

Share this post


Link to post
Share on other sites
3 hours ago, BJY1991 said:

Without FakeID video card will not have QE/CL should I add device id into kext ?

Also macOS display video card as  unknown.

I  come up a new idea.

can I add PP_PhmSoftPowerPlayTable info in kext

just like RX VEGA it can help macOS recognize GPU working status

Share this post


Link to post
Share on other sites

I have tried add PP_PhmSoftPowerPlayTable and it's not working:(

here is my info.plist in AMD8000Controller

<key>aty_properties</key>
			<dict>
				<key>PP_DisableCAC</key>
				<integer>0</integer>
				<key>PP_DisableDIDT</key>
				<integer>1</integer>
				<key>PP_DisablePPLib</key>
				<integer>0</integer>
				<key>PP_DisablePowerContainment</key>
				<integer>0</integer>
				<key>PP_DisableULV</key>
				<integer>0</integer>
				<key>PP_DisableVoltageIsland</key>
				<integer>1</integer>
				<key>PP_EnableBAPM</key>
				<integer>0</integer>
				<key>PP_EnableLoadFalconSmcFirmware</key>
				<integer>1</integer>
				<key>PP_Falcon_QuickTransition_Enable</key>
				<integer>1</integer>
				<key>PP_MclkActivityTarget</key>
				<integer>5</integer>
				<key>PP_PhmSoftPowerPlayTable</key>
				<data>
				oQIGAQAAAAkYWABgAH0AIAPoA1gAAIAAABIAAAIAPAAA
				YgB/AACvAAwArwDOACgFAADTHwAA6AARARwBAAB2AQAA
				AAAAAAAAAAAAAAAARQEAAAAACgAAAAIBAAACAQIAAwko
				mgHEegICEADg9gDEegIgEAAwdQCYOgACEAACGAgAAAAA
				AAAAAAAAAAAAAAAAAAAAAAAAAAUAAAAAAAAAAAAAAAAA
				AAAAAAAAAAAAAAcGcBdsIMQiuAskExAnECcAZADkEgAA
				AAAAAAAAAAAaADQVAgAsOgMAfwHpAS4CAABYAoICAAAA
				AAgwdQAB/+D2AAL/7CYBA/+kSwEE//BoAQX/bH4BBv9k
				kAEH/yiaAQj/Apg6ACADxHoChAMImDoAAf+YOgAC/5g6
				AAP/xHoCBP/EegIF/8R6Agb/xHoCB//EegII/whSAzkD
				AABrAzkDAAC8A34DAAABBLYDAABABOgDAAB4BBQEAACq
				BDkEAADJBF8EAAABIAMwdQCYOgAAC4y5AIy5ANjWANjW
				ACT0ACT0AHARAXARAfgkAfgkAYA4AYA4AQhMAQhMAaje
				AKjeAHCUAHCUAHjmAHjmAKhhAKhhAAgB/wAC/wAD/wEE
				/wIF/wMG/wQH/wUI/wYGAwEHAQgBCQEKAQcBAAcUzQB8
				kgAk9ACMuQA0GwGc4ABEQgGsBwHMVQH4JAFUaQFEQgHc
				fAGQXwEIAf8AAv8AA/8BBP8CBf8DBv8EB/8FCP8GAAgB
				/8ivAAL/yK8AA/8UzQAE/yT0AAX/NBsBBv+8LgEH/whM
				AQj/kF8BAAgB/9jWAAL/2NYAA//o/QAE//gkAQX/CEwB
				Bv+QXwEH/xhzAQj/3HwBAS8ALwAoAC8ALwCEA2AJLwBk
				AAAAAAAAAAAAAAAAAA==
				</data>
				<key>PP_PhmUseDummyBackEnd</key>
				<integer>0</integer>
			</dict>

 

Share this post


Link to post
Share on other sites

Have you solved this issue? I am also having the same problem and found this post. My R7 360 is under performing (especially on gaming), although it is detected by using FakeID and RadeonDeInit. Then, after reading this topic, I already tried Allan's solution but that did not work either.

Appreciate your help, thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By iTahaMe
      FINALLY IT'S WORKING THANKS TO @insanelymac
      But i have a single problem, My graphic card Radeon x1950 Pro not working, It used to work good on Snow Leopard but now its not on Yosemite i don't know why ... any kext needed ??
       
      Here the kext used to work good for me on Snow Leopard
      ATIRadeonx1000.kext 
      ATINDRV.Kext
      ATIRNDRV.Kext
       
       
      Any Help ? 
      Taha

    • By MikixIT
      Salve ragazzi, io ho un pc con sopra Windows e Sierra(che ho installato grazie a questo fantastico forum)
      Recenetemte ho avuto problemi con gli aggiornamenti windows 10(Che uso urgentemente per lavoro)
      E girando per i forum di Windows, ho capito che il problema era dato da un "interferenza" di clover di quando windows faceva i soliti riavvi quando aggiorna.
       
      Io volevo chiedere se era possibile selezionare MOMENTANAMENTE Windows come avvio primario e quindi non su clover, una sorta di bypassare clover
      e quindi il pc avvia o riavvia e va subito ad avviare windows senza passare da clover, in modo da fare aggiornare Windows e poi "RIATTIVARE" Clover esattamente come prima
      Esiste un modo di fare ciò senza perdere clover o dati etc? 
      Grazie se risponderete, buona serata ragazzi!
    • By BOB4UK
      Я выполнил инструкции, но когда я запустил установку, после загрузки полосы под яблоком у меня есть установочные окна, но их очень сложно понять, яркость ниже минимальной в Windows. Извините за мой плохой английский
       
      Specs: Core i7-6500u, 8GB RAM, GTX 950M (DISABLED)
    • By raphcort
      Hi everyone,
      This is my first post here so I hope I respect all the rules of this holy land ! (Please don't slay the noob !)
      I need your wisdom to give me advice for the new money burning hackintosh I'm building. I already have one, but I never managed to get it stabble enough and it gave me many headaches. Also it wasn't nearly powerfull enough for a tue professional use. The new one will serve me for my work as a video and sound editor but also, cause work's not everything, to dual boot and game while thinking of slaying some random and disrespectfull diretor !
      As I'm not much of a hardcore geek, the idea is to have a stable build that will last for quite a while, and be open for future adjustments or upgrades. I wish it to be as silent as possible and I really do not care about RGB stuff.
      I have searched a lot and seen many different builds but none who satisfid all my criteria.
      But I really want to find all the best parts possible and so I come for your help.
       
      For now, here are the parts I've selected :
      CPU : Intel I9 7900X 3.3GHz
      CPU Cooling System : Noctua NH-U12S
      MOBO : Gigabyte GA-X299 AORUS Gaming 7 Pro or Asus Prime X299-DELUXE
      RAM : SKILL F4–3200 mémoire 32gtzr (I'll add 32 more as soon as I'll have the money)
      System Drive High Sierra : Samsung 970 Pro NVMe SSD 512 Go
      System Drive Windows 10 : SSD Crucial 250go (Not for too long though !)
      PSUs : Corsair HX1200i 80 PLUS Platinum, 1200 Watt
       
      I haven't figure out the GPU nor the case yet... So please tell me what you thing cause there are so many models out there... I was thinking maybe a MSI GTX 1080 Ti GAMING X or the Radeon™ Pro WX 7100 Graphics which looks amazing for editing but not so great for hackintosh...
       
      Thanks a lot for your time and you help !
       
      Raph.
×