Jump to content
InsanelyMac Forum
MetalBreaker

Stuck at IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0

Recommended Posts

Posted (edited)

Hi,

I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.

SMBIOS: iMac13,1
Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
CPU: Intel Core i3-3210, iGPU disabled in UEFI

All kexts updated to their latest versions, along with Clover.

37556424-00bd77ca-29f6-11e8-96b0-1ad032283468.JPG

For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3

Any help would be appreciated.
Thank you for your time!

config.plist

Edited by MetalBreaker

Share this post


Link to post
Share on other sites
Advertisement

if you have installed Nvidia web driver try this config

in clover bootmenu press F11 (clear nvram) then try to boot

that loop error is very old error and was solved with latest clover and lilu/nvidiagraphicsfixup kext

 

 

config.plist

Share this post


Link to post
Share on other sites
Posted (edited)

Hi fabiosun. Thanks for taking the time to reply.

I tried the configuration file you attached, but I'm still getting the same issue.

The issue also happens with native drivers (as of High Sierra). Some people say it's a result of a multi-GPU setup but my iGPU is disabled in the UEFI, and I can't see it in the system report... The system worked perfectly in Sierra. I'm really lost and I'm quickly losing hope. I just wanted to try out iOS development... :(

Edited by MetalBreaker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • yes. please check it between 10.7~10.9. need to know supported minimum os.
    • Not sure but I think Netinstall starting in 10.8 ? I need chek for confirmation ?
    • Il post purtroppo è diventato chilometrico  e mi dispiace, ma ho ancora qualcosa da chiedere nella speranza che qualcuno di voi di buona volontà riesca ad aiutarmi.  Ho qualche problema di ottimizzazione riguardante l'audio che ogni tanto inspiegabilmente non va dalle casse integrate impostato in config su 28 (che è quello che normalmente funziona sua sulle cuffie che con le casse) ma ogni tanto non va. Ed infine il bluetooh della scheda, adesso son funziona più ( (BrcmFirmwareRepo e BrcmNonPatchRAM2 in clover) e invece BTFirmwareUploader in L/E.). Magari c'è qualche errore nel dsdt o nel config.  Vi allego la cartella clover https://drive.google.com/open?id=1d7qfHs3KYEWANjtSlKyR29aEbgTFsytd Non so come mai ma da quando il forum ha cambiato server l'upload diretto da sempre errore  e anche il caricamento delle pagine è molto lento. Vi ringrazio per la disponibilità .
    • can Netinstall support media for os version? 10.6~10.13? Netinstall Mac OS X Snow Leopard Netinstall Mac OS X Lion Netinstall OS X Mountain Lion Netinstall OS X Mavericks Netinstall OS X Yosemite Netinstall OS X El Captian Netinstall macOS Sierra Netinstall macOS High Sierra   right?
    • read that post and it looks like it's not a fix for the black screen . I did add whatever green and lily to clover folder on the USB but no luck.   


×