Jump to content
deathklok

Getting a green screen on boot - HP EliteDesk 800 G1 / i7-4770 / Intel HD 4600

4 posts in this topic

Recommended Posts

Hey everyone,

 

I'm having a strange and seemingly rare issue with my High Sierra installation. My computer is an HP EliteDesk 800 G1 / i7-4770 / Intel HD4600.

 

Whenever I boot, I always get a green screen after the Clover boot loader. However, if I wait until the computer enters sleep mode (not just the screen, the actual PC) and wake it up, the screen displays everything just fine.

 

My installation was super quick and easy:

  • Installed High Sierra on an SSD connected to a hard drive dock using my MacBook Pro

  • Booted into that installation using my MacBook Pro and installed Clover

  • Replaced the EFI folder on the EFI partition with one I found online for the HP EliteDesk 800 G1 (I believe it was posted by Donw35)

  • Installed the drive on my HP EliteDesk 800 G1, booted and that's it

I can confirm that everything is working fine, except on-board audio which I don't need since I'm using a USB interface. There are no graphical issues otherwise (doesn't hang, visiting www.clover.com on Safari, like stated above, works fine).

 

Does anyone have any idea what might be causing this? It's very annoying having to wait 2 or 3 minutes every time I boot just so I can wake the computer and get a picture.

 

Thank you in advance!

Share this post


Link to post
Share on other sites
Advertisement

that sounds strange, for the record I am using the same machine but with a Nvidia GT 1030 and an i5 processor 

Share this post


Link to post
Share on other sites

Hi I have a similar problem with my Hp elite desk 800 g1 , I use a dedicated GPU Rx 560 and my problem is with the dvi port I can't boot with a monitor plugged in to it , if I do after apple logo the screen turns black , also if I boot just using the HDMI connector it works but if I plug the dvi too both screens turn black , the only way I can make the dvi work is to boot with the hdmi then put the pc to sleep after I wake it I can plug in the dvi and it works together with the hdmi . Using or not lilu and whatevergreen makes no difference . Sorry for my bad English .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×