Jump to content
Sign in to follow this  
Followers 0
Friendlyx

Can't install High Sierra onto my computer - Service exited with abnormal code: 1

3 posts in this topic

Recommended Posts

Hello everyone!

 

I'm trying to get my hackintosh running, but i haven't been able to sadly. I'm basically trying to install high sierra onto my computer which is the following specs:

 

Intel i7 8700k

Gigabyte Z370 AORUS Gaming 7 

Gigabyte 1080 Ti AORUS Xtreme Edition 11GB

 

I had high sierra installed, but i messed up the software somehow, and then i thought i could just reinstall it (since it was really easy the first time, no issues) but was i wrong. I haven't been able to reinstall it even after wiping the drive completely clean. I am running windows 10, so i will be doing a dual boot.

 

I started following the following guide and it worked for the first time, but even after using their EFI it isn't working still: 

http://hackintosher.com/builds/gigabyte-z370-aorus-gaming-7-hackintosh-build-guide/

 

I'd appreciate any help i could get, i'm really at a loss. 

 

Thanks in advanced! 

post-2085021-0-68219800-1513574385_thumb.jpg

post-2085021-0-63287700-1513574401_thumb.jpg

post-2085021-0-96064000-1513574409_thumb.jpg

post-2085021-0-04376800-1513574421_thumb.jpg

post-2085021-0-81125100-1513574433_thumb.jpg

post-2085021-0-42554000-1513608618_thumb.jpg

post-2085021-0-90441000-1513608623_thumb.jpg

post-2085021-0-65372300-1513608629_thumb.jpg

post-2085021-0-04632500-1513608636_thumb.jpg

post-2085021-0-38377900-1513608640_thumb.jpg

post-2085021-0-98976900-1513619802_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

Disconnect the windows drive while installing.    Use clover boot argument nv_disable=1.    Once installed install Nvidia web drivers.

Hi there! Thank you for attempting to help me, however i did go ahead and set the argument and it still ends at the same issue. I've included more pictures and what i put in there. I've attached the new pictures to the original post after the blueish looking one, don't know why but my clover looks weird when i go to it. Hopefully you can help. Thank you! 

 

EDIT: I even doing the guide all over again, same issue, i waited long enough and got another thing after the abnormal code:1 thing. I've attached it in the pictures in the original post. 

 

EDIT: I tried using a different usb and different USB port, same issue. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rio2
      I recently installed High Sierra on my Ryzen system, just to find out how crappy the USB situation really is on AMD systems. The only choice is basically most of your ports flat out not working or GenericUSBXHCI crashing every time you pull out a thumbdrive. So after some trial and error here are my findings.
      The USB ports controlled by the XHCI controller on the SoC worked fine, but the ones attached to the chipset XHCI controller didn't.
      That's when I looked at the log and saw these lines:
      PTXH@00000000: AppleUSBXHCIPCI::createPorts: port 1 unsupported protocol USB 03.10 PTXH@00000000: AppleUSBXHCIPCI::createPorts: failed to allocate port 1 It turns out that for some reason the AppleXHCIPCI driver doesn't support the first two ports on the B350 chipset (made by ASMedia) USB controller. And after the driver fails to allocate port 1 it just stops and doesn't even look at the rest of the ports. So I first tried commenting out the first two ports from the DSDT and that worked and made all the other ports show app in the IOService tree. Than I quickly tested all the USB ports and it turns out that the 2 problematic ports aren't even wired to anything. But instead of editing the DSDT I wanted a cleaner solution, because I don't want to re-edit my DSDT every time I update the BIOS or change some BIOS settings.
       
      So here is my small SSDT that disables the stock PTXH device and adds a new device XHCI, that has all the ports needed for my board (ASUS PRIME B350-PLUS).
      DefinitionBlock ("SSDT-PRIME-B350-PLUS.aml", "SSDT", 1, "APPLE", "tinySSDT", 0x00000006) { External (\_SB_.PCI0.GPP2, DeviceObj) External (\_SB_.PCI0.GPP2.PTXH, DeviceObj) Scope (\_SB_.PCI0.GPP2.PTXH) { Name (_STA, Zero) } Scope (\_SB_.PCI0.GPP2) { Device (XHCI) { Name (_ADR, Zero) Device (RHUB) { Name (_ADR, Zero) // USB3.1 back panel Device (PRT1) { Name (_ADR, 0x5) Name (_UPC, Package (0x04) { 0xFF, 0x03, Zero, Zero }) } Device (PRT2) { Name (_ADR, 0x6) Name (_UPC, Package (0x04) { 0xFF, 0x03, Zero, Zero }) } // USB3.0 front panel Device (PRT3) { Name (_ADR, 0x7) Name (_UPC, Package (0x04) { 0xFF, 0x03, Zero, Zero }) } Device (PRT4) { Name (_ADR, 0x8) Name (_UPC, Package (0x04) { 0xFF, 0x03, Zero, Zero }) } // USB2.0 Device (PRT5) { Name (_ADR, 0x9) Name (_UPC, Package (0x04) { 0xFF, Zero, Zero, Zero }) } Device (PRT6) { Name (_ADR, 0xa) Name (_UPC, Package (0x04) { 0xFF, Zero, Zero, Zero }) } Device (PRT7) { Name (_ADR, 0xb) Name (_UPC, Package (0x04) { 0xFF, Zero, Zero, Zero }) } Device (PRT8) { Name (_ADR, 0xc) Name (_UPC, Package (0x04) { 0xFF, Zero, Zero, Zero }) } Device (PRT9) { Name (_ADR, 0xd) Name (_UPC, Package (0x04) { 0xFF, Zero, Zero, Zero }) } Device (PRTA) { Name (_ADR, 0xe) Name (_UPC, Package (0x04) { 0xFF, Zero, Zero, Zero }) } } } } } Please note that this is just an example and it most likely needs to be changed for your board.
    • By crazykeyboard
      Asrock Z370 Professional 7
      I7 8700K
      evga 1080 ti ftw 3
      16gb gskill 3200 CL14 
       
      High sierra the last version of curse
       
      THANK YOU
      dacd@me.com
    • By BJY1991
      I use WhateverGreen.kext and  FakeID 665C1002 get R7 360 working with QE/CL.
      But it's very Low performance even compare with intel HD4600.
      I found out that GPU frequency is very low stuck at 150MHz.
      What can I do to fix it ?
      thanks
    • By cydia2020
      G'day guys,
      I recently bought a Surface Book i5 256GB with dGPU, and I found that there's no tutorial about Hackintosh since it's released, so i am here to be the first (maybe) to try this out
       
      This guide is not being recommended by its author, as the final performance is usually janky and unstable, most fundamental functions of your Surface will not work in Hackintosh, please always consider the consequence of proceeding, you also risk losing your data, again, please proceed with caution
       
      ******謝絕轉載謝謝配合******
      ******Please do not repost, thanks******
      ******転載禁止です。ご協力をお願いします。*******
      This project is deprecated (and it was only meant for 10.11 - 10.12.3) due to hardware availability on my side, no support for future OSes will be provided by me personally and support on current OSes will be limited. Your contributions, testing and guides will be appreciated by the community.
       
      video is up at
       

      Disclaimer: everything is on yourself, please proceed with caution and care
      Works
      Keyboard & Trackpad (No Gestures)(Buggy, when you hold a key, pointer won't move),
      SD card reader,
      USB 3.0 ports,
      Sound
      PCIe SSD
      Intel HD 520 Graphics works perfect on 10.11.4
      DP Video output now works(don't close the lid, it lead to big problems)(after closing the lead with external monitor, when plug in the external monitor, it no longer recognize the internal display, you must unplug the monitor and reboot)
      Long press power key brings up the power menu
      Brightness
      Lid

      Doesn't work
      NVidia dGPU
      Touch Screen (Alex's driver won't work since it's now on HID Camplg ports, which is not open source)
      Wireless (Wi-Fi & Bluetooth)
      Volume rocker
      Battery status

      What Works for 10.12
      Everything for 10.11 :-)

      Bugs For 10.12.3 and below
      Graphics is janky and unstable. and does not work natively, driver patch is needed
       
      Graphics will not work on 10.12.4 as reported for the built-in display, please take notice and do not upgrade
      First Step: Installing a Virtual Machine
      You will need a VM in order to get the thumb drive ready, please install a VM or you can use a real Mac to do this, the installation is not very hard, but do need some times for downloads and other stuff.
      Download VMWare Workstation Pro 12.0 Trial Version Download VMWare Unlocker Download Python Runtime Modify Unlocker Bat file -- In the unlocker installer, there's a win-install.bat file that you can open by CMD, but don't open yet, we need to modify a path in the file, open the file using your favorite text editor, find unlocker.exe in the file, change it to unlocker.py The previous step is redundant  Follow the instruction on unlocker readme file Go to a Apple Store, get a Install App from their computer and convert the BaseSytem.dmg to CDR, or you can just skip those steps to the making USB step Use the converted CDR as install media in VMware Installing OS X as normal Second Step: Prepare to install
      You need an actual Mac to make the install USB or using a VM, both methods are fine, I wouldn't say more about installing a VM on your devices, you can Google that yourself
      You'll need to download the 10.11.x installing App from this link For macOS 10.12 please go to this link to get the preview version You need to open Disk Utility. Select the USB Drive and format it as Mac OS X Extended (Journal-ed), Name it whatever you want, as long as you can remember the name. Now, open the terminal, enter the following text, this will cost you around 4 minutes on a USB 3.0 device and 30 minutes on a USB 2.0 device, go get yourself some drinks For 10.11 sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/PARTITION NAME --applicationpath "/Applicatons/Install OS X El Capitan.app" --nointeraction The previous method won't work on 10.12 anymore, you will get a USB that is not booting, use the guide below Download Clover from Clover Official Download Page Install Clover by choosing "Install UEFI Version only, install to EFI partition, Install Themes, Driver64UEFI(unselect CsmVideoDxe-64) After installing, you should see a Partition called EFI mounted, and it's your thumb drive (Copy the EFI folder from Installing OS X to the EFI Partition) only do this if it didn't do atomically DownloadSurfaceDriver.zip and follow the instruction in the ReadMe.txt to paste the files into your CLOVER folder ++++++++++Notice for 10.12 USB Creation++++++++++
      The pervious way of making the 10.11 drive won't work anymore in 10.12, instead, after downloading the 10.12 install app, you'll need to follow the following steps
      Show hidden files by executing this command defaults write com.apple.finder AppleShowAllFiles YES Navigate to /Application/Install macOS Sierra/Contents/SharedSupport and mount InstallESD.dmg
      Open "Disk Utility", restore the USB drive with Basesystem.dmg (hidden) in the mounted DMG file.
      Copy /Packages in the mounted DMG file to the restored USB's /System/Installation. Delete the old link before proceeding to the copy.
      Copy basesystem.dmg and basesystem.chunklist to the root directory of your USB drive
      Third Step: Installing OS X 10.11

      Now, we can start installing 10.11, you should plug in an external keyboard, mouse, and your thumb drive, after you finish the booting process, you should see the welcome page, choose the language you prefer and proceed the installation
      Go to Windows First, partition your drive for at least 50 GB if you want to keep using, because as I tried before, remapping disk after installing macOS or OS X is extremely HARD, don't try that unless it's necessary, you will risk the integrity of your data by doing that
      Choose Disk Utility, choose your installing partition and click erase, format as OS X Extended (Journal-ed), then, exit Disk Utility and proceed the installation process, you might need to proceed the same process twice to get the full install, so if you didn't saw your OS X drive, please choose install again. (The installation will automatically continue.)

      Or: Installing macOS 10.12
      Please change ig-platform-id to 12345678 before installing the framebuffer kext.
      Things getting a little bit tricky when you're trying to install 10.12 on Surface Book. Since there's still a little bit of problems with the NVMe driver, you will likely get a error message says: unable to unmount volume for repair
      I am not sure if the error spreads largely, but, I experienced it every time I install the 10.12
      The temporary workaround is that to use an external USB hard drive or a SD card, I don't recommend a USB thumb drive unless it's superfast.
       
      Install 10.12 as normal to the external hard drive apply all the combo updates to the external hard drive system Use the recovery environment comes with the Installer (not the hard drive) Open Disk Utilities and restore the whole USB hard drive to the macOS install drive You can apply combo or delta updates as normal, but do not apply big updates that requires a standalone app download, backup and reinstall instead Problems regarding 10.12 installing has been solved, please proceed as normal
       
       
      The Final Process: Make your experience better
      You don't have to patch the keyboard drivers for 10.12.1 and/or above
      For 10.12, please install the kexts in 10.12 "install" folder located in the driver pack
      Make the keyboard works (10.11 only)
      Navigate to InstallHD/System/Library/Extension Copy the IOUSBFamily Kext to your desktop or wherever you like Right click on it and choose show package content, go to /Contents/PlugIns Right click on IOUSBHIDDriver and choose show package content, go to /Contents Open Info.plist using software like: PlistEditor Pro, and xCode Navigate to IOKitPersonalities Copy Generic Keyboard and right click on IOKitPersonalities Select "Paste as a child" Expand Generic Keyboard 2 change the value of bInterfaceProtocol to 0 change the value of bInterfaceSubclass to 3 change USBCompatibilityMatch to YES (doesn't have this on 10.11) save the file and open Kext Utilities Drag and Drop the kext in to it, enter password and after it finished reboot, then you should have a working keyboard Install Clover to SSD
       
       
      To install clover to ssd, you need the CLOVER PKG installer and remeber to update as a new version releases, it might contains bug fixes.
       
       
      Install clover as normal, install to your HACKINTOSH INSTALL DRIVE Use UEFI Boot Version, Install theme, and Driver, unselect CsmVideoDxe PUT THE SURFACE BOOT DRIVER INTO THE DIRECTORY Use BOOTICE x64 Version under windows, mount EFI under windows, Select UEFI tab, add a new boot entry navigate to EFI:\EFI\CLOVER\CLOVERX64.efi, name it clover bootloader (or whatever you like). Go to Surface UEFI, unselect Windows Boot Manager under Boot tab, select and drag CLOVER to the first position of the UEFI boot sequence,  
      NOTICE: DO NOT DELETE "INTERNAL" selection in UEFI setup, or your Surface WILL NOT BOOT (won't happen on newer BIOS)
       
       
      By the way, according to the feedback, there has been some problems with the AppleHDA patch, please install AppleHDA298.kext to S/L/E directly using your kext installer instead of placing it under /CLOVER/kexts, also, please use sRGB as color profile to avoid any grahpics glitch in 10.11.
       
       
      _____________________________________________________________________
       
      You'll need a Wi-Fi dongle to get online or you can use USB Sharing on Android and iOS, don't know whether network sharing on Ubuntu Touch, Windows Phone and Blackberry will work
      You'll also need a Bluetooth dongle to get BT working


       
      __________________________________________________________________________________________________________________________________________
      Thanks to
      LonelyTV
      MeuPRodrigo
      maj1es2tic
      Pike

      and all of you
    • By superq
      Hello everyone,
      My hack(HP Elitebook 2570p) works perfectly exept for one thing:Wifi.
      It has a BCM943142 Combo card,is there any way to get that card working?
      I'm running HS.
      Thanks in advance!
×