Jump to content
dark_hacker

Helps to create correct dsdt for my hardware

59 posts in this topic

Recommended Posts

I have the macOS sierra 10.12.6 installed, I have graphs 1st generation installed the kexts following the guide http://www.insanelymac.com/forum/topic/286092-guide-1st-generation-intel-hd-graphics-qeci/tengo but in some parts of the system I have some distortions from what I saw in the guide nobody had this problem.

I think it may be the settings of my clover and dsdt that are not correct, I leave attached the dsdt extracted from the clover and the current clover settings.

I also do not know if the power system is working properly because in sleep mode the screen does not turn black

 

Config

 

CPU: Core i5 460M

Memory: 6 GB

Graphics: Intel HD Graphics 1st + ATI Radeon 5470 1GB

files.zip

Share this post


Link to post
Share on other sites
Advertisement

I have not tried do not know how to disable an intel to work only with ati

Try this config.plist

 

 

EDIT ****

what is the revision Clover you have?

Edit *** config remove 

Share this post


Link to post
Share on other sites

Revision Clover_v2.4k_r4243

 

with this config give kernal panic

Post picture of KP  in verbose mode please

what is the Motherboard?

 

EDIT ***

Did you plug the screen to the DVI or HDMI port of the Graphics card?, not to the IGPU Motherboard

Share this post


Link to post
Share on other sites

Post picture of KP  in verbose mode please

what is the Motherboard?

 

EDIT ***

Did you plug the screen to the DVI or HDMI port of the Graphics card?, not to the IGPU Motherboard

 

And a laptop model g62-a40sp the only difference and the original processor well an i3 and i put an i5 460M i did not connect an external screen this on the screen of the internal laptop but if it achieves by an operation the hdmi was perfect if it does not do not hurt.

 

Image:

 

https://imgur.com/E1XEcrj

Share this post


Link to post
Share on other sites

And a laptop model g62-a40sp the only difference and the original processor well an i3 and i put an i5 460M i did not connect an external screen this on the screen of the internal laptop but if it achieves by an operation the hdmi was perfect if it does not do not hurt.

 

Image:

 

https://imgur.com/E1XEcrj

Ha ok its a Laptop  ATI Mobility Radeon HD 5470

I was a post in the PC section and I did not notice you were in the Laptop section , my bad Sorry  :angel_not:

Try this config one by one , rename config.plist before change

 

Edit ***config correction

config.zip

Share this post


Link to post
Share on other sites

Ha ok its a Laptop  ATI Mobility Radeon HD 5470

I was a post in the PC section and I did not notice you were in the Laptop section , my bad Sorry  :angel_not:

Try this config one by one , rename config.plist before change

 

Edit ***config correction

 

The two configs in the boot both stop to see image.

 

Image:

https://imgur.com/8iXE92v

Share this post


Link to post
Share on other sites

Do you want me to test or to do something ?

Disable ATI and Enable Intel, disable edid

and boot

 

You can change this in config.plist manually if you need in Graphics 

You have now a config working in progress  :P 

Share this post


Link to post
Share on other sites

Disable ATI and Enable Intel, disable edid

and boot

 

You can change this in config.plist manually if you need in Graphics 

You have now a config working in progress  :P 

 

I did this with intel enabled and you disabled it did boot correctly on the desktop

Share this post


Link to post
Share on other sites

I did this with intel enabled and you disabled it did boot correctly on the desktop

So now you have a working config.plist

You can change this in config.plist manually if you need in Graphics 

 

<key>Graphics</key>
<dict>
 
<key>Intel</key>
<true/>
 

 

Follow the Guide exactly for Arandale CPU thats the trick for you  :wink_anim: 

 

Edit ** 2

what ATI shows in about this mac in Graphics

Share this post


Link to post
Share on other sites

So now you have a working config.plist

You can change this in config.plist manually if you need in Graphics 

 

<key>Graphics</key>
<dict>
 
<key>Intel</key>
<true/>
 

 

Follow the Guide exactly for Arandale CPU thats the trick for you  :wink_anim: 

 

Edit ** 2

what ATI shows in about this mac in Graphics

 

I followed the tutorial several times more than always or even I tried it in several ways it could not solve I do not know what is missing but for a part of the dsdt that is not much more there is nothing to be? Now I do not have wifi to work. Can you give me a hand? and in the matter of the graph if you power grateful.

because even without intel activated without clover a graph works in the same.

 

Image with the default

 

https://imgur.com/sihn49b

https://imgur.com/jxtLkn2

https://imgur.com/tAzhh2G

 

Problem

 

https://imgur.com/UTuoIss

Share this post


Link to post
Share on other sites

I followed the tutorial several times more than always or even I tried it in several ways it could not solve I do not know what is missing but for a part of the dsdt that is not much more there is nothing to be? Now I do not have wifi to work. Can you give me a hand? and in the matter of the graph if you power grateful.

because even without intel activated without clover a graph works in the same.

 

Image with the default

 

https://imgur.com/sihn49b

https://imgur.com/jxtLkn2

https://imgur.com/tAzhh2G

 

Problem

 

https://imgur.com/UTuoIss

Ok wait for the Graphics Fix I send a Private message in my friend with a  a working laptop config Arandale 

What is the WIFI card?

Share this post


Link to post
Share on other sites

Ok wait for the Graphics Fix I send a Private message in my friend with a  a working laptop config Arandale 

What is the WIFI card?

 

And the AR928x with ids

168c: 002a

Share this post


Link to post
Share on other sites

And the AR928x with ids

168c: 002a

I see Nothing for your Wifi sorry

May be my freind post here soon for the Graphics  :)

Share this post


Link to post
Share on other sites

I see Nothing for your Wifi sorry

May be my freind post here soon for the Graphics  :)

 

Okay, the graphics is not bad, I'm waiting for your message to solve the problem. thank you

Share this post


Link to post
Share on other sites

Okay, the graphics is not bad, I'm waiting for your message to solve the problem. thank you

 

May be my freind post here soon for the Graphics   :)

Share this post


Link to post
Share on other sites

I see Nothing for your Wifi sorry

May be my freind post here soon for the Graphics  :)

OK , i'm the friend of CHRIS :)

See attached file

for config.plist - kexts 10.13 clover - kexts in S/L/E 

for wifi i use a usb key GO-USB-N150

my laptop is an ACER ASPIRE 5733 

good hack  :thumbsup_anim:

ACER ARRANDALE .zip

Share this post


Link to post
Share on other sites

OK , i'm the friend of CHRIS :)

See attached file

for config.plist - kexts 10.13 clover - kexts in S/L/E 

for wifi i use a usb key GO-USB-N150

my laptop is an ACER ASPIRE 5733 

good hack  :thumbsup_anim:

Thank you @arcade33  :)

May be This Wifi  working for her Laptop ?

Acer Atheros AR5B193

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPower50
      Hi, I want to install MacOS Catalina on my laptop.
      I was installed MacOS Mojave previously but i had a lot of problem, for example my wifi's card (Dell DW1820A) had a problem: My pc sometimes doesn't boot up or pc after some minutes crashed or slowed. 
      Now i want to try again to install macOS.
       
      this is my spec: 
      HP 15-AY034NL 
      CPU: i7 6500U  with HD520
      SSD: 500GB SSD Samsung
      Wifi & Bluetooth: Dell DW1820A (Bluetooth: BCM2045A0) (Wifi: BCM94350ZAE)
      USB 3.0 
      Ethernet: Realtek 8100
       
      Attached in this thread, my old clover configuration created by me (CLOVER OLD) and clover with Wifi driver (CLOVER) created by Hervè (I had asked help at insanelymac's community)
       
      P.S SORRY FOR MY BAD ENGLISH.
      Thanks in advance 
      -ANTONIO
      CLOVER OLD.zip
      CLOVER.zip
    • By Slice
      I successfully installed macOS 10.11.6 and Windows 7 Pro SP1 in UEFI mode on the laptop.
      I know, there are detailed guides here and on osxlatitude.com but I was not agree with them and carefully check and test every step to tune my Mac.
       
      Hardware
      Intel® Core� i5-3320M CPU @ 2.60GHz, speedstep works with Clover default settings
      Chipset Intel 7 series, no patches needed
      Video: IntelHD4000 or NVS5200M switchable in BIOS, work in both cases
      LAN; Intel 82579LM, works with IntelMausiEthernet.kext v2.2.1
      Audio: IDT 92HD93BXX, works with VoodooHDA 2.9.0.
      SDHC reader O2Micro; works with native AppleSDHC.kext with Clover Arbitrary properties.
      USB3.0 works natively if not disabled in DSDT
      PS2 keyboard and touchpad works with VoodooPS2.
      WiFi: Dell Intel WiFi was replaced by Dell DW1520, Broadcom BCM943224HMS. DeviceID=4353
      LCD Screen 1366x768
      BIOS A12. Initially was A02. Then I flashed A23 and found it is quite bad. The screen is full of artefacts. Flash A12 and all is OK. Not tested other versions.
      For some reason BIOS can switched from Intel to Nvidia by itself so I have to do my solution working independent on this state.
       
      WiFi
      It is not working OOB although it has DeviceID known to Apple. The reason is WhiteList in the driver.
      I set MacModel as MacBookPro10,1 while the WiFi will work on MacBookAir. I make a patch in Clover.
      As well a patch for channels.
      I deleted a kext Brcm4331 because it has the same DeviceID. Let kext Brcm4360 to work alone.
       
      VideoCards
      In Bios we can set Optimus = Enable/Disable
      If Enable then we have two videocards Intel first and Nvidia second. In this case additional SSDT-3.aml will switch off Nvidia.
      If Disable then we have only Nvidia card. It will work if Board-ID taken from iMac13,2.
      But here there is contradiction with WiFi with required Board-ID from MacBookAir.
      So I take MacModel as MacBookPro10,1 which is most close by CPU IvyBridge.
      Set BoardID like iMac13,2 to make Nvidia working.
      Patch BoardID in Brcm4360 to make WiFi working.
      Now I have
      Inject->
      ->Intel=YES
      ->Nvidia=YES
      and SSDT-3.aml in ACPI\patched folder. This SSDT will switch off Nvidia if Intel card ON.
      For Intel graphics there is a patch against 8 apples at start.
      This Nvidia 5200 is Fermi and works in ElCapitan.
       
      Brightness
      No special kexts.
      The brightness controlled by keys F1,F2 and slider in Control Panel in both case Intel or Nvidia. Details here  #72 
       
      DSDT and SSDT
      This is very long story and finally I have working sleep in both cases Intel or Nvidia.
       
      Sensors
      I use my HWSensors3 with FakeSMC 3.5.2.
      I got monitoring:
      CPU temperature
      GPU temperature
      GPU main frequency
      GPU shader frequency
      Battery state % full, time to charged or time to empty.
      Battery voltage dinamically.
      Battery amperage dynamically. I can see it changes on heavy games.
      HDD temperature.

       
      Audio
      I like VoodooHDA and have no problems with it.
      The sound is clear, loud, and switchable between internal speaker and headphone.
      Mic is working.
       
      Bluetooth
      Just tested with BTFirmwareUpdate.kext and it works in 10.11.6. I not needed it so switched off by wireless switch at right side.
      For 10.13.6 there is other kext BRCMInjector.
       
      Keyboard, Touchpad and Touchstick
      Post #14
      I made my fork of the VoodooPS2 driver, take here sources and release version
      https://github.com/SergeySlice/VoodooPS2-for-ALPS
       
      My config, ACPI files and kexts are in attachment.
      05.12.2017
      EFI.7z
       
      EDITED:
      Better DSDT in the post #6.
      Sleep working even when AC inserted.
       
      EDITED 06.12.2018
      Now I have HighSierra and this is my EFI folder. Note, HighSierra is possible only with Intel graphics (Optimus is enabled in BIOS)
       

       
       
      Welcome to discussion!
      EFI-E6430.7z
      BRCMInjector.kext.zip
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×