Jump to content
Sign in to follow this  
Followers 0
Morea

Can't get to installer on AMD E-450 APU

2 posts in this topic

Recommended Posts

Hi everybody! I need some help today: I’m trying to install Mac OS Sierra 10.12.5 on my friend’s laptop, which is an Acer Aspire 5250, but that’s quite a difficult task because it’s an AMD CPU. The model is AMD E-450 APU with Radeon HD Graphics (graphics model Radeon HD 6320). I need some help because I can’t boot the installer, when I select my USB from Clover, after the row of pluses in verbose mode instead of showing me all the booting commands it stucks on a black screen and the screen starts flickering along with a continuous beep sound and so I’m unable to get to the installer. Do I need a patched kernel or something else? Are you able to give me some help? Thanks!

Share this post


Link to post
Share on other sites
Advertisement

Do I need a patched kernel or something else? Are you able to give me some help?

For the first question: surely, as macOS won't run on AMD cpus OOB. For the second: no, as i don't have any AMD pc.

The real problem is that i don't think sierra will run smoothly on such pc. The cpu is very "basic", so it might be difficult to find patched kernels.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By macinsane
      Mojave (and maybe High Sierra 10.13.6) on Asrock H370M-ITX/ac and getting RX560 to work with Intel graphics for full hardware acceleration
       
      Components used:
       
      Core i7 8700, UHD 630
      Gigabyte Radeon RX560
      Wifi/BT BCM943602BAED (DW1830) M.2
      Samsung PM961 NVMe SSD
       
      *This guide requires you to know the basics, meaning how to create a macOS install drive, installing and using Clover. There are great beginners guides out there! As always you need at least FakeSMC to boot, every other kext I’ve used is mentioned in the guide. For Mojave beta you need to be enlisted with your Apple-ID in Apple’s beta programme. What is described here may work for High Sierra 10.13.6, but I doubt it to be reliable. Even in early beta status (PB3) Mojave runs much more stable and smoother than High Sierra ever did for me.* 
       
      UEFI-BIOS settings:
       
      The board comes with BIOS version 1.20, there is an update 1.50 on the Asrock website. Usually it is good to stay updated but in this case I’ll recommend to stay on 1.20, because the 1.50 version seems to be unstable and I had restarts upon wake and things like that I couldn’t get fixed even with dsdt patches. So I just downgraded to 1.20 which runs fine.
      Settings needed: Just the usual. Disable fast boot and security boot (everything Windows-related), disable vt-d and enable XHCI hand-off. Activate multi monitor support and set VRAM to 64MB to activate the Intel IGPU. From what I’ve read most people recommend 128MB but I find the 64MB setting to be more reliable, getting artifacts with settings below or above 64MB. 128MB may be needed for 4k support, though. As for nVidia users: You may have to disable the Intel graphics. I’m using an AMD card and that is the brand to go these days since Apple decided to work with AMD
       
      Clover and power management:
       
      I recommend upgrading to 4586. It seems that Aptiomemoryfix is now working with H370 chipsets. I stayed on OsxAptiomemoryfix2 together with Emuvariable and it works. Feel free to experiment.  
      For power management with your CoffeeLake cpu you can just tick plugin type within Clover or compile a ssdt with Pikeralphas script. Mojave reports my cpu correctly as Core i7 since PB3, before that it is just “Unknown” but that is just cosmetic. 
       
      Graphics:
       
      This is the worst part. Getting the Radeon to run correctly alongside the Intel graphics took me weeks to figure out. 
       
      While RX570 and 580 run out of the box in most cases, the RX560 models often do not or at least not correctly. Apple even banned them from eGPU use. For my approach you cannot use “Whatevergreen.kext”, it simply didn’t work for me the way I needed it. Instead I added some fixes to my DSDT to set the correct number of ports used (DP, HDMI, DVI) and tell macOS to use the correct frambuffer. For those who are not into dsdt editing I added my DSDT, look at the “PEGP” section how it is done. This works for the RX560 using the “Acre” framebuffer, you can replace it with “Radeon”, that works too. Other cards need a different framebuffer and a different number of ports. You can do it!   BTW: Do not buy this Gigabytecard!!! It has some weird VBIOS on it, which caused me nightmares before I got the card to work! Buy a Sapphire card instead, they are used by Apple too.   
       
      To get full hardware acceleration for encoding videos you have to have the Intel graphics enabled alongside your AMD card. Problem is, you cannot have it running simply as a second graphics card but you’ll need to “hide” it, means telling macOS that it doesn’t have any display connectors. Otherwise you’ll have screen artifacts or in the worst case just constant crashes. This can be done by adding a certain ig-platform-id in Clover. If you use 59120003 the Intel graphics will not show up in system profiler but it is there. You can check it with iStats or HWMonitor or look if the Kaby Lake graphics kexts are loaded.  This ID makes the CoffeeLake UHD 630 to be recognized as a Kaby Lake gpu that has no display ports, is just used as a helper card.
       
      You’ll need it as a helper card for video encoding. That is what Intel graphics are used for in Macs, to support video encoding on the hardware side. You can check if hardware encoding is supposedly enabled by using MacX Video Converter Pro and VDADecoderChecker. If both say “yes” and “fully supported” this is a good start. But despite the widespread belief this doesn’t mean everything is set correctly! You now have to find out, how to get both cards working together. This is the moment where you have to choose between work and fun: Are you using FinalCut Pro for video editing or are you planning to use iTunes for entertainment? Up until this day (Mojave PB3, High Sierra 10.13.6) you cannot have both working correctly! I’ll show you how it is done both ways. 
       
      The best settings for Final Cut:
       
      Use the DSDT I’ve added with the respective AMD settings for the RX560 or modify them for your graphics card.
       
      Use SMBIOS for iMac17,1 (14,2 does work but picture over DP port is ugly, iMac 18,1/2/3 do not work) in Clover.
       
      Have AppleIntelKBLGraphicsFramebufferInjector_3e9x.kextin your Clover/kexts/Other folder.
       
      Until Mojave PB2 (may work on High Sierra 10.13.6):
       
      Fake-ID 3E928086 plus ig-platform-id 59120003
       
      These are the correct setting when installing Mojave (usually you will start with PB1 as the full installer).
       
      For Mojave PB3 and higher:
       
      Fake-ID 59128086 plus ig-platform-id 59120003
       
      After upgrading to PB3 you will get a black screen with 3E92 fake id because PB3 introduces Coffee Lake kexts and macOS will use these kexts instead but that doesn’t work with our ig-platform-id. So you can download the update to PB3 but before installing it you’ll need to change the fake-id to a usual Kaby Lake id. While this didn’t work in High Sierra and the first two Mojave betas (meaning you didn’t get full hardware encoding) it is now magically working with PB3. It is safe to remove AppleIntelKBLGraphicsFramebufferInjector_3e9x.kext after upgrading to PB3.
       
      The best setting for iTunes and why it is the worstfor Final Cut:
      Just do the same thing as for FinalCut, put Shiki.kext into your Clover/kexts/other folder and add -shikigva boot argument. You can use -shikigva=1 or 2 or 12 it will work either way. Now you can watch movies with iTunes, yay! But it has some sideeffects. You cannot use this setting when seriously editing with Final Cut.
       
      While this works by tricking macOS to use the IntelGraphics to play protected video content, it doesn’t seem to be the way real Macs are doing this. As soon as you open FinalCut you will notice (check this with iStats or HWMonitor) that the Intel graphics is not or only barely utilized, instead cpu usage skyrockets, indicating that slow software rendering is used instead of hardware encoding through Intel graphics. To make it worse the Radeon still “thinks” there is an Intel graphics helping so it does not run at highest potential. You may never notice it when using HD material with 24 or 25p because it still fast enough for that. But 50p or 4k material will most likely cause stuttering. I was astonished when I had stutters while previewing my 50p material, impossible to watch it. Thinking: What is wrong? I have a freaking i7 8700 plus RX560! Even my old hackbook with HD4000 is doing better!     
       
      Wifi and Bluetooth
       
      I swapped the Intel Wifi card that was coming with the mainboard plugged into the onboard M.2 port with a compatible Dell card. The DW1830 or BCM943602BAED. The wifi part runs out of the box, but if you want the card to appear as Apple AirportExtreme and set the country code according to your country you need to put FakePCIID_Broadcom_WiFi.kext into Clover/kexts/other and add some Clover kext-to-patches by PMHeart. 
       
      Name: com.apple.driver.AirPort.BrcmNIC
      Find: 75166644 3BA3581A 0000750C 4183FE04 7406
      Replace: 66906644 3BA3581A 00006690 4183FE04 6690
      Comment: AirPortBrcmNIC - PCIe in 10.13.x
       
      Name: com.apple.driver.AirPort.BrcmNIC
      Find: 4183FCFF 7435488D 55D0
      Replace: 66C70644 45EB348D 55D0    (*this is for DE country code, change for your need)
      Comment: BCM4352-Country Code 
       
      Bluetooth will work thanks to Rehabman’s kexts. You’ll need BrcmPatchRAM2.kext and BrcmFirmwareData.kext OR BrcmFirmwareRepo.kext. The Data.kext can be injected through Clover, just throw it into the kexts/other folder, the Repo.kext has to be installed in /Library/Extensions on your mac drive, it won’t work with Clover. I had issues with the Data.kext, Bluetooth was gone on every second or third reboot. The Repo.kext is more reliable, haven’t had any issues yet. I really don’t like the kexts to be installed in my system but I guess I have to live with it for the time being.
       
      Oh, handoff and continuity don’t work, doesn’t matter that system profiler shows them as enabled. At least it works in one way: the mac can handoff Safari pages to my iPhone, but not the other way around. Documents opened on my phone show up in the dock, but they are not loaded. 
      This issue is around since at least High Sierra and from what I’ve read Rehabman is not going to fix this, because he founds this features not worth it. I have to disagree, these are very convenient and valuable features if you work with desktop, laptop and tablet in different situations, I miss this capability very much!    
       
      Audio
       
      Audio works with Lilu.kext plus AppleALC.kext and you need to inject Layout ID=1 in Clover. For Mojave use the boot setting -lilubetaall to force the kexts to load. If you like to have DP or HDMI audio add a HDAU device to your dsdt (see mine for reference).
       
      Credits:
      Credits go to this great community! I hope I mentioned everyone in this guide whose insights made this hack possible. If I have forgotten someone please let me know!
      DSDT.aml.zip
    • By GalaxymaxiS
      Buongiorno Forum Italiano (????)
       
      Sono nuovo negli hackintosh, non so bene ancora come Funziona il tutto, ma mi serve il vostro supporto, 
       
      Premessa:  Conosco già il fatto che: L'Aspire One D255e non ha i Kexts del Wi-Fi e della Scehda video*
      (o nel caso con gli anni abbiano fatto i Kexts, vorrei avere i link se ci sono XD)
       
      In sostanza vorrei sapere se ci sono dei Kexts da installare dei seguenti pezzi hardware:
       

      Vi ringrazio in anticipo per il supporto che mi date, 
       
      Con amore,
      Utente Disperato ♥
      (Tocco di stupidaggine ci sta sempre xd)
       
      Se serve qualche Log o cose simili, basta chiedere
    • By Fernando Castro
      In this Guide I will explain step by step how to install Mac OSX High Sierra 10.13.5
      over an Acer Aspire E1-572-53GN.
       
      1st: Get a copy of Niresh High Sierra on Hackintosh Zone
      Create an USB with the DMG file.
      You will get BOOTLOADER partion
      And High Sierra Installer partition
      Use Disk Utility to restore those partitions over an 16Gb USB Pen Drive
      Use this config.plist provided in this Tutorial and put in /EFI/CLOVER partition of your USB
      After create these USB with Niresh, boot your Laptop
       
      Install High Sierra.
      After installation boot with this Pen Drive Again and do in terminal this
      dd if=/dev/disk*s1 (your pen drive) of=/dev/disk0s1 bs=4m
      Reboot
      Load MacOS High Sierra from Clover
       
      You are done.
       
      Now you has an Acer Aspire with High Sierra 10.13
      Apple Store
      Update
      10.13.5
       
      Let the system do it for you.
       
      Install Voodoohda 2.9.0 v12
       
      My Acer Aspire I had changed the LCD with an 1920x1080p Full HD
      I´m using an WN725n V3 USB Wi-Fi
      Install the driver for Wi-fi from the TP-Link Web Site
       
      Now you are done!
       
      Enjoy!
       
       
      config.plist
    • By rio2
      How to make AppleHDAController load on Ryzen boards?
      Rename(/add) your audio controller to your DSDT/SSDT as HDEF Add a _DSM method to your HDEF device with layout id 1 Patch the AppleHDAController binary, because it has a static table containing the supported PCI Vendor/DeviceID pairs and it also checks the VendorID against known values. As an example I provide a dif file and patched 10.13.3 binary, but if you want to I can patch the binary for other versions.  
      After AppleHDAController loads to actually get sound working you need to patch AppleHDA.kext for the codec on your board. First I tried to use Lilu+AppleALC for this task, but for some reason it refused to work. (I might look into it later why) But for the time being it was easier to use toleda's cloverALC script for that, but to make it work I had to change(/remove) the specified location of the HDEF device from the script. And for some reason it also required me to mount the EFI partition manually.
       
      Change this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF@1") != 0 ]]; then Into this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF") != 0 ]]; then  
      AppleHDAController_Patched10.13.3
      AppleHDAController-10.13.3-AMD.bdiff
    • By Teress
      Hi, I tried during last 4 days almost everything but now I call for help. I have RX560 running on 10.13.4. Previously I was running it on 10.12.6 and had the same problem, but after waking from sleep my thiord display came to life, but it is not working anymore on 10.13.4. Without or with Lilu & Whatewergreen my system correctly recognize my gpu as RX560 but only 2 of 3 displays are displaying content, third display is black but recieving some signal. When I change cabling and connect only two, any combination of 2 displays is working. System profiller and system preferences are sayin I have 3 displays connected.

      Please can somebody help me to figure it out?
      Thanks a lot in advance. Tried to upload my ioreg but it is greater than 10MB allowed for me :(



×