Jump to content

Geforce GT610 works in High Sierra


24 posts in this topic

Recommended Posts

Hi everyone, sorry for my English, finally the geforce GT 610 works with High Sierra, the attached kexts apply the fixes at shutdown, restart, and mouse pointer.
Unfortunately, there are still problems, the system crashes if you set non-standard resolutions, if you turn on the screen saver and log out.
Tested with Asus GT610, High Sierra 17A360a, Clover 4189 and smbios iMac14.2.
Copy kext to System / Library / Extensions.

post-493104-0-63621400-1504782508_thumb.jpg

GT610 High Sierra Fix.zip

  • Like 6
  • 2 weeks later...
  • 2 weeks later...

Hi m1g2,

 

i use a Zotac GeForce GT 610 2048 MB which works perfect with El Capitan 10.11.6 (15G1611). Symbios is an iMac14,1 (21.5-inch, Late 2013), it is an older Core 2 Duo machine.
Unfortunately I could not update to High Sierra using your kext, I always get a black screen instead of log in screen ... I use Clover_v2.4k_r4220. Which configuration did you use in Clover config.plist?

Thanks, O.S.

Hi m1g2,

 

i use a Zotac GeForce GT 610 2048 MB which works perfect with El Capitan 10.11.6 (15G1611). Symbios is an iMac14,1 (21.5-inch, Late 2013), it is an older Core 2 Duo machine.

Unfortunately I could not update to High Sierra using your kext, I always get a black screen instead of log in screen ... I use Clover_v2.4k_r4220. Which configuration did you use in Clover config.plist?

 

Thanks, O.S.

 

Use this kext with lilu.kext in clover-kext 10.13 https://sourceforge.net/projects/nvidiagraphicsfixup/   

  • Like 3
  • 2 weeks later...
  • 5 weeks later...

hello, I have disabled sleep at the moment

Is your gt 610 working perfectly on High Sierra without freezing the system sometimes?

I'm using lilu.kext 1.2.0 and NvidiaGraphicsFixup.kext, but sometimes the system freezes. I put your NVDAResman.kext to solve the problem of the mouse, but it continued the same way (the problem of the mouse is less). Did you have to do something not to freeze the system?

At the moment my system is very stable, I recommend not to use lilu.kext 1.2.0 and NvidiaGraphicsFixup.kext, use updated clover with smbios imac 14.2, you must disable screen saver, sleep and night shift and never set resolutions not standard

  • Like 1

Thank You so Much for This!

 

It works for me with a GeForce GT610.  Got it working on a 9 year old computer Q9550 processor.  Things that do not work correctly are the same as noted by the OP.  Sleep and changing screen resolutions.  I'm not a gamer, so screen resolution will always be native.  As for Sleep, I will do the same as the OP, which is... don't put computer to sleep.

  • 1 month later...

Hi,

 

I'm struggling for a few weeks now to install High Sierra. I was running Sierra with my MSI NVidia GT 610 with no issue on my two screens. Now, I'm only able to start HS using the VESA mode, which prevents me for using properly HS as you can imagine.
 
I'm going to run another test using only the ZIP from m1g2 without doing anything else.
 
I plan to run the test with my config.plist (which is working perflectly for Sierra), keeping the clover folder 10.13 empty and Other with FakeSMC. I have iMac 14.2 in the SMBIOS and I'm running Clover 4359.
 
... I keep you posted with the outcome of the test...

Well, it's the very first time I boot HS with no issue.

 

The outcome is the following: the video is working, but it seems the full capabilities of the NVidia GT 610 are not recognized: no second screen, 1 st screen not fully recognized, and very poor GPU capabilities...

 

I guess it's the only way to run HS...

 

Well, a few tests shows this is the behaviour of the VESA mode. So nothing allows me to keep this configuration alive any longer.

 

Anyways, thanks for all so far.

  • 3 weeks later...

Hi everyone, sorry for my English, finally the geforce GT 610 works with High Sierra, the attached kexts apply the fixes at shutdown, restart, and mouse pointer.

Unfortunately, there are still problems, the system crashes if you set non-standard resolutions, if you turn on the screen saver and log out.

Tested with Asus GT610, High Sierra 17A360a, Clover 4189 and smbios iMac14.2.

Copy kext to System / Library / Extensions.

attachicon.gifScatto.jpg

Hello m1g2, can you help me with the settings that you used to make the graphics card work?
 
I downloaded your kext, but nothing happened.
 
My specification:
Core i7 3.99 Ghtz
Motherboard: Gigabyte GA-H61M-S1
RAM memory: 12 GB
Graphic card: EVGA Geforce GT 610 2 GB
 
Please, thank you very much
  • 2 weeks later...

Hi the GT610 also works with SMBios 12.x, 13.x ....

Add to Kext https://sourceforge.net/projects/nvidiagraphicsfixup/+ https://github.com/vit9696/Lilu/releases.  Just tick nvidia in clover drivers are natives, resolution FullHD only problem restart after sleep.........

Using HDMI cable, checking the ADDHDMI in clover also activates HDMI audio

config.plist.zip

  • 5 months later...

Back in January, I got this working with 10.13.1 using the modified NVDAResman.kext linked by the OP.  System worked perfectly and have full graphics accelaration.

 

So downloaded the 10.13.5 combo update and ran it.  It correctly updated my system to 10.13.5.  It boots up but freezes once the loading bar is at 100%.  I ran it in verbose to check the messages.  Nothing stood out.  No kernel panic.  So uninstalled NVDAResman.kext.  This time it booted, but only one screen and no accelerated graphics.  I then added the NVDAResman.kext to EFI/Clover/Kexts/Other.  Rebooted... and again single screen, no graphics accelaration.  I then moved the NVDAResman.kext to S/L/E... rebooted and voila... both monitors lit up, dual screen, and now have full acceleration.

 

I have a very old system.  Too cheap to update.  This system is quick enough for me.  I have no problems running Xcode on it and using it for iphone and android development.

 

Q9550

GA-G31M-ES2L (rev. 1.x)

EVGA GeForce GT 610

4 G DDR2

SSD and HHD

Two 24 inch monitors.

 

A big thanks to the OP.

  • 3 months later...

Plz... Upload your NVDAResman.kext

On 7/12/2018 at 11:45 PM, manOhman said:

Back in January, I got this working with 10.13.1 using the modified NVDAResman.kext linked by the OP.  System worked perfectly and have full graphics accelaration.

 

So downloaded the 10.13.5 combo update and ran it.  It correctly updated my system to 10.13.5.  It boots up but freezes once the loading bar is at 100%.  I ran it in verbose to check the messages.  Nothing stood out.  No kernel panic.  So uninstalled NVDAResman.kext.  This time it booted, but only one screen and no accelerated graphics.  I then added the NVDAResman.kext to EFI/Clover/Kexts/Other.  Rebooted... and again single screen, no graphics accelaration.  I then moved the NVDAResman.kext to S/L/E... rebooted and voila... both monitors lit up, dual screen, and now have full acceleration.

 

I have a very old system.  Too cheap to update.  This system is quick enough for me.  I have no problems running Xcode on it and using it for iphone and android development.

 

Q9550

GA-G31M-ES2L (rev. 1.x)

EVGA GeForce GT 610

4 G DDR2

SSD and HHD

Two 24 inch monitors.

 

A big thanks to the OP.

Plz.... Upload your NVDAResman.kext

  • 3 weeks later...

I run High Sierra 10.13.6 with full vanilla nVidia kexts and iMac10,1 SMBIOS on my old C2D E8600 desktop fitted with a Twintech GT610 2GB (Fermi GF119). I've got full graphics acceleration and had no need to use any modded NVDAResman kext at all. I've also installed the nVidia WebDriver but cannot see any difference between running on it or the macOS drivers.

 

I run Clover r4769 and just have to set:

  • Inject nVidia
  • nVidia Single (system reboots otherwise)

 

Of course, the same old problems as mentioned before remain:

  • changing resolution or modifying some graphics related settings freezes the system
  • no proper wake from sleep, system has to be restarted
  • calling on the screen saver freezes the system (display sleep/display wake is Ok though)
  • mouse pointer disappears unless set to max size
  • etc.
  • etc.

 

Edited by Hervé
  • 4 weeks later...
On 1/27/2018 at 9:28 PM, m1g2 said:

Hello, I can confirm that it works with High Sierra 10.13.3, use clover 4392,
enable in clover Inject nvidia true, use smbios imac 14.2 and install the attached kext,
I also attach my clover config.plist if you want to try it

config.plist.zip

NVDAResman.kext.zip

post-493104-0-99726400-1517059694_thumb.png

Thanks m1g2 for the workaround. I use the NVDAResman.kext and it works in High Sierra 10.13.3 with my Asus GT610 2GB silent version gfx. I use Clover r4428, InjectNVidia & SMBios iMac 14,2 in clover setting. I noticed a few problem same as above with addition;

 

1. Cannot change standard resolution (Freeze)

2. Cannot restart (Freeze/stuck at black screen)

3. Wake up from turned off display & sleep. (Freeze)

 

My hackintosh build:

1. ASRock H61M-VS R2.0

2. 6GB 1333MHz DDR3 RAM

3. ASUS nVidia GT610 2GB Silent

4. 250GB HDD

20181222_040807.jpg

Edited by Insanelymacnong

Yup. Unless you can live with these limitations & defects, you have no choice but replace Fermi-based GT610 by a fully supported graphics card. If you seek a similar low-end model, you may consider a cheap Kepler GT710, GT720 or GT730 (DDR3 64bit or DDR5) which have the added benefits of being supported in Mojave too. Those models works 100% OOB.

 

To give you a practical example:

  1. bought my Fermi GT610 for ~40€ in 2013 to run Mountain Lion
  2. sold it 29€ in 2018 due to poor support in High Sierra
  3. bought a Kepler GT730 DDR5 for 40€ instead

 

At some point, common sense has to prevail...

 

Edited by Hervé
  • 3 months later...

Guys, I have to remind that Nvidia 610,630,710 and 730 can be two families, Fermi or Kepler.

No sense to speak about kexts and trick until you know exactly your card family. See Clover boot-log for example.

If this is a Kepler then you can install any system including Mojave.

If this is a Fermi then 10.11.6 is your last chance no matter what you do.

×
×
  • Create New...