Jump to content
Sign in to follow this  
Followers 0
Mr Rager

Intel HD 620 sem QE/CI

6 posts in this topic

Recommended Posts

Opa galera, boa noite! Beleza? 
Então.. vou tentar ser o mais explicativo possível.
Fiz a instalação, e o sistema mostra que é a Intel HD 620, porém, estou sem aceleração, e mostra apenas 7MB.
Estou utilizando o plist do Rehab, que se encontra no repositório dele.

gHgc0v0.png

E eu só consigo iniciar o sistema, caso eu utilize uma invalid ig-platform-id inválida, como por exemplo: 0x12345678.
Caso eu utilize a 
ig-platform-id 0x19160000, tenho o erro a seguir:

NclxUEu.jpg

Pesquisando, vi que isso é relacionado a um problema de DVMT, que está em 32MB, e é necessário 64MB pelo que eu entendi.
Na minha BIOS, existe uma opção que CREIO que seja relacionado a isso, porém, se eu seto 32, 64 ou 128 o mesmo erro continua a aparecer.. PORÉM, se eu desabilito essa opção, mostra o erro a seguir:


SFVsaKq.jpg




I748mq7.jpg



Alguém poderia me dar um help com isso?
Minha pasta EFI segue em anexo, caso alguém queira tirar um tempinho para dar uma olhada.
Lembrando que: As kexts FAKEPCIID e FakePCIID_Intel_HD_Graphics estão em S/L/E.

Agradeço desde já!

EFI.zip

Share this post


Link to post
Share on other sites
Advertisement

Primeiro passo, usar o correto smbios

CLOVER.zip

 

se o seu notebook desfrutar da tecnologia optimus e vc não tem como desativar, vc precisa desativar a nvidia via dsdt ou ssdt

Share this post


Link to post
Share on other sites

Primeiro passo, usar o correto smbios

attachicon.gifCLOVER.zip

 

se o seu notebook desfrutar da tecnologia optimus e vc não tem como desativar, vc precisa desativar a nvidia via dsdt ou ssdt

 

 

Erro: This version of Mac OS X is not supported on this plataform.

Quanto a Nvidia, já está desabilitada 

 

Share this post


Link to post
Share on other sites

volte o smbios pro mbp11

eu mudei pra mbp13,1, só vai funcionar nas últimas versões do sierra

 

como vc desativou a nvidia?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By 16BitHusky
      Hello,
       am running sierra on a optiplex 780 with a pny gt 710. I followed a step by step guide here. My machine boots fine and actually shows that the pny 710 is recognized I have attached a link with proof. My issue is when I am doing anything that relates to video it artifacts and slows alot. I understand that this is a cheap graphics card but from what I read online it seems like the other hackintoshes dont have this issue with this card. I am wondering if you have had any similar problems or solutions to this. I  also have attached my config file. I asked around on reddit and they said this could be related to the qe/ci. I am pretty new at this so I don't know how to enable this. I have installed the web drivers for 10.12.6 and that hasnt changed anything. 
    • By Sekkio
      Hello, I've successfully installed macOS Sierra (10.12.5) on my Lenovo Thinkpad x220i (2011).
      I followed the x220 mcdonnelltech guide which I had to remove AppleIntelHD3000GraphicsGLDriver.bundle kext as it prevented the os from booting up. Everything is working fine except the brightness (which I fixed via the guide) and QE/CI is not working.
      The dock is not transparent and images are failing to load in screensaver and I'm experiencing lags/delay in launchpad.
      I'm using all of the stock Intel graphics kexts except AppleIntelHD3000GraphicsGLDriver.bundle.
       
      How do I enable full QE/CI acceleration in Intel HD 3̶0̶0̶0̶?
      I believe that it could be achieved if I manage to get AppleIntelHD3000GraphicsGLDriver.bundle working but, I absolutely have no idea how (It shows white apple logo with a loading bar that is stuck on 0%, verbose mode shows nothing related to the problem. ).
      I also tried various patched Intel graphics kext which had no effects .
      The problem may lie in the config.plist, dsdt or the bios setting.
       
      My Specs:
      Intel HD 3̶0̶0̶0̶ Graphics 384mb
      Vendor: Intel (0x08086)
      Device ID: 0x0116
      Revision ID: 0x0009
      Resolution: 1366 x 768
      Intel® Celeron® CPU 847 @ 1.10GHz
      smbios: MacBook Pro 8,1
      clover: config.plist and dsdt are from the mcdonnelltech guide
       
      Any help would be really appreciated!
       
      Update: I do not have Intel he 3000, I have Intel HD instead. I will be trying to create my own working dsdt, thank you for the clarification.
    • By oliveiro
      I have an almost fully working Intel HD Graphics in ElCapitan.
      At least QE & CI are working. I had graphic glitches in Dock background and windows titles, apparently due to my MBP9.2 SmBios (which I want to keep for Power Management reasons)

      It's on an Asus Laptop (F301A-RX229H) with an Intel Pentium Mobile 2020M, which includes an Intel HD Graphics, not labelled 2500, but it has 6 execution Units like the 2500 series, and approximately same clock settings (650-1100) instead of 650-1150 for HD2500. You can check specs here and here. It seems like it's a lower end HD2500.

      Vendor ID 8086 of course, Device ID 0156, rev 0009.
      I use chameleon with GraphicsEnabler=Yes, GraphicsMode=1366x768x32, IntelCapriFB=3
      (with Moutain Lion, previous setup on the same laptop, with QE/CI too, required IGPlatformID=01660003)
      I have vanilla AGPM and IntelGraphics kexts, SmBios MacBookPro 9.2, as mentionned before, and a custom DSDT, device is named GFX0.

      Graphic Glitches were solved (accordingly to real macbookpro users forums) by reducing transparency in Accessibility Preferences Panel.

      Hope it helps.
    • By fantomas
      ------------------------
      Update - 06.15.2016
      ------------------------
       
      A minor update of this topic - Clover (r3561) patch on the fly works fine with macOS 10.12 Sierra.
       
       
       

       
      ------------------------
      Update - 08.18.2015
      ------------------------
       
      ok
       
      with Download-Fritz help, I’m finally able to patch my kexts with new method.
       

       
      it works fine with Clover r3259 + DB6
       
      but in my case, I still have to use FakeSMC trick... I tried with ForceKextsToLoad feature but it didn’t work... not yet.
       

      ------------------------
      Update - 08.17.2015
      ------------------------
       
      Hi there!  
       
      almost a year later, I'm about to update this topic, not because I was too lazy to do it but just because the "patch on the fly" method  has a little bit changed since Clover r3154  and which I was not able to make work.
       
      not really happy with being unable to use this method, I decided to do some tests with older versions of OS X and Clover... Bla bla bla... bla bla Bla...
       

       
       
       
      ... as I expected, the old method still work... and it works fine with ElCapitan DB1  
       

       
       
        I even was able to install ElCapitan with Clover r2850 and boot well on it         but to have success with it, the most effective trick for now is to inject the details of my kexts (AMD5000Controller.kext and AMDRadeonX3000.kext) inside the FakeSMC Info.plist as additional IOKitPersonalities. With this trick, my kexts are always loaded.
        with the standard loading method, the patch doesn't work      
       
       
       

       
      ------------------------
      Update - 03.28.2014
      ------------------------
       
      just to tell that since Mavericks, we need no more those 3 kexts, only 2 of them (AMD5000Controller.kext and AMDRadeonX3000.kext) to enable QE_CI for HD6770 cards
       
      even if you use those 3 kexts, AMD6000Controller.kext will not be loaded
       

       
      to do this with chameleon, use GraphicsEnabler=Yes and edit 0x68B81002 -> 068BA1002 in both kexts
       
      if you want to do this with clover, use clover configurator and KernelAndKextPatches tweak:
       

       
      don't forget to put 'Inject Kexts' to 'Yes'
       

       
      if it does not work, it is because the kexts are not presents in kernel cache. 
       
      The most effective trick for now is to inject the details of your kexts inside the FakeSMC Info.plist as additional IOKitPersonalities. With this trick, your kexts will be always loaded.
       
      I did it with QE_CI Exotic patch for HD48xx series cards with my old HD4830 and it works!
       
      see here for more details: http://www.insanelymac.com/forum/topic/296949-tuto-qe-ci-exotic-patch-via-clover/
       
      p.s:
       
      here, more screens
       

       

       
       
      Method 3: if you're using Clover, you can make this card work with a Fake ID injection
      <key>Devices</key> <dict>         <key>FakeID</key>         <dict>             <key>ATI</key>             <string>0x68B81002</string>         </dict> </dict>
       
      Method 2: since OS X 10.8, you no longer have to edit those kexts, just inject your ID via dsdt: http://www.insanelymac.com/forum/topic/282687-radeon-hd-6770-full-qeci-mountain-lion/?p=1902721 (credits go to RampageDev)
       
      *This method also works very well with OS X Mavericks         Method 1: i can confirm it, with the last Chameleon-2.1svn-r2054.pkg, it work well on 10.8.2 Build 12C43 !!!

      No more need to flashing HD 6770 into HD 5770 to have QE/CI !!!

      So just add your ID (0x68BA1002) into ATI5000Controller.kext and AMDRadeonAccelerator.kext
       
      <key>AMDJuniperGraphicsAccelerator</key> <dict> * * * <key>IOPCIMatch</key> <string>0x68BA1002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002</string>
       
       
       
       
      * the story started with this original topic
    • By Nikita123
      Hi everyone,

      I have been trying for a while now to install Mac OS X El capitan 10.11.4 on the Sony Vaio VPCEB1M1E with limited succes.
       
      I am using Clover (latest version)
      The biggest problem is no LVDS detected and the notebook has a blackscreen as soon as OS X starts.

      I have created several config files, and if I disable Inject ATI i can login to the system without QE/CI. Wi-Fi works, AR9285.

      So I installed teamviewer, reboot, enable ATI config, got blackscreen, but logged in with teamviewer and QE/CI is working. I created an IOREG this way with IORegistryExplorer 2.1 and I have also attached my entire EFI partition, all unpatched ACPI tables are included. I think the problem is wrong connector info. Have tried several different framebuffers, Hoolock, Orangutan, Vervet, all give blackscreen on LVDS.

      Device ID: 68c1

      There are several config files, config4 is the bootconfig I used to make the IOreg.

      VGA is not working , have not been able to test HDMI (yet).
       
      Here is my entire EFI Folder: https://www.dropbox.com/s/ig134fl6pdq193a/Archief.zip?dl=0

      I found the following topics about the problem and there only seems to be a chameleon solution:

      http://yun.baidu.com/share/link?uk=3355666171&shareid=42351891&third=0&adapt=pc&fr=ftw

      http://www.insanelymac.com/forum/topic/248751-mobility-radeon-hd-5650-qeci-work-262-update/

      http://www.insanelymac.com/forum/to...d5000-and-hd4000-series-support-in-chameleon/
      http://www.insanelymac.com/forum/to...vds-qeci-1600x900-need-help-with-personality/
       
      I hope someone can solve this.
       
      Good hack to you all,
       
      Nikita
      IOREG.zip
      EDID.txt

×