Jump to content

[RyzenPatcher] Thread for channeling info about updates


51 posts in this topic

Recommended Posts

I got error like @RusticPotado

cp: ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/boot: No such file or directory
Even use "kernelversion rc4"

pls help, thank so much!

 

sh-3.2# python ryzen.py --volume /Volume/macOS>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Extensions/System.kext ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Extensions/System.kext'ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Extensions/System.kext'>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/IOKit.framework/* ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/IOKit.framework/*'>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/Kernel.framework/* ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/Kernel.framework/*'>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/System.framework/* ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/System.framework/*'cp: ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Kernels: No such file or directoryusage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file       cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directorycp: ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/boot: No such file or directory/Volume/macOS - No such file or directory.		Please run kext wizard and rebuild caches!		Please copy kernel file from /Volume/macOSSystem/Library/Kernels/kernel to /Extra/Kernels/ and Extra/.
This is what I get when starting the script... whats going on here?

I got error like @RusticPotado

 

cp: ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/boot: No such file or directory
Even use "kernelversion rc4"

pls help, thank so much!

It should be `--kernelVersion`

 

 

sh-3.2# python ryzen.py --volume /Volume/macOS>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Extensions/System.kext ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Extensions/System.kext'ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Extensions/System.kext'>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/IOKit.framework/* ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/IOKit.framework/*'>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/Kernel.framework/* ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/Kernel.framework/*'>>> Copying ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/System.framework/* ditto: can't get real path for source './tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Frameworks/System.framework/*'cp: ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/Kernels: No such file or directoryusage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file       cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directorycp: ./tmp/patcheR//ryzenFiles/RyzenEssentials/kernel_None_ryzen/boot: No such file or directory/Volume/macOS - No such file or directory.		Please run kext wizard and rebuild caches!		Please copy kernel file from /Volume/macOSSystem/Library/Kernels/kernel to /Extra/Kernels/ and Extra/.
This is what I get when starting the script... whats going on here?
Looks like it's not defaulting to rc4 .. can you try `sudo python ryzen.py --volume /Volume/macOS --kernelVersion rc4`

 

Let me know if it don't work . I will try to fix the default issue.

  • Like 1

Ahhhh this looked much better than on the first attempt :D Thank you ;)Now I'll move on through Gigamaxx' guide ;)@Gigamaxx do I have to rebuild the prelinkedkernel?

lol .. Yes still got bugs on it . Oh well something to get me through the momrial day weekend . Ha.

  • Like 1

lol .. Yes still got bugs on it . Oh well something to get me through the momrial day weekend . Ha.

I've been adding the kernel manually, I just tried the new command above, looks like it worked. I will test as well later, for now off to help a friend.

@Gigamaxx Did you also install Sierra on your Gigabyte AB350 Gaming with this guide?

I have the same mainboard and just don't get it to run

 

 

Try this, open this and make your partition the same.    copy kernel and add to System/Library/kernels folder and then run kext wizzard.   If it works please change serial number using Xcode or Pandora.  

Ryzen Extra and boot.zip

I reinstalled Sierra again and used RyzenPatcher and gigamaxx' guide to get everything to run.

The only thing I changed is my graphics card. At the moment I use a Gainward 7100GS. System Information says "Display 3MB"

Hi Guys, I'm trying to follow along with the guide. Are you suppose to install Sierra on an USB harddrive on your mac first then use that in you ryzen machine? so not using a USB installer directly on the ryzen machine. Thanks for the help.

I used my MacBook to install Sierra on a SSD that was connected to the MacBook using a SATA-USB-Adapter.

After installing and setting up the user account, shut down the MacBook and disconnect it from your Mac/Hackintosh.

Turn it on again, connect the HDD/SSD again to your Mac and follow Gigamaxx' guide

I used my MacBook to install Sierra on a SSD that was connected to the MacBook using a SATA-USB-Adapter.

After installing and setting up the user account, shut down the MacBook and disconnect it from your Mac/Hackintosh.

Turn it on again, connect the HDD/SSD again to your Mac and follow Gigamaxx' guide

Are you using nv_disable=1? I used it to get booted at first but now I don't use it and have the card 1gb with full drivers.

Try this, open this and make your partition the same.    copy kernel and add to System/Library/kernels folder and then run kext wizzard.   If it works please change serial number using Xcode or Pandora.  

Solved :-D my fault, miss understanding the tutorial.

  • 2 weeks later...

After running RyzenPatcher, it tells me:

Please copy kernel file from /Volume/System/Library/Kernels/kernel to /Extra/Kernels/ and Extra/.

 

However I have no Extra folders on my installation.

I just downloaded a pre-made VmWare image and it works on my Intel machine.

After running patcher and rebuilding kext cache, when I start this VM it just freezes on Apple logo and progress bar never shows up. VM used to show me a pop-up saying guest os rejected your cpu before installing ryzen patcher

After running RyzenPatcher, it tells me:

 

However I have no Extra folders on my installation.

I just downloaded a pre-made VmWare image and it works on my Intel machine.

After running patcher and rebuilding kext cache, when I start this VM it just freezes on Apple logo and progress bar never shows up. VM used to show me a pop-up saying guest os rejected your cpu before installing ryzen patcher

Go into the Sierra main partition System/Library/Kenrels folder and replace the kernel. Use kext wizzard or equivalent to repair caches.

 

I found i had to to do this, your Extra folder would be there if using the chameleon bootloader.

So I booted into recovery mode (holding win + r keys, while waiting for Apple logo to show up), than opened terminal and typed "csrutil disable" after this I was able to replace kernel, but i still get the same issue - when I boot the VM as soon as Apple logo shows up it goes into boot loop.

I used "kextcache -u /" to fix permission, but it gave me a bunch of missing symbols warning and i gave up on this.

So I booted into recovery mode (holding win + r keys, while waiting for Apple logo to show up), than opened terminal and typed "csrutil disable" after this I was able to replace kernel, but i still get the same issue - when I boot the VM as soon as Apple logo shows up it goes into boot loop.

I used "kextcache -u /" to fix permission, but it gave me a bunch of missing symbols warning and i gave up on this.

 

Did you replace the prelinked kernel as well?     FakeSMCKext in S/LExtensions folder helps a lot as well. 

  • 2 months later...

I added the Files from Gigamaxx 16_5 to the Folder in the Ryzen Patcher 

ryzenFiles / RyzenEssentials/kernel16

 

the folder ryzenpatch is on my desktop

i runned the script as seen in screenshot and get the same Issue as motoxnate

 

maybe someone knows what i did wrong?

 

 

post-2255651-0-13597000-1505904235_thumb.png

×
×
  • Create New...