Jump to content
p4antonio

Help Compile DSDT MSI B250M PRO-VH

27 posts in this topic

Recommended Posts

Advertisement

DSDT.p4antonio.zip

 

PATCHES

-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-USBX
-PMCR
-EC
-PNLF
-HDMI NVIDIA / ATI

Share this post


Link to post
Share on other sites

Taken from Acpi Config.plist

Change HDAS to HDEF
Then in Audio Devices: Set Layout 1

Restarted but low volume audio

 

thank you

@Gengik84 

@MaLd0n

Share this post


Link to post
Share on other sites

btw

Dont need HDAS to HDEF

 

The problem is Kabylake audio, in many cases sound fail, u can try a new ApppleHdaPatcher ;)

Share this post


Link to post
Share on other sites

@Gengik84  Post #5

Efi-Clover-kexts-10.12...AppleALC.kext

DSDT + layout to 5....audio ok.

 

 

 

post ur full Clover folder here

 

 

​ ok post efi folder

Share this post


Link to post
Share on other sites

essencial patches, all need to avoid conflict sata, usb, etc  ;)

CLOVER.zip

 

id 5 and compiled applealc


if u can, send me a ioreg after reboot, i apply HDMI audio

 

what ur GPU?

Share this post


Link to post
Share on other sites

u use ssdt for hdmi? :D

 

No ... use Audio Pc for logitech 3.1 sound system

 

 

Tips to do clean installation ??

After all these tests ??

Share this post


Link to post
Share on other sites

Installed new sierra

Continuous kernel panic
Remove NvidiaGraphicsFixup.kext and Lilu.kext.
 
Smbios 17.1 boot nv_disable ...
Smios 14.1 no boot problem.
 
In the old configuration or used for smbios 17.1
AGDPfix ... for graphic acceleration..
 
In the old configuration or used for smbios 17.1
AGDPfix ... for graphic acceleration.
The 5 patches in the config, plist did not work.

Share this post


Link to post
Share on other sites

Check

attachicon.gifDSDT.hdmi.zip

send me new ioreg after reboot, check about this mac / pci for new cosmetic

 

let me know

 

Remove NvidiaGraphicsFixup.kext and Lilu.kext.  (Smbios 17,1).

 

kernel panic.

Do  you have installed web driver?

InsanelyMacWebDriver(OsxBuild_16E195)-378.05.05.05f02. <--- Yes.

Share this post


Link to post
Share on other sites

lol

now is a pegp again

wait me

 

U need a NvidiaGraphicsFixup.kext and Lilu.kext

 

the problem is pegp and other device into peg0


post a photo kernel panic


Have a two devices with Name (_ADR, Zero) into peg0

;)

 

wait, fix it


EDIT

Check

Replace all files

CLOVER.zip

Run it

Olarila.command.zip

 

reboot, new ioreg

Share this post


Link to post
Share on other sites
This does not happen.
Used last gengik config and I had black display ..
Restored to the efi folder of NvidiaGraphicsFixup.kext and Lilu.kext.
In the sudo NVRAM -c terminal.
And then new command.
Sudo rm -f /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch / System / Library / Extensions && sudo kextcache -u /
 

 

Restarted and works.
:)

Night

@MaLd0n

Tomorrow I'll try your Clover and Olarila.command folder.

And let me know.
Thanks Gengik
Thanks MaLd0n

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×