Jump to content

Tiger plays welcome video but stuck on apple logo

Go to solution Solved by nvidia12,
9 posts in this topic

Recommended Posts

Hiya, im new to the forum and also pretty new to hackintoshing itself. I have an old dell latitude d505 and decided to install Tiger on it just to check it out. After days of searching i found a link to download the JaS dvd installer that still worked. I installed it and after a a little coaxing it completed. But when it restarts the apple logo appears with the spinning wheel, then the wheel freezes in place and after a minute i can hear the welcome video begin to play. It just stays on the apple logo with the frozen wheel even though behind the scenes i can tell im on the setup screen due to the sound ques. I know that the x86 project and Tiger have long since parted ways, but if theres anybody that could give me a hand with this that would be awesome. Cause theres not alot of places i could look for help on this ancient project.


Dell Latitude D505


1.4 GHZ Celeron

The Standard Intel Based graphics

Probably a graphics problem. You need to be more specific about your graphics card. What Intel chip specifically is it?? Your compatibility depends on what exact card it is. If you can tell me the CPU model number, I can find out for you.

I've had a look online, and it appears that your GPU will not allow you to have acceleration but will allow you to boot to the desktop. Basic troubleshooting boot flags include -v and -x. Please run it with these commands and let me know how it goes.

Well the bootflags didnt exactly make it work. -v displayed all the text on screen as it normally would, but then at the end it says something along the lines of "Starting OS X Setup Window" but then nothing happnes, one other line of text comes after it refering to a non existent Airport driver. And -x brought me the same result as no boot flags but with no music.

The graphics hardware does work 100% correctly i might add, Ive used Windows 7 on this laptop and the driver work perfectly.

I see. So in this situation I would recommend removing the kexts related to your graphics driver to see if it will boot without any video acceleration at all. I'm not entirely sure what the names of these kexts are in Tiger, but if you can set up a linux live CD or do an ls in single user mode you would be able to find their names.


EDIT: You also made a comment about your graphics card being supported in Windows, and that means that it works fine. That is not the case. You see, in Windows, Microsoft has to support a large amount of hardware in order for people to use it. Apple does NOT have to do this, so they only include drivers for their machines. Therefore a card that works fine in Windows may not have the same support in OS X.


In your particular case, Intel 855GM/855GME is not fully supported in OS X Tiger.

That's fine, we were all new once ;) but good news. I have found a possible solution to our little graphics problem. It does require some kext patching, so it assumes that you are able to get to the desktop. Once we fix that, we can work on proper video detection using this method. I found the names of the kexts, so you may not need that liveCD after all. If possible, keep burning it or wait for it to finish before trying this.


At the bootloader, follow these steps:


1. Press -s at bootloader


Wait for the shell to load up

Then type

2. /sbin/fsck -fy

3. /sbin/mount -uw /

Then enter these commands


4. cp /System/Library/Extensions/AppleIntel830.kext /

5. cp /System/Library/Extensions/AppleIntel915.kext /

6. cp /System/Library/Extensions/AppleIntelIntegratedGraphics.kext

7. rm -r /System/Library/Extensions/AppleIntel830.kext

8. rm -r /System/Library/Extensions/AppleIntel915.kext

9. rm -r /System/Library/Extensions/AppleIntelIntegratedGraphics.kext


Try this and see if it works


Good luck,


- Matt

  • Solution

Ok, despite all this stuff i did manage to get it working. The commands you gave my didnt seem to do much. I got a "file or directory not found" after trying to use most of them, eve though i typed them correctly. What i did was re-install JaS and then uncheck some of the install options under"Most Common Hardware" and that seemed to do the trick. And then under later inspection the AppleIntel830.Kext want even installed when all the things were selected. Not complaining ;)  Thanks for all your help, glad to see there still is some help for these old projects.

  • Create New...