Jump to content

Update and Drivers for 10.5.5

35 posts in this topic

Recommended Posts

But again capitals are probably a fraction of the problem. As I typed the commands above is how i typed them with directory not found. Spaces before and after / are possibly a problem. The * used in the examples do not clearly indicate to me whether or not spaces before or after the root symbol are required. As for the restoration procedure using the disk utility when I attempted to repair my failed attempt of the update, the backups on both hard drives did not open on the iDeneb disk utility restoration process. What error was made in the commands i used or is 10.5.5 too old for a 10.6.8 update?? As for the FakeSMC, I don't know the commands to do this and this includes copying the legacy kernel to the USB. This reminds me of Linux. Most if not all of my hardware is supported but if the CLI is required and unless you can find, or know the commands, renders it useless making me realize why Linux users are becoming more and more of a minority!!!
Matt please don't get me wrong for my reply here and there is no lack of gratitude intended towards this forum or you for your help, but due to the fact that I'm not an experienced Mac user limits me to what i can use UNLESS I have very clear detailed information and instructions. This is the main reason forcing me to keep using this Dell and obviously I have alot of hardware laying around but again, unless I know what patches and procedures to use, it is pointless trying to attempt this due to the perpetual kernel panic and unsupported hardware. One thing I did notice was the number of members in all of the forums I visited during all of my searches for information that asked questions that went unanswered, or hardware wasn't supported, etc. with very few posts from quite a few of these members making me wonder if they figured it just wasn't worth it and giving up.

Then try this one instead:

cp /Volumes/*insertHDNameHere*/Users/*YourUsernameHere*/mach_kernel /Volumes/*insertUSBNameHere*/


The asterix does not represent a space. It is where you put in your username. If the directory does not exist, you have not placed mach_kernel in the right place and therefore cannot be copied.


As for Disk Utility not working, just use a third part tool instead to copy over the SL files.

Absolutely non of any of this works. No such file or directory





Now lets ACCURATELY type the commands. NO asterix etc. and what appears on the terminal before I enter anything is

john-does-macpro31 :~ johndoe$                       and of course to attempt to clarify John Doe is an alias used here to accurately depict what should be typed in this CLI


At the $ after my name do I type

cp /Users/johndoe/Documents/mach_kernel /         with my username ALL lowercase run together as one word?


cp Users/John Doe/Documents/mach_kernel /              with my username BEGINNING uppercase with a SPACE and last name beginning with uppercase? 

and what about the spaces before the /     ??

None of the commands work because there is obviously an error entering these commands. Its either an uppercase/lowercase or space required or not required command error. 


This also applies to 

cp /Volumes/*insertHDNameHere*/Users/*YourUsernameHere*/mach_kernel /Volumes/*insertUSBNameHere*/


I used a blank USB and copied the mach_kernel to it and Mac recognizes it as NO NAME and this is what I typed into the terminal ALL UPPERCASE as it appears on the desktop with  the error No such file or directory being presented. 

This is my argument about that stupid command line and unless the command is precisely and accurately entered you end up with absolutely nothing accomplished! Oops wrong description I gave, something is accomplished, frustration :blowup:


This obviously should work for updating this kernel if iDeneb v1.3 is working very stable with no issues other than the version is outdated and this is preventing me from using newer hardware because of all of these problems just attempting to update a kernel. It should work but obviously wont unless the command is incorrect.

Then your kernel file IS NOT in your documents folder. That was probably a misunderstanding on my part; I thought you said earlier that you copied it to your Documents folder.

Note that the kernel MUST be called mach_kernel, and that all commands are case sensitive.


As for your username, to find out type this in Terminal:


ls /Users


then with the name that comes up (case sensitive also), and your kernel file in your Documents folder, type this command to copy it to a USB.


cp /Users/YourUsername/Documents/mach_kernel /Volumes/YourUSBNameHere/


then once you have SL installed. boot back into the USB Installer, go to Utilities from the drop down menu and type this:


cp /Volumes/YourUSBNameHere/mach_kernel /Volumes/YourHDDNameHere/

don-hennmann-macpro31:~ donhennmann$ Is /Users

-bash: Is: command not found

don-hennmanns-macpro31:~ donhennmann$ is /Users

-bash: is: command not found

don-hennmanns-macpro31:~ donhennmann$ Is/Users

-bash: Is/Users: No such file or directory

don-hennmanns-macpro31:~ donhennmann$

Also in System Profiler I get this

User Name: Don Hennmann (donhennmann) again edited for this forum with my username for this forum and for the earlier commands where you mentioned to use my user name I would assume with uppercase being used for both the first and last User name separated with a space?

This is copied and pasted directly from my terminal EXCEPT my real user name is replaced with my forum username for illustration purposes to clearly show what is happening and what I have attempted to do. Shown in my attempt is the first where command is not found and then uppercase, and lower case, followed by space variations at the / symbol as an attempt to make this beast happy.

Now for the kernel. Yes it is in the Documents folder and yes it is unzipped to the point of making a copy from the original you sent and placing this in the folder to the point of having two in the documents folder labeled mach_kernel and mach_kernel copy.

Now to simplify the reply to post procedure I am NOW using Safari on my Dull and this post and the copy and paste is on the same attempted Mac computer instead of posting on my Windoze computer with the Dull idling, floundering, or panicking on the sidelines.

Doing this also allows me to copy the command directly from my browser to the CLI


I should have did this in the past but oh well live and learn.

Now another thing to ponder about is it possible that having multiple hard drives running on the same IDE ribbon with identical versions of OS has discombobulated this entire mission impossible?

And a final mention was I used OSx86 Tools to update the kernel (install kernel function)in previous attempts and it seemed to go through the motions appearing to be doing the update like it should with no apparent problems until I rebooted as instructed where it didn't proceed with the full boot. After going through that procedure, is it possible that it led me down the right path but a kext or driver had to be replaced?


Matt see what you make of all of this now that I finally provided an actual copy of what is going on to diagnose what is going on and if need be we can copy and paste the command with my user name properly inserted in the command and by properly inserted clarify how the username must be typed in. If I copy and paste your reply this should eliminate any errors re space or no space etc.

At least I can use this Dull to this extent and not like a dead or disabled PC sitting off to the side and of course this also includes the fact that if it does crash or panic I can reboot into the other intact drive and peer around inside the experimental drive named iDenebX.

One more question before I post this. Is it possible that 10.6.8 is too big of a jump from 10.5.5?? If not then perhaps as mentioned earlier something got replaced in the final update that needs to be replaced with an earlier version?

don-hennmanns-macpro31:~ donhennmann$ ls /Users
Shared donhennmann
don-hennmanns-macpro31:~ donhennmann$

Okay that is much better! As we can all see what effects one small error can create which must be the case with all other attempts.
One thing I should have done for simplifying things for demonstration purposes is I should have used my forum username uppercase and lower case for this experimental OS for simplicity of directly copying to and from the terminal and Safari browser for showing and explaining what is going on and if need be make it easier for copying commands from the browser and pasting it into the CLI. Anyway this is a start in the right direction Matt and perhaps we can give the kernel attempt another try.

As for this

"I apologise that I still haven't had time to install SL on one of my P4 machines; I have been quite busy recently. I have a free night tonight, so I will try and get it done today."

No need to apologize for anything because if you can put up with my bumbling along as well as being quite busy your schedule is what it is!

Now back to this
cp /Users/*YourUserName*/Documents/mach_kernel /
Re *YourUserName*
Am I to assume that I would roll it all together such as
/DonHennmann /
                        ^ with a space above where my arrow is pointing?
Because one little glitch can throw a wrench into this operation or should I just give the OSx86 tools utilities another try to install this legacy kernel with repairs being made to the iDenebX VIA iDeneb_V1.3 which is my working "do not mess with OS"?
Also another thing I thought of as well is I used my Win7 to download the kernel you provided AND I used Winzip on Win7 to extract this zipped Kernel and install on my USB drive to transfer over to this wannabe macpro 3.1
I could probably figure it out on Mac which would be downloading it again on the Dull Mac but what utility is used on Mac to unzip a file? It is probably like the 4600 patch that was required for the 10.5.5 instal that some attempted to install and failed because we forgot to extract or unzip it prior to installation. I also got temporarily stalled on the patch as well so is it correct that this Kernel 10.6.8 must be unzipped prior to placing in Documents as well?
Anyway for now I will see if we can get this mach_kernel to take root in this box and if this is a successful possibility I will throw that Socket 775 Mobo into a case and give it a go because that one might have more possibilities being 775 with the only? downside is the questionable PCIe slot on it other than the onboard video. By questionable slot, it is that short 1 1/4 inch slot with a divider in the middle which I have no idea where I would begin to look for a card like that making me think this board is another door stop or frizbee. Since you are working with some P4 machines as you mentioned, what are some of the easiest of these to get going with good potential for easy and low cost expansion or upgrades? By this I mean CPU's, drivers, etc. Should I look at Intel Socket 775 or is AMD AM2 not too bad to work with? These I have and at least they are not laptops that present more problems due to proprietary hardware. I wish this 4600 was a 4700 with 775 because I saw a recent thread started with one getting 10.6.8 installed and I think the member mentioned he was able to install a dual core in it as well.

OK, I think we should point this chat in another direction. I'm getting a bit lost on what you're trying to achieve. Do you want to install Snow Leopard or do you want to install Leopard?


I think we should attempt Snow Leopard as that is a much better OS in terms of support as well as kernel improvements.


To install SL you must do this:


1. Open Disk Utility

2. Mount the Snow Leopard DMG

3. Partition your USB in MBR partition type and Mac OS Extended Journaled format.

4. Click on the restore tab and make the SL volume the source and your USB the destination.

5. Install Chameleon 2.4Svn to your USB

6. Copy the mach_kernel to your USB on the root directory using this: cp /path/to/file/mach_kernel /Volumes/USB name here (By the way, if the name has spaces you must put a backslash \ after each word like t his Volumes//Example\ USB\ Name/)

7. Boot up and install SL

8. Reboot into the USB and open the utilities menu and select terminal.

9. Type this: cp /Volumes/USBNameHere/mach_kernel /Volumes/HDDNameHere/

10. Reboot

11. Profit

Sorry for leading you astray Matt!

Not Leopard because this is working very good but is obsolete like the hardware. Snow Leopard and beyond was the plan of attack. I attempted to upgrade with the Leagacy kernel 10.6.8 you provided and my directory was never found using CLI but as I discovered with the last task for the username just one little error such as an L lowercase instead of I uppercase and as I read this post or reply being done on my iPhone they both look like the same character which led me down the wrong garden path. Like you mentioned earlier installing SL from scratch is probably an easier option. myHack want an option at the time due to being updated to a version only working with 10.6 and all earlier versions being discontinued. Anything is possible if one has the knowledge including where I discovered a Dell Dimention 3000 running 10.7 and since the OSx86 Tools and utilities allowed me to install your mach_kernel smoothly with everything running fine while this was happening until I rebooted tells me there was probably one driver or kext replaced that needed to be removed and replaced.


Nope not Leopard, just Snow Leopard or newer and it's my turn to apologize for my lack of knowledge that limits me to a tried, tested and proven but obsolete piece of hardware. I got much better but at the same time a Dementia 3000 is very low on the food chain compared to the 4600 and the 478 3400GHz is optional for this box but at the same time I have a 775 laying beside IF Intel is easier to "tosh"

One thing about all possible options on the 4600 is I have working drivers etc. on the untouched drive. How about booting up on an install disk that boots up and runs on this box AND use the disk utility>restore>then restore with an OEM or modified 10.6++? Is this option possibly easier? Back to your P4's? What are you running and what were you able to make run just to see what is similar to the junk I got laying around

The OSx86 Tools are out of date and haven't been updated since 10.5. Don't use them. About using myHack for SL, I tried it and I haven't had much luck with it. I can tell you how to make one manually, all you need to do is go to Disk Utility, choose your USB and hit Partition. Go to options and select MBR (Master Boot Record) then click OK and select 1 partition, then formatting it as Mac OS Extended (Journaled). After you partition it, go to the restore tab. Mount your SL dmg and then drag the SL volume as the source and your USB as the destination. Click Restore. Afterwards, install Chameleon 2.4svn onto it and copy over the mach_kernel onto the root directory.


Reboot, install and profit.

  • Create New...