Jump to content
hennmann

Update and Drivers for 10.5.5

35 posts in this topic

Recommended Posts

Is it possible to update the version or Kernel but keep your drivers? Also I'm running V1.3 10.5.5 on a Dell Dimension 4600 (there is prob hissing and booing right now but this is a starter PC known to work very well and I will upgrade) and this is Darwin 9.40 which (correct me if I'm wrong) Vanilla instead of Voodoo. Is it easier to attempt an upgrade on Vanilla or Voodoo? Also should I attempt to install V1.4 10.5.6 Voodoo 9.50 and continue with a newer or just attempt taking the plunge up to 10.5.8 and beyond? As an experiment and learning process after I got this Dull running very stable with everything running including Ethernet I let the update process start and finish to see how badly it would crash and burn because doing a reinstall is no big deal at this point because I at least know how to install V1.3 10.5.5 with a network with Win7 working very well. The result was it wouldn't shut down, sleep, or restart, and Safari etc. wouldn't start. At this point of time what can I attempt to upgrade to? With 10.5.5 this Intel 2.8 GHz with 4 GB of RAM boots, operates, and performs faster than XP and Win 7 with no crashing. 10.5.5 limits me for software updates.

Share this post


Link to post
Share on other sites
Advertisement

Just reinstall your drivers after the update. If the PC won't boot then use single user mode or a linux live CD.

Share this post


Link to post
Share on other sites

Thank you very much for the reply and more googling will follow but at least this is somthing to look into now that I know what to look for. Yes it is a $h!t box in today's standards but is good to get started and learn on and actually works quite well with very little $ invested. As it is I have found sorces mention they have installed 10.7 successfully on a Dell Dimension 3000 and it works great so the story goes. The 3000 is lower on the "food chain", an older version that was replaced by the 4600 with a smaller harddrive, smaller CPU, less RAM, no SATA ports but very similar chipset (prob the same but earlier version, only diference is one less letter after the version number), same Ethernet, etc. so if that older box works on 10.7, this 4600 fossil should work better. Also as I send this, the 10.5.5 performs faster than XP that this Dell originally came with which was fast compared to seven. Also the larger CPU a 3.4GHz are available for not much $. My other excuse also is a google led me to this adventure and instructions were provided on this forum showing exactly how to install 10.5.5. I have an Athlon 4800+ Toledo dual core and two mother boards, one with VGA and another much newer supporting PCIe but that will be my next project. I was given the newer mother board the other day and will retire my VGA Mobo and single core 3500+ for an update to the Dell because of the learning curve. I never had a Mac before other than an iPhone and was curious to try it out.

Share this post


Link to post
Share on other sites

Hey 0000-1248

Instead of a linux live CD would I better off sticking a small extra hard drive beside the one I'm attempting to upgrade with the same working V1.3 on it so if the update fails i can totally access it by booting up on the other and copy or replace drivers from the working spare drive to the attempted update? My success with Live CD has not been overly good compared to things permanently installed and Mac side by side might be better than using linux. Bare with me because this is my first so called Mac and it is a total learning experience compared to Windoze and Linux (of which I ran away from due to the CLI and terminal requirements with very little info on commands info available). As for the Linux at least there are more drivers available and not restricted to proprietary must use hardware. As it is now I have to figure out how to find all of the drivers other than looking in System/Library/Extension that may be affected which will require replacement. Also how far ahead (newer kernel or version)can I use the earlier drivers?

Share this post


Link to post
Share on other sites

You could do that, but then you would have to install the operating system on it but with a live CD it's just there. It is up to you which you want to do.

Share this post


Link to post
Share on other sites

Installing an operating system on another drive is certainly easier than trying to salvage a damaged working system to me. I attempted to update to 10.5.6 with horrible results and to top it all off from Vanilla to Voodoo leaving me staring at the Apple Logo at startup. This upgrade in my opinion is a waste of time because it is outdated and not new enough for newer software but meanwhile there is documentation on the web where 10.7 Lion has been successfully installed on a Dimension 3000 which is older and lower on the food chain compared to the 4600. After my failed attempt of the iDeben V1.4 I removed, backed up all of the drivers and then copied and replaced all the drivers from V1.3 but face the logo! The problem I suspect is the damn drivers from Vanilla are probably not compatible with Voodoo. I would upgrade hardware but unless I have detailed documentation on how to deal with Apples stupid forced upon proprietary hardware issues and how to modify the OS or drivers, I'm lost. 10.7 is probably vanilla as well and copying or replacing drivers from the 10.5.5 to the 10.7 would probably be more successful than to Voodoo but then due to the fact that unless I have instructions on how to deal with this leaves me sitting spinning my wheels and wondering if all of this is even worth it.

Share this post


Link to post
Share on other sites

Well for the Pentium 4 you should try to use the legacy kernel, this is where you are probably going wrong. After updating this is something you should try. Nawcom's 10.6.8 kernel allows for the Pentium 4, so you can try SL. Here are the kernels: http://wiki.osx86project.org/wiki/index.php/Patched_Kernels

 

Try the 10.5.7 legacy kernel, and if this doesn't work then use Nawcom's 10.6.8 kernel to install Snow Leopard.

Share this post


Link to post
Share on other sites

Thanks 0000-1248! I have done a great deal of googling and what little I find was the instal of V1.3 and getting that totally working including networking it with my Win7 Laptop and Desktop PC. One major problem I have found is the search engines never give specific results and doing a search for my Dull Dementia 4600 can end up with the majority of makes and models not even close. Most of what I found was by accident and was pretty much stumbled upon. My biggest handicap was

Okay we found it, what do we do with it? A good example of this was preparing the hard drive for first time installation. I had to do much searching just to get to this point. I attempted to use Linux back in the early 2000's where back then you had to determine your partitions, how many you wanted and for what they were used for then install and hope for the best. I found drivers were never a problem but having to use the CLI or command line interface and terminal. It wasn't of much to me if you can't find the commands or know the commands! As it is the newer distros do partitioning etc. automatically. Then there were many like myself asking the same questions waiting for a reply and a reply we could understand. Mac OS X is UNIX based like Linux but not very compatible in some respect. I guess it would be safe to say many doing the hackintosh have an advanced knowledge of Mac already and know how it works, where to find what they are looking for and how to modify. Like I memtioned before was the only "Mac" I had was this crappy iPhone and one thing I learned fast was don't upgrade the IOS unless as a last resort with MANY bugs and problems being the usual result. I would watch the net to see what problems people had before upgrading.

In the case of my Hackintosh using a specific make and model search got me this far but getting into newer hardware is also a problem. I have quite a bit of hardware much better but now we have to try to get AMD going or specific newer ( but still obsolete) Intel CPUs going not to mention the chipset etc. A guide just to get started is needed for myself and others but would take days to even find a very small amount leading me to wonder if trying to learn Linux would be more productive especially not having limits on drivers etc. Years ago I walked into a Mac store and found their OS software was very reasonably priced but walked out in disgust empty handed because of the stupidity of being forced to pay double or triple the price for hardware they "feel" you must purchase to keep your copy legal. My opinion was with that mentality they deserve to get their software pirated!!

Is there such a thing as a very basic beginners guide? Or is it pretty much post a question and hope somebody answers? This is another thing I find searching. Google will point me to a question or topic like my situation but nobody will give an answer. These are common.

Share this post


Link to post
Share on other sites

my Dull Dementia 4600

This ^^ :hysterical:

 

Anyways, you said how it was all automated with distros, etc. and I agree. Back in the day it was a lot more difficult to make a hackintosh, but now it appears that there are even premade installers for vanilla OS X and anyone can get it working.

 

Is there such a thing as a very basic beginners guide? Or is it pretty much post a question and hope somebody answers?

The answer is, it depends. I'll explain: there comes a point where for a lot of things you don't even need to ask for help to solve, you know what's wrong and how to fix it. But, for very complex problems or for things you don't understand seeking help from the community is a very good option. It is also a good idea that once you've installed OS X and got it all working to help your fellow  members and make a guide for it, I did it for my G560 and A57.

 

As for a beginner's guide, I will provide you with some articles that will give you basic knowledge about the OSx86 project.

This pretty much sums up everything you need to know. It contains a great amount of guides and tutorials to help you gain some basic knowledge.

 

Good luck, and have fun.

 

- Matt

Share this post


Link to post
Share on other sites

Matt

Again thanks for your help!

As for the guide and helping other members, I'm at a loss for getting this going due to the fact that as far as I got was the V1.3 working as per the guide (and totally step by step by the guide) on this forum. V1.4 and V1.5.1 were failures to say the least! I'm staring at the Apple Logo at attempted boot not knowing what the hell is happening :(  This is on my spare hard drive with my V1.3 running fine beside but greatly limited due to the OS being out of date. I copied all of the drivers from 1.3 but they are probably not compatible because of Vanilla and Voodoo differences I think??. As it is I'm not sure how to use the Kernel you suggested and all of the links I found so far, are dead. All I have on hand is MacOSXUpdCombo 10.6.4 and 10.6.8 but never used or attempted to use due to possible Apple Logo of death or the reboot cycle. I performed the update from Apple a while ago to see what would happen, and even though the system rebooted and ran, lots of things just wouldn't work forcing another re install.

Using different Kernels isn't much help to me because unless it is on my USB or CD as an option to select (or is this legacy Kernel installed like an Update Combo?) , again this is another problem and as it is using different Kernels is a problem if patches are required because to sum it all up unless I know what the problem is, I don't know what to ask for or what to look for. Also understanding "kext" terminology etc. is new to me as well and in some ways this adventure reminds me of trying Linux in the past and being locked out in the cold if CLI was required.  Like I mentioned earlier the google for the Dull Dementia 4600 and Mac brought me this far for the specific hardware and operating system but this is as far as I got probably because many of the posts are quite old and very limited including unanswered questions. Using newer or better hardware wasn't an option mainly due to lack of knowledge and information. To me this was starting from scratch and possibly worse than the Dull because at least the Dull was somewhat "standard" for the hardware so the problems and patches were pretty much universal for these boxes. Also I wasn't  overly  interested in purchasing Mac supported only hardware because I have quite a bit laying around here but in today's standards it is obsolete but should be fast enough to handle Lion and newer OS but again that's if i can even figure out what to use and how to set it up. As it is right now other than the Dull I have:    an Acer Aspire T600  (915GV-M5A intel based )motherboard with a socket 775 2.9 GHz cpu with larger single core CPU options laying around in junk boxes from the friend that gave the board to me,    an MSI K9N6PGM2 AM2 motherboard (in an eMachine T3256 given to me by the neighbor destined for  recycle with a new 600 watt power supply and hard drive ) that supports up to 6X processors (presently has a single core 2.6 GHz CPU and I was given a free  3800+ AM2 ADA3800IAA4CN single core CPU today). This eMachine is presently running Win 10 Pro, 64 bit,   an  MSI K8T Neo2-F socket 939 AMD mobo with 4800+x2 Toledo or 3500+ single core CPU, NVidia FX5700LE TD128 video,       TForce4 SLI socket 939 motherboard with PCIe (a newer considerably better mobo than my K8T with more options etc. including PCIe instead of VGA!!) with the different 3500 or 4800 CPU options I have on hand, and I haven't purchased a Mac friendly Video card (or any card yet) for this board but I most certainly can because other than Mac, a Mac video card would probably work very well with Windoze and Linux and finally       an Acer Aspire One 533 Laptop with an Intel Atom 1.6 GHz and 2gb of RAM.

The Acer Aspire T600 motherboard is a piece of {censored} in today's standards but perhaps is better than the Dull 4600 because it is a newer obsolete socket 775 processor and was given to me recently for free and because of Intel being a possible better choice for Hackintosh motivated me to grab this orphan for perhaps an ability for newer slightly more demanding versions such as Lion, etc. BUT does this one fall into the same category as the 478 or Pentium D (dinosaur is prob what the D stands for) ??  Mind you I haven't been able to determine whether or not this board supports dual core CPU and perhaps is just a sweeter tasting Lemon than the Dull and perhaps can become a frizbee? The friend of mine that gave it to me repairs and sells computers and has a stack of Mobo's that are only there in the scrap stack because they are either single core,older Intel& AMD, or still have a dual core processor in them waiting to be plucked out of the board. 

Oops I forgot! I also have an IBM 1829 ThinkPad off to the side and an HP OmniBook XE3 both in very fine working condition that are expendable for Hackintosh experiments. These two wouldn't bother me if they only worked on something like V1.3 or older because they would be good enough for basic web, email, and iTune for my iPhones. A menagerie perhaps (collected for free or close to :thumbsup_anim:  by a possible hoarder :blush: ), not including my very first new computer, a PIII 450 sitting off to the side collecting dust. 

Finally I have access to newer and faster AMD and AM2 processors and boards as indicated above but are they harder to Tosh than Intel or is that a thing of the past?

Sorry for all of the questions and I don't want to present the image of needing to be "spoon fed" but sad to say like Linux, Mac is about as puzzling too me compared to Windoze. If there is documentation that is more advanced than vague I can get somewhere :blush: Also this 4600 performs very fast and stable compared to Win 7 and is probably as fast as XP on this hardware. iTunes certainly works better as well but the version needs to be updated and if memory serves me correct the latest isn't supported on 10.5.5. Kodi also needs a minimum of 10.6 as well to get another use out of this box

Share this post


Link to post
Share on other sites

To install the legacy kernel you need to replace the vanilla kernel. In OS X versions 10.9 and below it is located in the root directory /

Just rename it to mach_kernel and place it in the root directory and it's installed.

 

I would recommend just installing a copy of Snow Leopard as you can do it with a vanilla install and then replace the kernel and copy your kexts. It is also a much newer OS and is largely still supported. You can buy SL from Apple or alternatively 'find' a copy online. Then you can use Nawcom's ModCD to install. One thing you CANNOT do is install the combo update for 10.6.8 on Leopard, as it is only an incremental update and not a full one.

It would be better to try SL then to bother troubleshooting L since you can't do a vanilla install of L, and distros are tedious and annoying.

 

Kext stands for kernel extension and is literally just that. It 'extends' the kernel to support more hardware and take full advantage of its capabilities, so pretty much drivers for Mac OS X.

 

As for your other hardware socket 775 is supported on the vanilla kernel as Apple used C2D and C2Q processors in their Macs, AMD processors are supported by Legacy Kernel and are considerably harder to use with OS X than Intel.

 

Best regards,

 

- Matt

Share this post


Link to post
Share on other sites

Thanks Matt

Before reading your reply I figured the only other possible useable outdated hardware was my AM2 processor and the Mobo can handle a 6x except it has to be the harder to find more expensive 1055T 95 watt due to that limitation of the voltage regulator on the board. My socket 939 is equivalent in performance to an E8400 in stock comfiguration and hopefully equivalent to an E8500 if it is overclocked. Sad to say even though the Biostar Mobo is newer with more options, support for it is dismal compared to MSI on this older lousy temperamental K8T that was APITA for ram from day one! From what the link you mentioned indicated the Nawcom 10.6.8 leg should support all of the above including the "Dull" and I found a link for download on X86 so now I can get it. A later post mentioned Nawcom?10.7.3 for AM2 including 6x and some very good work from the Russian members also on this forum (after using a translator LOL). All of this information and posts are 2014 and older making it a bit harder to "stumble" on. Some mention Athlon 64 on working hardware but don't mention 939 or 940 so my only clue is the ram they indicate they are using IE ddr2&3 but one post didn't mention ram so who knows on this post.

Things appear to have improved for AMD but with limited info due to age of posts etc. but as indicated is limited period due to Apples choice of hardware and us AMD diehards are sitting on the sidelines waiting to see what happens. Also from what I read Nawcom is out of the picture? due to health reasons? if my memory serves correct but I found out a few others are taking over. I used to use hex editors and all of that fancy software when I used to "test" satellite TV but that was many years ago and fell out of touch with these goodies. This mentioned Nawcom Kernels buys me a bit of time because yes my hardware is somewhat outdated and eventually I will get some "modern" mildly obsolete hardware. Perhaps I will be persuaded to go Intel. I may as well call it mildly obsolete because a lot is obsolete the day you purchase it and this is why I still use this old usable hardware. Okay anyway enough said other than checking out my socket 775 options which might be my best option other than AM2 and perhaps better than AM2. Later on today I will see what I can get for Nawcom and give it a try on my spare hard drive with 10.5.5 on it. I will do everything as my other hard drive which I don't touch because if I need a Mac computer it is available.

Share this post


Link to post
Share on other sites

I attempted to install a retail SnoLeo using usb and it wouldnt boot. Next I used i**** and it started to install, got to the Grey Apple and the gear below started rotation but stopped and nothing is proceeding. Most likely this isnt going to work. It's obviously not this simple. There are more Legacy 10.6.8 kernel versions that you can shake a stick at but hopefully i got the right one. It is not labeled Nawcom 10.6.8 and many google searches led to dead end. The link you provided shows and explains the Legacy kernel but the "40" hyperlink is dead.  

Share this post


Link to post
Share on other sites

It isn't going to boot unless you copy the Legacy Kernel onto the USB. As for where to find the legacy kernel, I got you. I used the WayBack machine to download the kernel from Nawcom's blog.

I'd also recommend you start a new thread in the Snow Leopard section and list your problems in detail (with screenshots of where it hangs using -v).

 

Good luck,

 

- Matt

Legacy_Kernel.zip

Share this post


Link to post
Share on other sites

Thanks again and as I discovered this is slightly bigger than the other Legacy Kernel of which there seem to be a number of variations. Now as for copying it to the USB? Would I just copy and dump it into the USB containing my OEM Mac OS X 10.6.0 installation disk or is there a special step or procedure I have to follow? Also is this Legacy Kernel just an update to 10.6.0 or is my retail copy not new enough or am I actually making this box byte off more than it can chew? Before I read this post I started downloading update combos in small increments above the 10.5.5 in case this might be an easier option or my only option because according to the system requirements, it listed the OS as having to be 10.5+ for each of the 10.5 combo updates and any update combo ABOVE 10.6 stipulated the system requirements MUST be 10.6 or greater BUT I think if I had at least 10.5.8 it would let me escape into 10.6?. My 10.6.0 indicated my OS wasn't new enough or supported when I tried to mount or open it on my operating 10.5.5 which prompted me to try a boot install first from the USB and when it refused to boot, then I used iB :censored:t  out of desperation where it did and started to install with the typical grey Apple and the rotating wheel or gear below that rotated for a minute and then "froze".Yes I agree about starting a new thread in the Sno Leo section but I got to get to the point of even getting some indication of the Leopard staying instead of running away :cry:. Also to make matters worse is the hardware I'm dealing with which I found limits the responses to my posts (with the exception of you of course). My AM2 would probably fall into all of these problems as well with the updates and the Kernel you kindly provided falls nicely into that category of these processors from what I read but again this is outdated information.

Share this post


Link to post
Share on other sites

While attempting to copy the Legacy Kernel using 

  • sudo mv /legacy_kernel-10.6.8 /             I get the following error no such file or directory and I have copies of both the legacy_kernel-10.6.8 and a copy renamed mach_kernel sitting in plain view on the desktop. What directory do I need to move it to in order to use a terminal to copy this Kernel.

This is explained here:http://tlhaas.blogspot.ca/2012/09/installing-snow-leopard-ver-1068-on.html

as well but they also don't explain these missing steps but mention renaming the Kernel like you did

Share this post


Link to post
Share on other sites

Ok, I looked at that guide and it is completely wrong. Here is step by step what you should do:

1.  Use myHack (find it here) to create your SL USB.

2. Your Terminal command doesn't work because it assumes 2 things: 1. is that the kernel is located on the root directory and 2. is that it is named legacy_kernel-10.6.8

Place the kernel in your Documents folder and type this:

 

sudo cp /Users/*yourusername*/Documents/mach_kernel /*insertUSBname here*/

 

This will work if the kernel is named mach_kernel and it is in your Documents folder.

3. Boot up the USB and install SL.'

4. Boot back into the SL Installer but this time go to Terminal (in the Utilities drop down) and type this:

cp /*insertUSBnamehere*/mach_kernel /*insertVolumenamehere*/

5. Exit Terminal and reboot using -v at Chameleon (just in case it hangs, then I can help you diagnose the issue.)

6. Install your Miscellaneous drivers (network, graphics, audio etc.) once you get into Mac OS X.

 

7. Enjoy Mac OS X.

 

Note: the Volume name is the name of the partition on which you installed OS X.

 

Good luck,

 

- Matt

Share this post


Link to post
Share on other sites

I followed the link to myHack and it only works on 10.6 which didn't surprise me due to the age of Leopard but surprisingly About this Mac lists the date as up to 2008 but what is and isn't supported is equiv. to Windoze XP I would guestimate. Anyway after finding out about the required 10.6 and being unable to install SL from the operating 10.5.5 with the error "The application "Install Mac OS X" cannot be used from this volume" I attempted to copy the Legacy Kernel using the provided steps. I typed sudo mv /mach_kernel and my password after enter and then i got three lines displayed (sorry I didn't record the info) and exited the terminal. Then I rebooted and System Profile and About this Mac both indicated 10.5.5 and Darwin 9.4.0

Okay I suspected I missed a step so I typed in sudo mv /mach_kernel /              suspecting I forgot the root  command after kernel and hit enter followed by my pass word to receive the following

 

mv: /mach_kernel and /mach_kernel are identical

 

Then I exited the terminal

 

The only thing that I think I discovered that is possibly different is after POST and the start of boot, instead of seeing Darwin 9.4.0

I now see

Darwin/x86 boot v5.0.132 - Chameleon v1.0.11

Build date:2008-06-09 20:12:22

 

Keep in mind about this boot info indicated that this is my expendable experimental spare drive OS with everything? transferred over to it using the transfer utility that I directed the source as my other v1.3 drive and it was surprising how much and how easy it was to get everything over including email etc.  (does this clone the drives?).
Did this change the start of boot info or did something actually change during my copy kernel attempt?

Also the Darwin 9.4.0 is Vanilla? yes? and Seems to me the Nawcom Legacy 10.6.8 is Vanilla as well?   

Okay Matt now back to the instructions posted directly above. Am I to assume that in order to:

"Boot up the USB and install SL"

"Boot back into the SL Installer but this time go into Terminal and Type this:

cp /*insertUSBnamehere*/mach_kernel /*insertVolumenamehere*/

 

That this would have to be a myHack modded SL USB installer to even get this far?

After I post this I will see if I can find an earlier version of myHack that would work on 10.5.5

Share this post


Link to post
Share on other sites

Hi there, sorry for the late reply. I do not visit this forum over the weekend. Before you waste your time, no, myHack does not support 10.5. Don't bother with 10.5, we can install 10.6 which is much better and can run newer applications.

First I need to clarify a few things:

 

Don't use the mv command, use the cp command; it overwrites every time.

Are you using the actual full copy of 10.6 or just a combo update?

If it is the full copy, is it modified in any way?

The version of Darwin doesn't specifically matter; it's referencing the build version of the OS so it would be different from 10.5 to 10.6 and also in Chameleon as Darwin/x86 boot is not the actual Darwin kernel but the version of the emulator firmware.

It would also be better to do a clean install of Mac OS X Snow Leopard rather than updating from Leopard. Try wiping your drive and trying again.

 

Anyway as to your final question when you finish installing SL you have to boot back up into the Mac OS X installer and copy the kernel from your USB to the root of your HDD to allow for booting.

 

Best regards,

 

- Matt

Share this post


Link to post
Share on other sites

Hi Matt! No apologies necessary because a late reply is better than no reply!! My SL is supposedly Mac OS X 10.6.0 Snow Leopard Retail DVD 7.15 GB (7,687,472,848 bytes) from the "Bay" and from what the documentation mentioned it isn't modified and is a copy of the retail DVD (so the story goes)

When you mention dont use the mv command          

 sudo mv /mach_kernel /  

 

Should I assume you are recommending

sudo cp /mach_kernel /

 

and if this is the case the mv command didn't overwrite the kernel? If it didn't I suppose all it did was copy it to the root / directory where it is just sitting in this directory taking up space and not doing anything?

 

I will find your answer quite interesting as your latest reply because my mind has become soft dealing with Windoze all of these years and as for Linux I'm not scared of the CLI but on the other hand If I don't know what to type in the Terminal it leaves me not able to finish the task at hand. 

​Now back to the iDeneb V1.3 10.5.5 and the expendable OS on the smaller spare drive, after I realized the limitations of the 10.5.5 Vanilla? Darwin 9.4.0 and because this is expendable I tried a genuine unaltered MacOSXUpdCombo10.5.8 to see what would happen. It started installing appearing to install the way it was intended but when the procedure was oh, about a third of the way through give or take, the Apple Black Window of Death appeared advising me to restart the computer by using the power or reset button. I shut the computer down, restarted and the boot started but then this Black window popped up as the boot froze. I would assume Kernel Panic? Probably the same thing as using the software update to 10.5.8 which actually worked a bit better than update combo where it actually rebooted to the desktop but a number of Apps wouldn't work. Since I have a good procedure to follow for installation I will reinstall 10.5.5 again with the proper patches and use the transfer feature to transfer everything from my working untouched main Hard drive like I did before which impressed me with how good it worked. Also after this latest update combo attempt happened I discovered there is an iDeneb 10.5.7, update combo kit including tools etc, 10.5.8 iDeneb update combo as well to use with the iDeneb 10.5.5 V1.3 or earlier versions. Sounds like the iDeneb needs modified iDeneb combo updates as well. 

I will look for these iDeneb updates as well (unless this is a waste of time?) and these will require some searching around due to dead links and being somewhat outdated. As 10.5.5 is installing I will look for these and first I will try sudo cp /mach_kernel / and the legacy Kernel again to see what happens. Correct me if I'm wrong about the command ( I will wait before I try) to use for the installation of the 10.6.8 Legacy. Like you mentioned about just installing SL being easier than this method, it probably is but I'm limited with myHack only being available for 10.6 and they eliminated the downloads for the older versions that would have worked and I suppose myHack is required? to do a clean install with the Retail 10.6. Yes I attempted to do a clean install but things locked up before I could use the disk utility to erase the drive, whether or not his would have helped to make the install work. 

Regards

Don

Share this post


Link to post
Share on other sites

I do recommend the cp command over the mv command because when you are at the final step, if you type mv then your mach_kernel will be moved from your USB to your HDD, making your USB useless. It is also good to keep a backup of the file stored safely just in case there is an error and it is lost.

 

About the combo update woes: combo updates before 10.6 (which is when the kernel was able to run most Intel CPUs natively) are very finicky, and most of the time they overwrite drivers or add new things which break compatibility.

One example of the latter was my old Laptop, it ran 10.6.3 (retail DVD) and it had Intel HD Graphics 1st Gen. When I tried to upgrade to 10.6.8 graphics drivers for my GPU were introduced, and they broke compatibility for my laptop. This is because the framebuffer used in the MacBook Pros was different to the one in my laptop, thus giving me a black screen on boot.

 

I will explain what process combo updates go through so you can understand why your applications don't work:

 

First of all they change drivers, system files etc. but then after that (at the very last part) they change OS identifier numbers.

 

So pretty much your critical system files are running 10.5.8 but your OS still identifies as 10.5.5. This breaks all compatibility as programs try to run on 10.5.5 mode but the OS is actually a mixture of 10.5.5 and 10.5.8.

 

I wouldn't bother with 10.5 anymore, I will install 10.6 on my P4 machine tonight and then give you a full guide about how I did it.

Share this post


Link to post
Share on other sites

Okay I did a clean reinstall, first I used the migration tool and it got me ethernet etc. all working and attempted to install the Legacy kernel relabeled mach_kernel I placed in my documents and typed the command

sudo cp /mach_kernel /

and got an indication  that the kernel was duplicated or already existed and grrrrrrr  :mad:  I figured by using the migration tool it copied my failed attempt from my other hard drive. Next I did another clean install (I'm getting good at this by now  :blush:  :thumbsup_anim:)   but this time I did not use this tool but installed the ethernet 4600 patch and again I typed sudo cp /mach_kernel /

and received

cp: /mach_kernel and /mach_kernel are identical  (not copied)

 

Next I used OSx86 Tools and used the app to update the kernel with the option of which hard drive and where it was and after  entering my password it went through the motions of installation, indicated the update was successful, and instructed me to restart the computer. 

Upon boot I get

 

Darwin/x86 boot  v5.0.132 - Chameleon v1.0.11

Build date: 2008-06-09 20:12:22

3711MB memory

VESA v3.0 64MB (NVIDIA)

Loading Darwin/x86 

 

Crikey and that is as far as it goes

Next I rebooted and pressed enter for more options and typed -x followed by enter and get the following

 

Darwin/x86 boot  v5.0.132 - Chameleon v1.0.11

Build date: 2008-06-09 20:12:22

3711MB memory

VESA v3.0 64MB (NVIDIA)

Loading Darwin/x86 

Loading kernel mach_kernel

Loading HFS+ file: [mach_kernel] from 4234670.

Loading HFS+ file: [mach_kernel] from 4234670.

 

exactly how I typed it here on this post and below this is the blinking cursor with no further activity  :worried_anim:

 

Now other than NOT using the migration utility as I suspected screwed me up the first time, I didn't disable the other hard drive and hopefully s  :censored:t  didn't get transferred from one drive to the next and i was careful to make sure i selected  the proper directories etc. and if diagnostics or items needing to be reinstalled is necessary i still have my other drive untouched. I will wait and see what you figure before another wipe and reinstall. Perhaps I should call this the Manhattan Project  :blowup:

One thing to mention as well now that i just remembered is it advised me to make a backup of the kernel first and my legacy kernel i directed it to was my USB drive so perhaps the backup is on this drive as well. I will reboot to my other drive and check.


It wasn't backed up to the USB drive but clicking on the other drive I labeled iDenebX to make it easier to identify the correct drive with the installed or should I say attempted installed kernel shows mach_kernel and beside it mach_kernel backup so it would appear something did happen and possibly a small repair can be performed from my working iDeneb_V1.3 drive?

Share this post


Link to post
Share on other sites

Well first of all the command to copy mach_kernel you used was wrong. Remember what I said in the 10.6 thread about the format of the command?

First you have to specify the directory you are copying from; in your instance you selected / so it would copy the file already on / therefore they are identical.

The correct command:

 

cp /Users/*YourUserName*/Documents/mach_kernel /

 

That should fix your first problem.

 

Your second problem about not getting past loading the kernel it is either a problem with your bootloader or a problem with the kernel, probably the latter, as OSx86 Tools are completely out of date and haven't been updated in years.

 

I apologise that I still haven't had time to install SL on one of my P4 machines; I have been quite busy recently. I have a free night tonight, so I will try and get it done today.

Share this post


Link to post
Share on other sites

cp /Users/*YourUserName*/Documents/mach_kernel /

 

No such file or directory!

cp /Users/johndoe/Documents/mach_kernel /            ???

or 

cp /users/ johndoe /documents /mach_kernel /          ???

 

There is obviously an error in the command and the mach_kernel IS unzipped and in the documents folder because even though everything is there I get the message that the diurectory or file does not exist and I have used many variations of this command. IE space after /Users /            cp /users/ johndoe /Documents /mach_kernel /

Share this post


Link to post
Share on other sites

All of the folder's names have capitals.

 

I got SL installed on my Pentium 4 computer; here's how

 

1. I made the install usb manually (mount the SL iso, go into Disk Utility, format your USB as MBR with Mac OS Extended Journaled, then restore the SL image onto your USB. Then put FakeSMC in /S/L/E and install Chameleon.)

2. I copied the legacy kernel to the USB and renamed to mach_kernel

3. Booted up and installed SL

4. Rebooted into the installer and went to Terminal and typed cp /Volumes/*InsertUSBNameHere*/mach_kernel /Volumes/*InsertHDNameHere*/

5. Booted into OS X and got drivers installed.

 

Try this and see what happens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×