Jump to content

Can't Boot to Snow Leopard Using Clover


15 posts in this topic

Recommended Posts

I've been trying for hours to get Snow Leopard to boot using Clover (v4035). I use to be able to boot this partition with Chameleon so I now it's a working install.

 

Can anyone help me with what settings I need to use in config? I have attached what I currently use for El Capitan.

 

Machine details are in my signature.

 

Any help would be appreciated.

config.plist.zip

Really? That’s interesting. It's crazy frustrating.

 

It's a legacy BIOS board.

 

My Sig:

Gigabyte GA-EX58-UD4P | Core i7-975 Extreme Edition | EVGA NVIDIA GeForce GTX 750 Ti 2047 MB | 12GB RAM | Mac OS 10.11.6 | Clover_v2.4k_r4035 | FakeSMC 6.23.1417 | SMBios MacPro 5,1

 

It could very well be the GTX 750 ti but I figured I could at least boot using nv_disable=1.

 

What exactly does the file you attached do?

 

I tried using Clover v3811 and put your attached kext into the 10.6 kext folder along with FakeSMC but still no boot. It boots to clover, I select Snow Leopard disk, it gets to "PCI Configuration Begin" and then stops.

Clover can boot from Tiger up to Sierra.

Enoch/Chameleon does the same.

It's only matter of using the right config and kexts for your HWare.

 

sent from my iPhone

 

I realize that. That is why I am asking here for help as to what my config.plist or other settings should be. What other users may use.

 

I currently boot into El Capitan with no issues at all, so I used the same config.plist (which was attached to my first post) to ask if anyone can see an issue with it re: Snow Leopard. Is there a certain version of Clover I need to use? Are there any settings I need or not need? Does the version of FakeSMC I use matter when trying to boot into SL? These are the issues I need advice about.

 

The only kext I currently need and use (to boot into El Capitan) is FakeSMC (with plug ins) and realtekALC.

 

I don't care about network or audio as I would just like to boot into SL for a few legacy apps.

 

It would stand to reason that the same configurations for my hardware should work with Snow Leopard, yet they don't. Perhaps it is my graphic card. SL may simply not be able to work with it. Can anyone confirm that? I do not have another card that I can swap in and out to test.

  • 4 weeks later...

The biggest problem I have with clover right now is no-matter which settings I put it doesn't give me any useful info when I try to boot with my OSX 10.6 containing partition - it just freezes on its nice pretty but useless GUI selection screen. I believe with older versions it gave me some meaningless numbers at least.

Currently I'm trying to boot the OS X 10.6 installation DVD using it. Before that I tried to boot the already installed OS (I used MBR based boot-loader to install it before) with the same luck.

I already hate Clover so much - is there any alternative to it for the 10.6?

Like it's un-acceptable for me that Clover is ignoring my simplest request to acquire more information about why the heck it isn't booting Snow leopard.


And before anyone asks - I want to install Snow Leopard because it supports Rosetta and so I can run Power PC games on it.

  • 4 months later...
  • 1 year later...
On 4/1/2017 at 10:41 AM, pkdesign said:

It's a legacy BIOS board.

My Sig:

Gigabyte GA-EX58-UD4P | Core i7-975 Extreme Edition | EVGA NVIDIA GeForce GTX 750 Ti 2047 MB | 12GB RAM | Mac OS 10.11.6 | Clover_v2.4k_r4035 | FakeSMC 6.23.1417 | SMBios MacPro 5,1

 

I know this is an old thread but the op used a MacPro5,1 SMBIOS that was not supported in SL until 10.6.8 and 64 bit boot only (most retail installers are 10.6.3 and default to 32 bit booting - see this blog post for difficulties when trying to install SL on a real MacPro5,1).

 

I originally installed SL 10.6.3 in standard 32 bit mode on my desktop GA-P55A-UD3 using Clover and iMac11,3 SMBIOS, then updated to 10.6.8 with the combo updater.  Changing the SMBIOS to MacPro5,1, the boot process would hang due to FakeSMC injection failing ---> in 32 bit mode, message about kext "thinning failed" appears in boot log.

 

The solution was to use an older FakeSMC version (eg Slice's FakeSMC ver 3.4.2 works but newer 3.5.0 does not, Rehabman's FakeSMC ver 6.21-315-gad4f8dd.1727 also works OK) and the following boot flags: -v arch=x86_64 -nehalem_error_disable

 

-v = verbose boot to confirm FakeSMC actually loaded
arch=x86_64 = force booting in 64 bit mode
-nehalem_error_disable = prevent kernel panic from AppleTyMCEDriver.kext when using MacPro5,1 SMBIOS without ECC memory

 

The advantage of the MacPro5,1 SMBIOS + latest Clover r4920 for my machine is that it allows me to boot macOS from 10.6.8 to Mojave 10.14.4 using the same config.plist  :)...

1032261090_SL10.6.8onGA-P55A-UD3SMBIOSMacPro51.thumb.png.d875ddf933618563308f8efa718cfb9f.png

 

 

SL compatible FakeSMC.zip

 

Edited by fusion71au
Attached SL compatible FakeSMC (Slice or Rehabman versions)

Hi Fusion,

 

This is very interesting to me. The SL on my hard drive 10.6.8. It was an old drive I was using before upgrading to HS.

 

I also use Clover 4920. I copied the FakeSMC that you provided (RehabMan version) and added the following to my config.plist:

 

    <key>Boot</key>
    <dict>
        <key>Arguments</key>
        <string>-v arch=x86_64 -nehalem_error_disable</string>
        <key>Debug</key>
        <false/>
        <key>DefaultVolume</key>
        <string>High Sierra</string>
        <key>Legacy</key>
        <string>PBR</string>
        <key>Secure</key>
        <false/>
        <key>Timeout</key>
        <integer>3</integer>
        <key>XMPDetection</key>
        <string>Yes</string>
    </dict>

 

The following is from preboot log:

5:443  0:001  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
5:443  0:000  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC.kext (v.1800)
5:451  0:007  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_SMMSensors.kext (v.1800)
5:457  0:006  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_LPCSensors.kext (v.1800)
5:471  0:013  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_GPUSensors.kext (v.1800)
5:476  0:004  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_CPUSensors.kext (v.1800)
5:477  0:001  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_ACPISensors.kext (v.1800)

 

When I tried to boot I get all the way to the followg andthen it stops:

IMG_3286.thumb.JPG.9ddf0f2a0d07b7279ccc1615699ed480.JPG

 

Not sure what is wrong.

@pkdesign,

 

From your screen shot, the good news is that FakeSMC is being correctly injected by Clover and is clearly loading during the boot process.

Bad news is that you have a different problem now: "still waiting for root device" means your system is waiting for a bootable system drive to appear and is not able to find it...

 

For some reason, the SATA port you have attached your old SL hard drive is not being recognised by Snow Leopard.

  • Try a different SATA port, make sure AHCI mode is enabled in the BIOS. double-check your BIOS drive priority?
  • What SMBIOS, 3rd party kexts did you use with Chameleon when you originally installed SL?  Have you tried Clover with this original SMBIOS + your old kexts in 32 bit mode?
  • Maybe add -x (safe mode boot) &/or -f (without caches)?

Might be easier to try a fresh "clean" install of SL with Clover, perhaps on a different hard drive eg externally connected USB hard drive or hard drive attached to a different SATA port?


Can you boot a SL 10.6.3 DVD with say MacPro3,1 SMBIOS or iMac11,3 SMBIOS in 64 bit mode?  If not, 32bit mode?

 

Good Luck!

×
×
  • Create New...