Jump to content
bigpoppa206

Older Hackintosh CMOS reset error on Sierra

11 posts in this topic

Recommended Posts

My signature should have all of my equipment info.  Everything has been running fine up until 10.12.4.  Booting with Clover and yes the AppleRTC.kext has been patched.

Share this post


Link to post
Share on other sites
Advertisement

There are reports, that users with latest clover revisions have the same problem. You could revert to older ones to test it.

 

Maybe the mainboard is just dying...

Share this post


Link to post
Share on other sites

Hi,

Maybe AppleRTC was not correctly patched ( maybe something is different from older one ) or something is related to New Clover version.

 

However you can try the old Kext ElliotRTC to see if help to resolve the issue.

 

Btw the Best Solutions is to patch AppleRTC and inject in Clover o DSDT some other patch to avoid cmos reset error.

Share this post


Link to post
Share on other sites

I tried that fix but it doesnt help me... Lenovo Thinkpad L420 here and I get it 2 out every 3 boots, since Clover 3270 somethin and with this new fix it happens like one of every 20 boots. I wonder if maybe something in Clover or in Mac OS X doesnt like the GUID partition scheme on a legacy BIOS system.

Maybe we all should try if this problem happens as well when having Mac OS and Clover in a MBR partition scheme???

Share this post


Link to post
Share on other sites

I've got this issue (CMOS reset) on an older hackintosh too (see my Sig for specs).

 

I've replaced the CMOS battery - but no change.

 

I'm running Clover v2.3k_r3994

 

I've got original Apple RTC in S/L/E and Patched 10.7 AppleRTC in EFI/kexts/10.12 folder and patched Apple RTC in Clover config.plist.

 

I've tried removing the kext from the EFI partition - result → boot loop. Same result with unchecking the Clover patch.

 

Interestingly - I have an old install Yosemite usb with Clover 2953 - which successfully boots up the machine.

 

Currently - the machine goes into a boot loop after resetting everything back to how it was - and is only booting from the usb. I'm installing latest Clover updat 3998. Will report back.

Share this post


Link to post
Share on other sites

Patched_10.7_AppleRTC only works on Lion as its name implies. Details of the patch for subsequent OS X versions are available here.

 

Clover on-the-fly patches only apply to patched kexts so do remove the patched Lion kext from your EFI/Clover/kexts/10.12 folder and rebuild your cache. The Clover patch should then be applied on the cached vanilla kext placed in /S/L/E. Of course, that's of limited help if the patch itself is incorrect for Sierra...

 

But afaik, the AppleRTC kext has not changed since Mavericks (v2.0) so it's the same patch in 10.12 as it were for Mav 10.9, Yos 10.10 and EC 10.11. I can also report that since patching the Sierra vanilla kext, my laptops no longer suffer from the longer BIOS POSTs that I did experience before using the patched kext. These longer BIOS tests were indicative of a CMOS write or write attempt.

Share this post


Link to post
Share on other sites

GA-P55-USB3 that was rock solid on Sierra until some time after the Security Update 2018-01 on January 26th

Now CMOS reboot loop on wake from sleep.

Have not seen this issue in so long I did not recognize it.

Will drag out working Sierra backup this weekend and see what changed.

Share this post


Link to post
Share on other sites

So, even my backup master that has not been updated started doing this - simplified cards in slots, tried other OS, not likely the hardware.
Definitely the AppleRTC kext changed with update, but that's not an explanation...   grrrr. was a great, stable elder hacintosh...

Share this post


Link to post
Share on other sites

The same problem on H55M-UD2H with xeon x3470.. It's jist cant awake from sleep – infinity loop of fail tries to wake up. Latest security update, latest clover version.. Have any news how to fix it?

Share this post


Link to post
Share on other sites
Posted (edited)

I'm having what appears to be the same problem with my Biostar TH55HD / X3450 system running Mojave 10.14.5 (CLOVER R4961 Legacy).   I just read on another forum that configuring S3 suspend state in BIOS with P55 / H55 chipsets results in BIOS corruption on sleep (even with CLOVER RTC fix) and that the solution is to change suspend state to S1 in BIOS.  This is the first I heard of this.  In order to make this change and try this fix, I will have to extract new DSDT.  Has anyone tried changing suspend state to S1?  I'll report back with my findings when I have time to test.

 

EDIT: I changed S3 to S1 in BIOS.  On sleep, displays go black and fans stay running (which I think is expected S1 behavior). System wakes normally with mouse or keyboard activity.  While I wouldn't consider this a "fix," this is the configuration that I'll run with until theres a working solution for S3 suspend state.

 

NOTE: Changing state S3 to S1 in BiOS did not result in any DSDT changes.  I thought that I had seen two OperatingRegion changes in my DSDT when I had experimented with suspend state before.  This might have been when I set suspend state to "Auto S1/S3" (instead of to either S1 or S3).  Not sure, but no DSDT changes were required for this 'fix."

Edited by tonyx86

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gengik84
      E' stata rilasciata la versione pubblica 10.12.1
    • By xJPN
      Hello all,
       
      I am attempting my first Hackintosh build on OS X Sierra (10.12.4). While doing so I seemed to have ran into a brick wall. I cant even get the initial setup going to install OS X. It gives a kernel panic every single time. I've tried everything I could think to do to try and fix this, problem is there wasn't really much I could think of besides to format and re-create the Install USB. Below, I will walk you through my hardware and the steps I've taken to reach said kernel panic. This post may be lengthy so, thanks to all that take the time to read it all and offer advice.
       
      Advisory: I use the Clover bootloader and Clover Configurator in the steps below. These are a must for me! (Sorry [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] fans)
       
      Hardware:
      Mobo: Asus Z170-Deluxe
      CPU: i7 6700K
      RAM: 4x8GB Crucial Ballistix Sport
      GPU: EVGA GTX 1080 Ti Founder's Edition (Not yet purchased, so not a factor as of now)
      PSU: Corsair RM750
      SSD: Samsung 850 Pro 512GB (yet to be formatted, used in a fully working previous El Capitan Hackintosh build)
      Install USB: PNY 8GB USB 2.0 thumb drive
      Current Mac: MacBook Pro 17", Early 2011


       
      Process:
      Step 1 - Download OS X Sierra from AppStore



      Note: As you can see from my System Info above, I have an SSD as a startup disk. This SSD is not very large in storage capacity so I use external thunderbolt hard drives to save all of my data. When I downloaded OS X Sierra, it was stored on said external drive.



      Step 2 - Format USB



      1 Partition
      Named "Installer"






      OS Extended (Journaled)
      GUID Partition Table



      Step 3 - Create Sierra USB Install Drive



      I was able to easily and successfully complete this step by using Terminal. Since my "Install macOS Sierra.app" wasn't in the default location, I simply had to point to it in the Terminal command.



      Step 4 - Install Clover Bootloader



      I used the following customization options when installing Clover Bootloader to my USB:





      Step 5 - Download kexts and other essential files



      FakeSMC.kext
      AppleIntelE1000e.kext
      VoodooHDA.pkg
      Clover Configurator.app
      Nvidia Web Driver
      Nvidia Cuda Driver
      Note: Put all these in a folder in the root of the install USB for post-install.



      Step 6 - Clover Configurator



      I used the following flags and other options in my Clover config.plist (Most things were left as default, not sure if this is the problem)





      Step 7 - BIOS Settings



      I used the BIOS settings in wildwillow's build guide here as reference, since he seemed to have the most similar hardware to me that I could find.
      Ai Tweaker > DRAM Frequency > Set to your choice of frequency depending on the memory.
      Advanced > System Agent (SA) Configuration > VT-d Disabled
      Advanced > (SA) Configuration > Graphics Configuration > Primary Display > PEG
      Advanced > (SA) Configuration > Graphics Configuration > IGPU Multi-Monitor > Disabled
      Advanced > USB Configuration > XHCI Handoff > Enabled
      Boot > CSM (Compatibility Support Module) Launch CSM > Enabled
      Boot > CSM > Boot Device Control > UEFI and Legacy OPROM
      Boot > CSM > Boot from PCI-E/PCI Expansion Devices > UEFI driver first
      Secure Boot > OS Type > Other OS
      Secure Boot > Delete all keys under Key Management (4 in total)
      Boot option #1 > UEFI macOS installation USB
      Press F10 and save the changes to the BIOS.



      Step 8 - Boot to USB (Kernel Panic)



      Clover Bootloader comes up fine, and begins to countdown. I selected Boot OS X Install from Install macOS Sierra , then the verbose log began to run. After a few seconds, kernel panic.
      Here are some pics of panic log(please excuse the dirty monitor...):


       



      So this is where I am. I haven't a clue what the problem even is, so I'm not sure how to go about fixing it. It's super frustrating to have almost everything in place, and some unknown error keeps me from just installing OS X. I know my hardware is supported. As stated above, the SSD I am using has been used in a previous Hackintosh build where I used El Capitan. As a test, I did install OS X Sierra on this SSD to see if it was stable. I haven't formatted the drive yet as the kernel panic issue hasn't allowed me to get to Disk Utility. However, I am not sure if that even matters. I am just at wits end and am trying to include every little detail so the experts here can perhaps find a solution for me. Anyway, thanks for reading. Any help offered is greatly appreciated!
       
      Best regards
       
      -xJPN
    • By KSDER98
      ciao ragazzi, ho usata la guida del sito per creare una chiave usb bootabile con sierra, ho digitato il comando per farlo in automatico, ma il terminale mi dice: /Applications/Install macOS Sierra.app/Contents/Resources/createinstallmedia: command not found
      se faccio gli altri due metodi la chiavetta non va. suggerimenti?
    • By gachogavacho
      My system:
       
      Motherboard: Gigabyte GA-Z170MX-Gaming 5 BIOS F20 (latest),  
      CPU: Intel Core i7 7700K Kaby Lake 
      CHIPSET: Intel z170 
      Storage: Samsung 960 Pro m.2 1TB
      Ram: Patriot Viper 16 GB (2-8GB Sticks) DDR4-3400 
      Video: MSI Radeon 5700 /w HDMI audio patch (but was trying to use integrated graphics previously and couldn't get acceleration   )
      MaCOS Sierra 10.12.4, Monitor: LG 21:9 34UM88 34-Inch UltraWide QHD.
       
       
      I cloned my drive, do I need to do any housekeeping like repairing permsisions? I saw some tutorials that are 5 years old that say I need to. Also, I had my original drive and cloned drive plugged in at the same time and when I booted the system from my cloned drive with the cloned drive in it still, it would hang for long periods of time with the spinning pinwheel. I removed the original drive and it worked flawlessly. Any insight to why it would do that?
       
      Do I have to enable trim like with other SSD's do I?
       
      I'm attaching my IO Reg, hoping anyone with some time can tell me if i'm missing anything here also. 
      Send me Gachogavacho's iMac.zip
      Gachogavacho's Imac.zip
    • By meaganmargaret
      Mieze:
       
      After upgrading to 10.12.4, my Ethernet ports are not working. Wifi is, but any Ethernet LAN port will not work. I've tried three different ethernet cards, including my internal motherboard card/port, and none are working. I have the latest IntelMausi driver from ReHabMan, (3/21), but nothing seems to work.  Tried other versions, no luck.
       
      None of the cards will accept DHCP. You can manually address them, and they do respond to a self ping, but they cannot ping anywhere else. Not to my local router, (or any local IP addresses), and not to the Internet.
       
      I tried removing all of the network interfaces and the plist and rebooting - that didn't work either.

      Internal Ethernet chip is: Intel® I218V, 1 x Gigabit LAN Controller

      $ kextstat | grep Mausi

      64 0 0xffffff7f83ac3000 0x24000 0x24000 com.insanelymac.IntelMausiEthernet (2.2.1) 43B3C3B1-E032-3C2B-8598-320889964F57 <53 12 5 4 3 1>

      ping 8.8.8.8

      PING 8.8.8.8 (8.8.8.8): 56 data bytes
      ping: sendto: No route to host
      ping: sendto: No route to host
      Request timeout for icmp_seq 0
      ping: sendto: No route to host
      Request timeout for icmp_seq 1
      ping: sendto: No route to host
      Request timeout for icmp_seq 2
      ping: sendto: No route to host
      Request timeout for icmp_seq 3
      ping: sendto: No route to host (but adding a default route doesn't work either, as the route shows as already added (or the Wifi card wouldn't be able to get to the Internet).

      I do have loaded the latest drivers from NVidia for 10.12.4. Most everything else works, just would like to get one of my wired Ethernet ports working.

      I have an Asus X99-A II (Bios version is 1501), 64 GB of DDR4 RAM, NVMe Samsung drive, GTX 980 TI with the latest drivers from NVidia, and of course 10.12.4. Most everything works. Just would like to get my LAN cards working.
×