Jump to content

Jas 10.4.8 Install DVD: Display shuts off after grey apple Screen


23 posts in this topic

Recommended Posts

I have tried many times but Display shuts off after grey apple Screen at the very begining of installation. I have also tried to input mach_kernel.mifki -v in startup option, mach_kernel is loaded but still incurred same problem. My laptop is Dell640m with T5600/Intel 945GM.

Link to comment
Share on other sites

try a diff monitor else if you have DVI I think it is use that dvi to vga converter.... I had that prob with my one monitor....... I dunno but OSX detected it as something and would I guess work with it wrong causing it to go on energy saving:P


oh {censored} your using a laptop dunno then.... try playing with the video drivers..... boot in safemode see if it does the same.... didn't do same for me in safemode..... if it does the same then diff issue:P


again nothing its during installation so..... maybe try hooking a external monitor:P

Link to comment
Share on other sites

Hi, guys. It seems it is the same problems for all Dell laptops. I have disabled one core in bios and I don't have an outside moniter. I don't think it is video driver problem as my configuration is T5600/Intel945GM/GMA950. If we can get a solution, then it should work for all Dell laptops.

Link to comment
Share on other sites

Same problem re black screen - Initial grey Mac screen, then Black screen (no curser, no GUI). System seems to keep on booting.


Compiled semthex kernel and installed.

Compiled mifki kernel and installed.

Tried to boot with Jas DVD.

Tried external VGA monitor (no video)

Tried various BIOS and boot parameter changes (-s -v -x cpus=1, platform=acpi, etc...). Result - Black screen.


Even verbose mode goes to Black Screen after initial kext loads (I believe ACPI is the last to load).


Dell 6400 Laptop

Core DUO 1.67 Ghz

GMA 950 graphics


It appears this kernel or the kexts do not provide GMA 950 graphics support (or support for laptop LCD ...) ?


This laptop also ships with ATI graphics - Anyone get it to work ... ?

Link to comment
Share on other sites

Finally got it to work using the suggestion by Joe75 at this topic:




Basically install 10.4.8 Apple update over an existing 10.4.8 JaS install and then replace kernel, kexts and repair permissions. My problem appears to be that one of the kexts was missing or I needed the r2d2 kext.


Cheers ...


Dell Inspiron 6400

Core Duo T2300 1.67 Ghz (unfortunately must disable one core or stutter ... still)

GMA 950 graphics (100% working incl res, QE, CI, dual display, rotate, sleep, etc..)

Sigmatel 9200 (no sound as usual)

Dell DW1390 (shows as airport)

Sata (works)

Sleep works for display mode only. Computer sleep can never wake up display.

etc ...

Link to comment
Share on other sites

I'm still having this problem (I've grabbed the reseed). I only have a copy of the JaS 10.4.8 Full DVD Reseed and I'm just getting involved with OSx86 so, although I've been browsing the wiki and the forums, I can't seem to find a fix for this. Is there any chance someone could point me in the right direction of a step by step?


Dell Inspiron 6400 just like everyone else.

Link to comment
Share on other sites

i have the same problem here but im on a dell 640m with the t5600 core 2 duo


the install works fine on my external

but to get there i just blindly press enter when the cd stops working (when i get black screen)


nyways.. if anyone has a fix this would be nice .. thx lots


Ok, i found a way to enable the secondary display(crt) . Just press the fn button with f8 in my case witch is labeled crt/lcd and then boom .. display on the secondary monitor popped out. I am installing it right now and will post to tell you guyes if it went well

Link to comment
Share on other sites

got it working on dell 6400 with external monitor with jas's reseed, boots fine without the dvd in the drive after install but wireless doesnt work. its detected but deactivated gma950 works fine with full qe/ci. about this mac works fine, and ical too. still only one core though and no sleep! keep up the good work , success is surely just days away - maybe? hmmm.

Link to comment
Share on other sites

I have the same problems on my Dell E1405 (BIOS just updated to A05). I have tried again after completing the download of the re-seed. I will continue to seed this for everyone as it seems to only affect Dhell customers. :thumbsdown_anim:


Here are my computer's specs:


Intel Core Duo 2.0 GHz T2500

Intel 945GM chipset

SigmaTel STAC 92XX

BlueTooth 350

Intel Wireless 3945ABG (Just purchased a Dell 1390 off of E-Bay)

Broadcom 440x


100GB 7200RPM SATA Hard Disk ::


Partition #1 - Windows XP Pro w/ SP2

Partition #2 - Windows Vista RC2

Partition #3 - Mac OSX 10.4.6 (HOTiso) -- Fresh Install

Partition #4 - Ubuntu 6.10


I am open for any suggestions.

Link to comment
Share on other sites



same problem here: I tried to install on my Inspiron 6400 (GMA950) via the "MAC OS X 10.4.8 Intel Only Jas re-seed (SSE3 Only - NO AMD)" from the Green BT-Site. First I attempted to install and after the white screen with the Apple Logo the screen went black. After reading this thread I connected my CRT und switched over to it via Fn-F8 - this worked. I can even switch back to the laptop and get a picture there....

Maybe the two-wire-trick would also work.


Then I ran into the next problem: the menu to choose the standard language (btw: i'm german so please excuse my bad english...). The whole screen was distorted into length - I couldn't see the button to press ok. I got over this by choosing with the arrow keys and pressing enter. After that the installation program started - and here i am right now trapped: i can't choose the button to start the installation. It is under the frame of the screen - screen adjusting wouldn't help. This has to be a software issue; it just doesn't paint the part that is outside the screen. I tried several different screen resolutions but none worked - when the resolution gets to high it isn't only stretched into length, the picture then also consists of weird stripes and the screen becomes unreadable.


I guess this maybe due to the fact that Darwin shows something about 7 MB video ram (should be more...).

Would be so cool if you could help me - I wasted quite some time with this (searching, getting out if the hardware is supported etc. pp.) and getting an result in the end would be quite nice.

If someone could tell me the keys to press in the different installation stages this would be as helpful as a way to get the distortion away.


Thx in advance

David, who is now really frustrated


Edit 1: I'm using the newest Bios (A09) and I have disabled one core of the processor.

Edit 2: The display is the 15,4'' 1680x1050 display.

Link to comment
Share on other sites

  • 1 month later...


I thought I will go ahead and post this since so many people have the same problem and trying to install using CRT monitor . This worked for me using CRT monitor.

1. When the installation DVD boots and if it goes blank on language selection screen then hit FN+F8 key so the CRT monitor becomes your primary display monitor

2. This is where we have encountered the stretchable screen where half the screen is cut off or you cannot see the bottom half and adjusting your monitor won't help.

3. While on language select window, do not do anything until you hear the installation dvd STOP SPINNING and go quite.

4. Now unplug your CRT monitor connect and plug it back in and if the display does not show up in both screen then hit FN+F8 so the display will show off on CRT. This time around, you should be able to see the whole screen

5. Like I mentioned, in order for this to work, THE INSTALLATION DISK HAS TO COMPLETELY STOP SPINNING and IT will Stop Spinning once it does not detect any user input after certain time period.


Like I mentioned, I don't know if this will work for you but I tried this on two different CRT and I tried it 4 times. It worked for me all 4 times.



Edited by Reb
Link to comment
Share on other sites

  • 2 months later...

  • Create New...