Jump to content

Mac OS x86 10.4.6 Installation Problem PICTURES INSIDE


21 posts in this topic

Recommended Posts

Partition Map Read Error Problem


hey guys,

i am seriously having one frustrating partition map problem that i seriously can not fix.


So I am trying to install a Mac OS x86 10.4.6,

and my PC has the right specs to run this operating system


I have Acronis already activated and everything,

and i also DO have Norton Partition Magic installed (but i do not use).


So I have been following the guide all the way up to the part where it says

choose the partition you made from step 2, and change the drop down list to "Mac OS Extended Journaled" then click ERASE.


right when its trying to erase (it doesnt even erase it)

it says

"Erase Failed,

Could no read partition map"


and i have no idea what to do!!! can someone please help me out?



Here i have taken some pictures on my point of view,

exactly what im talking about, hope this helps!! :happymac:


ok, so i first go through the beggining installation processes:



then, i get to my problem:

i do everything right



i click the erase tab



I choose mac osx journaled



i click erase



i confirm my erase



and in about 5-10 seconds, my problem occurs:



and i even did a varification if my partition was working correctly, etc..




i cant seem to find the solution to this problem.


much appreciated to all giving time to help me out.



Edited by r2 studios
Link to comment
Share on other sites

ive tried just about everything inside of the osx installation CD to get this error fixed.


the only things i havent worked with too much in the osx installer is the terminals utility.


other than that, ive done everything else,

so im pretty sure i have to fix this error by using my windows xp operating system.




let me try it with partition magic...

Link to comment
Share on other sites

wait a second...







so i just opened up partition magic,

and i am increasing my unallocated space and defragmenting.




i am going to use the partition table tool to fix the reading.....


does anyone know if this should work?

this is about a 1 hour process.


*crosses fingers* :compress::hysterical:

Link to comment
Share on other sites

I had this SAME issue and I also used partition magic. My problem was that apple was the 3rd partition (In order: XP, Kubuntu, Apple) and it didnt like that. So I deleted the Linux partition (bring apple to the second primary spot) and then went into partition magic and deleted my apple partition and made a new partition that was fat32 primary, but did NOT label it. In partition magic, the partition read as *.fat32* (or something like that). I think that if you label it, windows automatically associates it with windows and therefore is no longer a 'lone partition'.


Just deleting and redoing it without a name, see if that works.

Link to comment
Share on other sites


let me give that a try........



does anyone else have a second option i can use?


ive been testing a few other things with partition magic but not the one above.








any more suggestions?

Link to comment
Share on other sites

Ok I had the same problem and fixed it. Your partition needs to be primary and possibly the first one on the hard drive. You should create it with any partitioning program like diskpart under XP or partition magic, parted / fdisk under linux whatever.


Do it this way: create an unformatted partition (primary) and change it to type 0xAF.


Boot the install CD. Run disk utility. Select the partition which should be grayed out (e.g. disk0s1). Go under the erase tab, select MS-DOS, click erase. Then select HFS+, click erase.



Exit the disk utility, and Tada! you can install on your new partition.



Hope that helps

Link to comment
Share on other sites



nothing works for me.. :\






im going to reformat all drives and start from total clean.

if this doesnt work, then im done for.

because i have a feeling that my D partition is screwing my partition maps up.



hopefully this works.

its my last resort!

Link to comment
Share on other sites

  • 1 month later...

try using a GParted linux live CD to resize your main partition, then make a new primary fat partition after your main partition with Gparted, PartitionMagic or Acronis Disk Director


It shouldn't have anything to do with your hardware




also, look at this thread, dilnalomo's method works great!




I haven't had much success partitioning with acronis, but gparted works great

Edited by luketc
Link to comment
Share on other sites


  • Create New...