Jump to content
Sign in to follow this  
Followers 0
v7kF4U2HTd

leopard haswell kernel

10 posts in this topic

Recommended Posts

yes indeed, i'm trying to run 10.5.8 on a haswell because i have certain software that needs 10.5. for that to work i grabbed the haswell patch for 10.6 and applied as much as possible to the 10.5.8 sources.

now the 10.6 patch hardcodes

uint32_t cpufamily = CPUFAMILY_INTEL_SANDYBRIDGE;
into cpuid_set_cpufamily() which doesn't exist in 10.5's cpuid.c. so instead i edited machine.h and used the haswell id (0x10b282dc) for the definition of CPUFAMILY_INTEL_NEHALEM hoping to make it think it's a nehalem.

 

yup, you guessed it, it didn't work. the kernel stops with an "Unable to find driver for this platform" panic from IOPlatformExpert.cpp so i guess i wasn't able to trick it successfully. any help is most welcome :)

 

 

btw, the Enoch chameleon seems to have something in that regard that sounds promising but unfortunately the installer fails

Share this post


Link to post
Share on other sites
Advertisement

not yet, i've actually not used clover at all. does it even support 10.5?

 

EDIT: i tried clover and it was actually worse than with chameleon but i might have to dig deeper into the config. however, i'd prefer modifying the actual kernel instead of spending hours going through the clover config for the off chance that it might have a better effect than changing the cpu id in the kernel's source that i did already

Share this post


Link to post
Share on other sites

i tried a lot more with clover and it seems it's willing to apply the fake cpu id but it doesn't seem to find the kernel. something like "kernel not found at 0x20000".

maybe clover needs a special option for 32bit or is 10.5 not supported at all?

Share this post


Link to post
Share on other sites

Clover supports OSX from Tiger to Sierra. ( also Chameleon/Enoch)

 

IMO It is not a problem of bootloader or FakeCPUID.

 

I was able to boot osx Tiger on Intel Core2Duo, but i got "unkown Platform" on Intel Core i5.

 

Simply old Osx don't known how to manage new CPU/Platform .

 

You probably need a patched IOPlatform.kext to run Leopard on your Haswell computer .

 

I tried a lot to boot Tiger / Leopard on my Intel i5 , but until now i don't have found the right way ...

 

See Ya

Share this post


Link to post
Share on other sites

Simply old Osx don't known how to manage new CPU/Platform

yeah that's the thing, 10.5 supported nehalem and if i hardcode the 10.6 kernel to nehalem it works. haswell wasn't supported by 10.6 either but it works anyway if you force the cpu family in cpuid.c to nehalem or above. going by that i'd assume that since 10.5 supported nehalem as well it should do the trick.

hence i wanna do the same with the 10.5 kernel but cpuid.c is different from the 10.6 version so i need to find the right place for enforcing the cpu family.

Share this post


Link to post
Share on other sites

Hi,

regarding the issue to run apps which need Osx Leopard ; do you try yet to trick apps to run in 10.6 instead of 10.5?

 

This can be achived modifing SystemVersion.plist from 10.6 to 10.5.8

 

 

 

 

Sent from  iPhone/iPad

Share this post


Link to post
Share on other sites

after some more checking and research i found another possibility why it doesn't work. might be totally wrong but anyway, it's about the chipset.

core2 and nehalem which are supported by 10.5 both share the same family (IHA). haswell however doesn't, it uses the newer PCH.

now sandybridge uses PCH as well and since that's supported by 10.6 this might be the reason why the haswell works there but not with 10.5 so the cpu id alone wouldn't be enough of course in this case. and that would also explain why i get an "Unable to find driver for this platform" from the 10.5 iokit despite a matching cpu id.

 

in that case my little project here would be over because backporting PCH from 10.6 to the 10.5 kernel would be way out of line ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×