Jump to content

Sandy Bridge-E & Ivy Bridge-E Power management 10.12 Beta

55 posts in this topic

Recommended Posts

  • 2 months later...

The XCPM doesnt work with sandy bridge, Sandy bridge E and Ivy bridge E. Piker Alpha found a couple of new pacthes that can enable the xcpm on the future.


I have the Asus Sabertooth X79 Motherboard MSR not locked.  My CPU is the E5-2697x2 Ivy Bridge 12 core.  I thought in version MacOS 10.11.x I needed the kext  10.11 X79PlatformPlugin.kext and for MacOS 10.12.x but X86PlatformPlugin loads with or without this kext for me with 24 values in IOReg both for CPUCStates and CPUPStates.  I must have misunderstood some things but is this processor CPUPM suppose to be supported directly by the kernel XCPM?  Right now in 10.12.6 X86PlatformPlugin loads so I am assuming this means ACPUPM kext is the one supporting CPUPM and not XCPM?   Is there some Binary fix in Clover to get XPCM to load?  I am using SMBIOS MacPro6,1.




Edited next day:


Found out that the real MacPro6,1 natively uses AICPUPM, but still not clear if I need the 10.12 X86PlatformPlugin or not?  As I said it loads fine without adding this kext, I just need to see if I am getting more P-states with this kext versus without.



  • Slice pinned this topic
  • 1 month later...
On 4/18/2017 at 11:42 PM, venganzarte said:

Hi, I was running into issues with getting Pstates and turboboost working with a xeon E5 2670 on huanan X79 motherboard. Tried lots of different things but eventually got it working. Had to run the 

10.12 aicpm patch.command.zip and add 10.11 X79PlatformPlugin.kext.zip  as directed  followed by the install.command.zip  had to run a few times to fix all permissions. I then removed all entries of the kext nullcpupowermanagement.kext.

from installation drive and clover kext folder. I removed all entries from acpi section of clover but ticked only drop OEM. The config did not work till i entered bios and reselected default profile for cpu power management with eist enabled.

Benchmarks on geekbench4 now run slightly faster than my linux install. I think the fakeSMC sensors are a bit off as I am consuming slightly less power at idle yet monitor shows slightly higher clock speeds when comparing with linux install. Can also confirm worked on mac-mini 5.1 and mac pro 6.1. But decided to stick with Mac pro as seems to have lower idles.

I did test clover settings and bios settings and pstates were still not working so must be patch and x79 kexts, many  thanks to the providers

Can you send me your Clover folder? I have Xeon E5 2680 v2 on Huanan X79/C602 Deluxe but I can´t enable work Pstates and cpu work only 2,8 Ghz all the time. Thanks

  • 1 month later...
  • 1 year later...
  • Create New...