Jump to content

Yosemite Installation went fine. First boot doesn't want work


5 posts in this topic

Recommended Posts

Hello,

 

I installed Yosemite-Zone successfully into my Laptop without custom arguments, or kernel. Just the Clover's default args.

So I restarted, and choose to boot OSX (through Clover) it restart without errors, same story with -v, -x, "no kext inject" and "ignore cache" (or something like that) always through Clover configuration menù. IDK if it has been removed but I never saw the Darwin Boot Loader not even in the installation. (I copied the Extra folder and the kernel from the Installation USB key to the Installed OSX)

 

My spec:

APU: AMD A6-4455M

GFX: AMD Radeon HD 7500g

MSB: Acer Havok V5-551 (UEFI Mode Enabled)

Explain to us in detail how you have successfully started your AMD APU system by using Clover bootloader with vanillia kernel, I am very curious to hear your response. :rolleyes:

  • Like 1

Explain to us in detail how you have successfully started your AMD APU system by using Clover bootloader with vanillia kernel, I am very curious to hear your response. :rolleyes:

Sorry but I didn't use the stock OSX's "vanilla" kernel, just the Yosemite-Zone's default one (there are like 7 kernels) I wrote it because is weird, the default one should not work with AMD, there is the "amd" kernel, where you have to manually load through Darwin Boot Loader (Well, in Mavericks was like that). BTW some peoples told me that I will not receive any help from the community because Distros are not legit, Sorry, I didn't know. I'm trying to download the vanilla OSX and do the steps with Pandora. Thanks anyway.

Hi,

 

You need to specify the AMD kernel at boot. Since your installation media has too many options, i can not give a recommendation on how to do this. 

What packages did you select? 

 

Hate to say this, but perhaps you have better luck on their forums. Or go here: http://www.insanelymac.com/forum/forum/418-amd/

Hi,

 

You need to specify the AMD kernel at boot. Since your installation media has too many options, i can not give a recommendation on how to do this. 

What packages did you select? 

 

Hate to say this, but perhaps you have better luck on their forums. Or go here: http://www.insanelymac.com/forum/forum/418-amd/

Well that's hard to say but I have a theory, first of all, Yosemite-Zone has "amd", "amd1", "amd2", "amd32" and "amd64" kernels, (except other platforms' kernels) unfortunately I don't find any specification about the difference between those kernels. And there start the weird thing, Yosemite-Zone (iso and dmg) as far I can see doesn't support native UEFI mode booting(I tried both iso and dmg, both has EFI PE exutables but the UEFI firmware can't boot em) so I partitioned my USB and created manually an UEFI partition (by using GParted) installed manually Clover into It (when i say installing I mean copying Clover iso files) and copied Yosemite-Zone.iso files in the 2° HFS+ partition, so I created a fully working bootable USB key to boot this Distro. So I rebooted my PC and choosed USB to boot, so Clover showed up, I choose to boot the 2° partition on my USB key and Yosemite Installer started, so the Darwin Bootloader didn't started (and didn't let me pick the amd kernel),(remember that the clover installation is the stock one, no configs!) (I tried in VirtualBox uefi disabled and Darwin Bootloader works, so it's included in the default master boot record (in virtualbox I had to pick the amd kernel or I get kernel panic (same machine)) so my theory is that in somehow Yosemite-zone's UEFI bootloader pick the best kernel for your machine. Otherwise I don't know what to think, or how Clover started Yosemite Installer without passing through Darwin Boot Loader

×
×
  • Create New...