Jump to content
kkc

Disabling SIP in El Capitan under VMware Workstation Pro Running on Windows 8.1

15 posts in this topic

Recommended Posts

As I am developing some apps on windows which needed packaging for Mac, I created an El Capitan VM in VMware workstation pro V5. Then realized that OSX is now SIP protected... aaaargh...!  And despite trying different key combos, I could not boot into the OS X Utilities menu so that I could use "csrutil disable" in Terminal.

 

Finally figured it out and so here it is for anyone who also hates losing time like I did.

 

Disabling SIP
1. Start vmware
2. select guest and "power to firmware"
3. in efi menu, enter setup > config boot options > add boot options > select recovery partition > select boot.efi
4. at input file description hit <enter> and type in label e.g. "recovery" > commit changes and exit
5. boot from recovery and be patient
5. follow prompt until you see OS X Utilities menu
6. At the very top menu select Utilities > Terminal
7. In terminal enter "csrutil status"
8. then csrutil disable
9. then csrutil status
10. then reboot > hit enter once or twice

11. Double check in OSX Terminal app to ensure SIP is disabled

 

Enjoy..!

Share this post


Link to post
Share on other sites
Advertisement

As I am developing some apps on windows which needed packaging for Mac, I created an El Capitan VM in VMware workstation pro V5. Then realized that OSX is now SIP protected... aaaargh...!  And despite trying different key combos, I could not boot into the OS X Utilities menu so that I could use "csrutil disable" in Terminal.

 

Finally figured it out and so here it is for anyone who also hates losing time like I did.

 

Disabling SIP

1. Start vmware

2. select guest and "power to firmware"

3. in efi menu, enter setup > config boot options > add boot options > select recovery partition > select boot.efi

4. at input file description hit <enter> and type in label e.g. "recovery" > commit changes and exit

5. boot from recovery and be patient

5. follow prompt until you see OS X Utilities menu

6. At the very top menu select Utilities > Terminal

7. In terminal enter "csrutil status"

8. then csrutil disable

9. then csrutil status

10. then reboot > hit enter once or twice

11. Double check in OSX Terminal app to ensure SIP is disabled

 

Enjoy..!

You could do it simpler with your boot loader settings. Clover can do that perfectly.

Share this post


Link to post
Share on other sites

You could do it simpler with your boot loader settings. Clover can do that perfectly.

 

This does not use bootloaders like Clover. It is a close to a real Mac as is possible in a VM.

Share this post


Link to post
Share on other sites

This does not use bootloaders like Clover. It is a close to a real Mac as is possible in a VM.

Either you don't know what you are talking about or don't know which boot loader you are using, or the VMware doing something illegal...

Share this post


Link to post
Share on other sites

Either you don't know what you are talking about or don't know which boot loader you are using, or the VMware doing something illegal...

 

Uh I wrote the VMware unlocker with nearly 400000 downloads and know how VMware do this. VMware is using an EFI firmware image and boot vanilla OS X on Fusion, and with the unlocker on Workstation and ESXi. It does not use any 3rd party boot loaders.

Share this post


Link to post
Share on other sites

Donk... thanks for the unlocker ...!! awesome... !  I really did not want to buy a mac just for packaging couple of apps.  Also the boot to EFI is perfect... as it gives access to virtually any object at the bootstrap level.  I haven't tried connecting an apple device yet - iphone or ipad... leave that for another day...!

Share this post


Link to post
Share on other sites

Uh I wrote the VMware unlocker with nearly 400000 downloads and know how VMware do this. VMware is using an EFI firmware image and boot vanilla OS X on Fusion, and with the unlocker on Workstation and ESXi. It does not use any 3rd party boot loaders.

Well, I didn't know that. I thought that one needs a boot loader even after using your unlocker. Good job on that, I didn't mean anything negative on your job...

Share this post


Link to post
Share on other sites

Either you don't know what you are talking about or don't know which boot loader you are using, or the VMware doing something illegal...

WOW, that funny! You really have no idea yourself (what you talking about & who you reply to!)

 

sebus

Share this post


Link to post
Share on other sites

WOW, that funny! You really have no idea yourself (what you talking about & who you reply to!)

 

sebus

Yeah, I didn't know how VMware works and who I replied. I thought, that it was the OP...

Share this post


Link to post
Share on other sites

Hi.

 

I wonder, how can you work with kexts or something from MAC os X in vmware. Should you (and if it possible) to install Clover or something?

 

I've tried installing refind - it works and adds some options. But when I try to run Clover - it fails. Any ideas?

Share this post


Link to post
Share on other sites

Even it is not needed, if you disabile Efi , and you want boot OSx in VMWare, you could install/ use Chameleon or Enoch bootloader.

 

On my trials with Clover ,i was'nt able to boot Osx on Vmware.

 

See Ya

Share this post


Link to post
Share on other sites

I tried installing Enoch, but I cannot get to boot menu. I can do it with Clover or Refind. I've tried installing refind, but there's one option only. When I tried refind + clover, clover was listed as an option.

Share this post


Link to post
Share on other sites

Hello.

 

I have VMWare Workstation (not Pro) and am having trouble getting the SIP for my Mac El Capitan turned off.

 

Reading your post, you say

 

2. select guest and "power to firmware"

 

 

 

Looking through all of my settings, with the guest powered down, I can't seem to find that option anywhere.

 

I've googled for it, but either I am not entering a good search phrase, or I'm going blind (both possible).

 

Where is this option located.

 

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×