Jump to content
Sign in to follow this  
Followers 0
duduclx

[solved] HD550 hp elitebook displayport

2 posts in this topic

Recommended Posts

Hi all,

 

I've started to install El capitan on a HP elitebook 820 G2 with i5 5300U and HD5500.

 

The video card is working good, native screen resolution, 1366x768,

set as internal dispay, and recognised as Intel HD Graphics 5500 1536 Mo.

i have 512Mb video dedicated memory setup in bios.

 

But when I connect a second screen on the displayport, all display turns on black screen.

 

I used rehabman laptop patches for my dsdt:

:[bat] HP ProBook-4x0s-G1
:[sys] AC Adapter Fix
:[sys] Shutdown Fix v2
:[igpu] Brightness fix (haswell)

 

I used ssd broadwell generator script.

 

I patched AppleintelBWGraphicsFramebuffer binary with clover:

find

02001616 01030303 00002002 00005001 00000060 6C050000 6C050000 00000000 00000000 00000000 00000800 02000000 30020000 01050900 00040000 07050000 0204

replace

02001616 01020202 00002002 00005001 00000060 6C050000 6C050000 00000000 00000000 00000000 00000800 02000000 30020000 01050900 04000000 04000000 FF04

 

Without the patch of the AppleintelBWGraphicsFramebuffer dispayport is not effective (nothing appened when i connect a second screen, not recognized).

With it, second screen connection give black screen.

Not sure of what i do by patching this ^^

 

I also tried dsdt patch to rename gfx0 to igpu, have no effect.

 

btw, light/brightness control is enabled is monitor preference, shortcut respond, but nothing effective.

i patched the dsdt with the brightness fix for haswell and use the last ACPIbacklight.kext.

 

Here some stuff used

https://drive.google.com/file/d/0B-sUmdgLOBgBSnVMdkdDU21tUk0/view?usp=sharing

and a tutoriel of what i've done (in french):

http://www.insanelymac.com/forum/topic/307270-hp-elitebook-820-840-g2-i5-5300u-hd5500-el-capitan/

 

I attach my ioreg to the post.

hp-elitebook-820G2.zip

 

Any helps and ideas are welcome !

 

Cheers

Share this post


Link to post
Share on other sites
Advertisement

hi,

 

rehabman updated is config.plist.

 

The last one is working perfectly.

i now can use display port without issue.

hot plug/unplug is working.

 

thanks to rehabman !

 

https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD5300_5500_6000.plist

 

this topic can be closed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ltooz_audis
      After i finished updating macOS High Sierra on HP x360 15-u011dx Haswell HD4400 i7-4510u, I started to update my daughter Dell Inspiron 7352 Broadwell HD5500 i7-5500u. It was a little harder but it works quite nicely. The new Clover is Buggy with the cache that cause "Error loading Kernel Cache..." that I had to re-install the OS. Kernel Panic all the time until I got the config.plist and kexts correctly. Now it's a perfect little 13" MacBook Air7,2. If you have anything thing with a "u" at the end of the CPU, don't use macbook pro, it doesn't do you any good.
      I'll have full tutorial soon.
       


      Make sure to have en0 built-in without Ethernet Built-in

       
      Cheers,
      Louis
    • By Phaetherap
      Hi all,
       
      I'm doing a mackintosh in a EliteBook 840 G2.
       
      it has an Intel HD 5500 Graphics Card.
       

       
      and I can't figure out how to make it work properly, when I check Inject intel on clover I get this loop below, it keep looping over these two different lines:
      RTUSBWriteMACRegister: Offset = 0x1314 - Value 0x3030505 ... AGS: ---> MlmeDynamicTxRateSwitchingAGSv2 ... RTUSBWriteMACRegister: Offset = 0x1314 - Value 0x3030505 ... AGS: ---> MlmeDynamicTxRateSwitchingAGSv2
       
      here is my CLOVER folder with my current config.plist:
      CLOVER.zip
       
      if someone can help me with this I'll be so glad.
    • By Skyy_0
      Title says it all. I have an R9 390 working great on Sierra thanks to cyberdevs on this forum.
       
      That being said, I still have no audio and have "No Audio devices" in settings and system report. 
       
      I'm running a displayport cable from the R9 390 to my monitor, an XR341CK, and was hoping to get audio from the built-in speakers.
       
      Anyone have any ideas?
       
      I've already tried installing the RealtecALC.kext for the ALC887 codec in S/L/E.
       
      Running this via onboard audio on my ASUS B150M-A mobo.
       
      Thank you in advanced - lord knows this forum has saved me from plenty of headaches.
    • By frees11
      Hi I have Acer Predator 17, 6700hq, 17" gsync display and Nvidia GTX 1060 6GB without internal gpu - laptop display is hooked to gpu directly so are the display port and hdmi connectors. I have newest pascal webdrivers. Everything works fine under sierra except I can't turn on my 4k display connected via displayport - it just says no signal and whole gui on laptop display is frozen. When I disconnect displayport, gui works again on laptop display. Does anyone have similar problem and solution?
       
      Also I have problem when I play Hearthstone with some light artefacts. It's common on nvidia gpus or this is hackintosh only problem?
    • By raajen73
      My Setup:::::
      Toshiba Satellite p55w-c5204
      Processor: intel i7-5500u
      Graphics: Intel HD 5500
      Audio: Realtek High Definition Audio
      Hard Drive: SSD 256 GB
      Ram: 8GB (4GB x 2)
      Display: Full HD IPS
      Wireless: Intel Wireless 7265AC
       
      I've successfully installed Hackintosh Sierra 10.12.3 with the help of TransMac app. I know the wireless isn't working as of now. So I've purchased a wireless usb device(Prolink WN2001) and it works. I somehow managed to make things work like audio, battery percentage etc.

      The main problem I'm facing is with Bootloader & Graphics. Intel HD5500 is detected but shows 7MB. The windows counterpart I've previously checked shows Dynamic Memory of 128 MB by default so it shouldn't be problem. My questions are:::
      1. How can I boot with hard drive without USB being plugged in?
      2. How to fix the graphics issue? Do osx need to be booted from the hard drive in order to fix graphics issue? 

      Any help would be appreciated. 

      ~Thanks
×