Jump to content

New - Old hardware build - help needed

6 posts in this topic

Recommended Posts

Hello all,


I am playing with my old computer I had lying around. I want to install Snow Leopard on it. I know it CAN be done, but so far I am not having luck rebooting after the install.


I am getting the infamous  "still waiting for root device" error.


I am pretty sure this is a chipset driver issue.


This is my hardware


Gateway GT4024 computer

MSI 7428r motherboard



2 gb ram

NVIDIA pci e card 8600GT

Altheros wifi

PS2 keyboard  USB wireless mouse


I think the issue I am having is the ATI x200 sb450 chipset.  I know older Tiger vintage macs used this chipset and older distros had them built in. By searching the net I have found ATISATA  and ATIPATA kexts.


I can boot iatKOS S3 and load that on to my hard drive (seperate drive on IDE) the install completes and I reboot. The reboot however never finishes, I stall on the waiting for root device. I think the kexts above would get me past this.


Now I think what I need to do is get the above kexts installed..  I dont know how to do that without a working system.


I have MODCD, MODUSB,1Boot, IBOOTlegacy, HAZARD distro, retail Snow Leopard as well. 

I cannot seem to boot the retail any way from a bootable USB I made. I don't have any DL dvds at the moment. Maybe DVDs should be easier?

HAZARD I tried last night.. did not get anywhere with that.. and it is supposed to have those kexts built in.


Only success so far is iatKOS S3 v2 boots to install everytime - I run the install no issues but I cannot get a re-boot from the installed drive.



Help with installing the Kexts?




Link to comment
Share on other sites

If I can load a distro to the point of installing Snow leopard on a HD.. am I not running it ?? do I not need these drivers working to even get to that point?? Is there not a way for me to just install with all the options that the distro is booting up with? and then trim them out or down once I have a working install??



Link to comment
Share on other sites


yes, if you can run the installation... it's obivously because a kext who supports your chipset is loaded.

i looked into the Extra folder of iaktos S3 v2, and checked inside the AppleVIAATA.kext, and yes, there is an id for ati chipset, so, it's certainly this one...

so, if you want to stay with iaktos, check the VIAATA in drivers > main hardware > sata/ide.


or, if you want to try the retail way, pick the kext in the iaktos iso :)

  • Like 1
Link to comment
Share on other sites

OK, thanks .. will give it a try. I would like to try retail sure, but at least maybe I can get a working SL if I go with iaktos.


When I tried retail, I could get a boot loader to load.. but could not get to the language question of the retail usb.


I would need to pull the kext from the iaktos cd.. save it to where on the retail usb?

Link to comment
Share on other sites

OK! I am posting this from Safari in my SL install.


So now I am on to the post install issues.. and there are a few.. But i will post them in the post install forum.


VIAATA kext I assume did the trick.. I also used an alternative kernel. drive shows up as SATA.. but dont really care as long as it works.



Link to comment
Share on other sites

  • 4 weeks later...

I abandoned this project in favor of a DC7900 I picked up cheap..  SUPPOSED to be a much more vanilla install. Still think sound will be an issue.


Thanks for the posts. there is a new thread for the other build.

Link to comment
Share on other sites


  • Create New...