Jump to content
Sign in to follow this  
Followers 0
Allan

Como corrigir a memória de video

7 posts in this topic

Recommended Posts

Em alguns casos o GraphicsEnabler do Chameleon funciona para ativar o vídeo, porém a quantidade de VRAM aparece errada. Isso é apenas visual, mas para quem quiser acertar, aqui vai uma forma:

 

Rode este comando no terminal para obter o string device-properties gerado pelo Chameleon:

ioreg -lw0 -p IODeviceTree -n efi -r -x | grep device-properties | sed 's/.*<//;s/>.*//;' > ~/Desktop/device-properties.hex

Converta para plist (coloque o gfxutil.zip no desktop)

cd ~/Desktop
./gfxutil -s -n -i hex -o xml device-properties.hex device-properties.plist

Edite a VRAM no device-properties.plist   

<key>VRAM,totalsize</key>
<string>0x40000000</string>

O valor está em hexa, pode converter para decimal usando a calculadora no modo programador, mas normalmente basta dividir ou dobrar o valor que você já conhece.

 

Exemplos:

0x20000000 = 536870912 (bytes / 1024^2 = 512 MB)

0x40000000 = 1073741824 (bytes / 1024^2 = 1024 MB ou 1 GB)

0x80000000 = 2147483648 (bytes / 1024^2 = 2048 MB ou 2 GB)

 

Converta o device-properties.plist editado para hex

./gfxutil -i xml -o hex device-properties.plist device-properties-new.hex

Copie o string do arquivo device-properties-new.hex para a chave device-properties no arquivo /Extra/org.chameleon.Boot.plist

 <key>device-properties</key>
 <string>cole o string aqui</string>

Desative o GraphicsEnabler (ou remova a opção)

   <key>GraphicsEnabler</key>
   <string>No</string>

Para quem usa Clover o ajuste pode ser feito através da opção VRAM no config.plist

  <key>Graphics</key>
   <dict>
      <key>Inject</key>
      <true/>
      <key>VRAM</key>
      <integer>1024</integer>
   </dict>

Fonte: Olarila

Share this post


Link to post
Share on other sites
Advertisement

Allan, te comento que el link a gfxutil requiere login para descargar en Olarila. Subelo aquí que será mas directo. Gracias por la guía!

 

EDIT: puedes borrar este post si quieres para que este mas limpio el hilo.

Share this post


Link to post
Share on other sites

Olá

 

Grande guia esse ai do Olarila, me ajudou quando comprei minha GTX 760 e dava 0mb kkkkk ajustei e pronto e no momento eu estava usando Chameleon

Só uma coisa allan: Seria muito bom se fosse colocasse nos créditos o link do guia e o nome do usuário que o criou originalmente :)

 

Pro chameleon eu tenho que baixar um comando, rodar um comando no terminal e ainda fazer umas matemáticas.....

Pro Clover é só colocar o tamanho da memoria e pronto

 

Isso só me dá um pensamento: Clover=usuario normal ou leigo se usar HV/Chameleon=usuario que faz tudo na manual e não tem medo de enfrentar códigos, linhas e até uma matemática  :P 

Share this post


Link to post
Share on other sites

Olá

 

Só uma coisa allan: Seria muito bom se fosse colocasse nos créditos o link do guia e o nome do usuário que o criou originalmente :)

 

Pronto!  B)

Share this post


Link to post
Share on other sites

No Chameleon fica assim :

 

<key>device-properties</key>

 <string>cole o string aqui</string>

 

No Clover é a mesma coisa?

Share this post


Link to post
Share on other sites

Olá

 

Não, no Clover o ajuste fica na chave VRAM e é bem + fácil veja um exemplo:

 <key>Graphics</key>
   <dict>
      <key>Inject</key>
      <true/>
      <key>VRAM</key>
      <integer>1024</integer>
   </dict>

1024 é só um exemplo, pois 1024MB=1GB, 2048MB=2GB e por ai vai, isso depende do tanto da tua memoria sendo que ela deve ser sempre expressa em megabyte.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By technosinner
      Hi guys,
       
      I need help with my Sapphire RX580 8GB. It works and I have it connected to a BenQ EW3270U (4k monitor through DP), but I noticed that the quality of my video is not exactly great; I just don't feel like it's up to spec with some fuzziness and everything just isn't as sharp as I expect it to be. It's hard to explain exactly what I see, but especially when there's transparency in windows for instance, I see what I would compare to colour compression artifacting in the gradients of the images showing through the transparency effects. It looks like a video with fading on Youtube but the compression makes it look like waves of pixels as opposed to a real gradient, if that makes any sense? It's impossible to film or photograph properly, and - the part that gets me - if I do a screenshot, it's not visible! I must have been super tired when I posted... it's visible on screen shots after all (see attached). It screams graphic acceleration issues to me but I really am at a loss on how to diagnose this issue further. It's not unusable or anything, but I want to get it to work properly and get as much as I can out of it all.
       
      As a comparative I did plug in a Retina MBP to the monitor to make sure it wasn't the issue and as expected, I did not see any of this with the MBP.
      I have Lilu and WEG in my 10.14 kext folder, and my (shameful) config is attached, but I more than likely am missing something important...
       
      All this explained, I want to point out a few things: this is an old machine (built 2012) and I had the same config throughout with exactly 0 issues. This is one reason why I not only never had to optimize it, but I now also pretty much fell off the Hackintosh bandwagon: I am not exactly well versed in all the technical backend of this community as I was until now lucky with a plug and play machine with no issues.
       
      I will need a lot of help to get back up to date... that said I also had incomprehensible and undiagnosed issues getting the RX580 to work on this machine. Even if it was effortless for everyone else, I had to do a LOT of troubleshooting and in the end, I have no clue how I got it to work! So I'm mortified of changing anything on it without getting some advice first since everything, iCloud and iMessage included, works. I'll be happy to fill in any info and I'm hungry to learn. It's just a bit daunting to start over and my searches have discouraged me a but. I know beggars can't be choosers but I have a 60-hour a week job and I just need a bit of guidance if anyone wants to help me off my training wheels  I fully know I'm in a bad spot and quite frankly I'm ashamed of it. Help me make it better please.
      config.plist



    • By Allan
      Hello guys!
       
      Here's how you can add a signature in your profile.
       
      Signature.mov
       
      Follow the rules.
       
      Signatures, Avatars and Nicks
       
      Keep your signature/avatar clean and tidy - should you receive a PM from the staff regarding your signature/avatar, please make the requested alterations or it may be removed/shortened appropriately.
      To keep pages loading fast for everyone, we request that your signatures and avatars contain no animations or high-definition graphics of any kind.
      Signatures should be no more than 6 lines of text using a regular font. If you can't fit all of your system specs in that you'd like, why not create a small graphic to contain the information?
    • By Wallfacer
      hi there, 
      when attempting install 10.10 to my old PC, it reboots everytime when attached pic shows up. my hardware is:
      mb - unika p35 (with ich9) 775pin
      cpu - intel xeon x3210
      video card - nv geforce 8600gt
       
      could anybody know what was wrong? or is it possibly because of the video card, or the powermanagement?
       
      thank you so much for help!

    • By safar
      Hi   Clover limits the number of gpus to 4 :   from Clover source code : rEFIt_UEFI/Platform/Settings.c :   GFX_PROPERTIES                  gGraphics[4]; //no more then 4 graphics cards   Anybody knows why?   This number is limiting for me : - 1x gpu is AMD display GPU - 1x gpu is Supermicro's built-in vga IKVM output (Matrox 0x532102B)  
      - 3x gpus Nvidia for Cuda   I At present, I have to take off one Nvidia (but I'm trying to disable the build-in vga IKVM output through software, so that it's available for other operating systems : I'll make another post on that topic, to keep things clean)
    • By Punkdat
      Hi!
       
      I’m starting a designing course and I’ve been told a Macbook is the best option to handle specific softwares like adobe Photoshop perfectly.
      Right now, i’m studying in Lisbon, Portugal. So, I would need to buy it from some Portuguese store, in case I need to claim warranty.
      Anyway, I started my search and found som results, fort some Portuguese stores , i’ll leave a link below.
      I'm aware that a desktops like a Mac Pro would be a much suitable solution, but I need a laptop to take to classes.
      I think a 13” Model is enough since the retina screen helps me see details better, but I don’t understand the software requirements for each type of software.
      What do you guys think I sould buy?
      Feel free to make any question or suggestion!
       
      My research:https://www.tecmagnet.com/produtos/equipamento/portateis?pagina=1&q=Apple+-+13%22+-+13-9%22+-+&id_marca=13&query=%5B%5B%2219%22%2C%2269%22%5D%5D
×