Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sinn

Getting osx works

23 posts in this topic

Recommended Posts

Hi!

 

I want to install osx mavericks, but i have some problems. 

 

My Pc specs

 

 CPU: AMD FX-8350 

 GPU: Gigabyte nVidia GeForce GTX 650Ti 1Gb

 Motherboard: Gigabyte 970A-D3

 RAM: Geil Dragonram 16Gb (2 x 8Gb)

 

And there is a problem..

My graphic card dont have full acceleration, sometimes i have problems with sound too. (0mb not 1024 on card, or 1024mb but still total lagging and 0 acceleration)

 

How i can install osx on this pc ? After trying niresh million times i dont have idea how ;-;

 

Thanks for any help!

Share this post


Link to post
Share on other sites

Hallo

 

I gave to you a solution to install OSX

 

You'll need just replace original kernel for a modified kernel...

 

See in here AMD builds: http://www.insanelymac.com/forum/topic/285110-amd-working-builds/

In each post is listed CPU and modified kernel for this one... see if FX 8350 is in there

 

boot flags usualy: -f -x -v ncpi=0x2000 or ncpi=0x3000

Share this post


Link to post
Share on other sites

This from Niresh doesn't work correctly ? And what with gpu  ?

Share this post


Link to post
Share on other sites

Hallo

Niresh is distro, i'll never get a hack running 80% with this, is much modified... Your grafik card work OOB, but distro doesn't allow this work

Retail is the best solution, i gave to you a retail solution.

Like i said your grafik card is OOB, maybe you need just add GraphicsEnabler to make this work...

See that topic about AMD builds it'll helkp you much

Share this post


Link to post
Share on other sites

I have installed osx and amd kernel, but now i have other problems. 

While booting i have restarts only..

Share this post


Link to post
Share on other sites

I dont have Execute Disable Bit or NX bit, or XD bit , i have hpet, AHCI and ACPI but only suspend type s3 or s1

Share this post


Link to post
Share on other sites

Still doesnt work, restart when system is loading drivers

Share this post


Link to post
Share on other sites

Hello

 

I believe that you get Clover bootloader, so, try press [space] and select without caches

 

If don't work... press 1 while cursor blinking before find Clover Screen  to get a Chameleon bootloader.... and type these flags:

 

-v -f -x

or

cpus=1 npci=0x2000

or

cpus=1 npci=0x2000 amdfx-v

or

cpus=1 npci=0x2000 amdfx-v -f -v- x

 

AMD CPU is just testing... please try these flags...

Share this post


Link to post
Share on other sites

Still nothing :(

Share this post


Link to post
Share on other sites

Hallo

Try this kernel: http://www.insanelymac.com/forum/topic/285580-database-of-current-working-amd-kernels/

if don't work try: http://www.osx86.net/downloads.php?do=file&id=1675

if not again try: http://www.insanelymac.com/forum/topic/281450-mountain-lion-kernel-testing-on-amd-dont-ask-help-here-use-the-help-topic/page-135

I believe that this last kernel will work :)

 

If nothing work, use this last kernel and try boot with:
-v USBBusFix=Yes UseMemDetect=Yes UseKernelCache=Yes npci=0x2000

Share this post


Link to post
Share on other sites

Dont work. Maybe lower osx? 

Share this post


Link to post
Share on other sites

There is no kernel 

Share this post


Link to post
Share on other sites

Thanks so much for help, with some kext my osx works perfectly ! :D

Share this post


Link to post
Share on other sites

Okay, so:

 

Amd kernel + 10.9 retail + nullpower and something other (i don't remember now)

After install i copied kernel to osx hdd.

After this i install voodohda and ethernet

 

and it works! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×