Jump to content

[Guia] UEFI multi-boot com Clover


16 posts in this topic

Recommended Posts

Vejo que muitos ainda tem dificuldade para instalar os sistemas operacionais no modo UEFI.

Com esse guia, as coisas ficarão mais fáceis.

 

1 - Seu BIOS precisa ter a opção UEFI Boot e ela precisa ser ativada.

 

nHqgjko.jpg

 

Observe que quando essa opção está ativa, aparece UEFI antes do nome do drive.

 

VwJY50T.jpg

 

 

Instalação do OS X

 

Você pode criar um instalador desta forma, ou baixar um pronto da minha assinatura. Não precisa iniciar o instalador no modo UEFI, só é necessário no passo seguinte, para instalar o Clover.

 

IMPORTANTE: para instalar o Windows 7 ou 8 no modo UEFI, o esquema de partições deve ser GPT puro, não pode ser hybrid MBR como se usa no modo BIOS, então ao criar as partições pelo Utilitário de Disco, não mude a partição do Windows para o formato MS-DOS (FAT), mantenha todas as partições no formato Mac OS Expandido (Reg. Cronológico), você vai mudar o formato da(s) outra(s) mais tarde.

 

Instale o OS X na primeira partição.

 

Edit: se você usou o instalador do 10.8.5 ou 10.9 com partição EFI você pode apenas copiar o Clover do pen drive para o HD.

 

Formate um pen drive como FAT32 e instale o Clover nele com a opção "instalação para placas mãe UEFI".

 

http://sourceforge.net/projects/cloverefiboot/

 

Você precisa ter pelo menos os drivers FSInject, OsxFatBinaryDrv e VboxHfs (ou HFSPlus) na pasta /EFI/CLOVER/drivers64UEFI (instalados por padrão). Dependendo do BIOS pode precisar do OsxLowMemFix (Insyde H2O), EmuVariableUefi (Phoenix UEFI) ou OsxAptioFixDrv (todos os demais).

 

Inicie o sistema pelo pen drive para testar o boot UEFI.

 

Rode os comandos a seguir no terminal, substituindo X pelo número do HD.

 

Para formatar a partição EFI como FAT32

diskutil list
sudo newfs_msdos -v EFI -F 32 /dev/diskXs1

Para montar a partição EFI

mkdir /Volumes/EFI
sudo mount_msdos /dev/diskXs1 /Volumes/EFI

Crie a pasta EFI na partição EFI.

 

Copie a pasta EFI/CLOVER do pen drive para a pasta EFI da partição EFI (que está em seu HD).

 

Faça boot novamente pelo pen drive. No menu do Clover, entre na opção Clover Boot Options e selecione Add as UEFI boot option. A partir de agora você conseguirá iniciar sem o pen drive, pelo Clover da partição EFI, no modo UEFI.

 

Recomendo a leitura deste tópico para mais informações

http://www.projectosx.com/forum/index.p ... topic=2428

 

Instalação do Windows

 

Para criar um instalador UEFI em USB execute o Prompt de Comando como administrador e rode os comandos

diskpart
list disk
select disk X (troque X pelo número do pen drive)
clean
create partition primary
format fs=fat32 quick
active
assign
exit

Copie todos os arquivos da imagem (DVD) para o pen drive.

 

Para o Windows 7 é necessário copiar a pasta efi\microsoft\boot para efi\boot (um nível acima), copiar o arquivo bootmgfw.efi para essa pasta e renomeá-lo para bootx64.efi

 

O arquivo bootmgfw.efi está na pasta \1\Windows\Boot\EFI\ dentro do arquivo \sources\install.wim do DVD. Abra o arquivo install.wim com o 7-Zip.

 

Para o Windows 8 basta fazer os passos usuais, mas não pode ser uma imagem "AIO" (all in one), x86 e x64 (com efi\boot\bootia32.efi), tem que ser uma apenas x64 (com efi\boot\bootx64.efi).

 

Antes de instalar o Windows você precisa alterar o formato da partição para NTFS. Use o aplicativo gParted a partir de um live CD do Linux.

 

IMPORTANTE: o instalador do Windows formata e renumera todas as partições que estão depois da selecionada como destino, pois ele cria uma partição reservada, então caso for instalar o Linux, deixe para o fim ou instale o Windows na última partição.

 

Se você usa loader para ativar o Windows 7, ao invés disso pode injetar a tabela SLIC pelo Clover.

 

Baixe o binário da SLIC 2.1 e o certificado

 

http://forums.mydigitallife.info/thread ... post514521

 

Renomeie o arquivo NOME.BIN para SLIC.aml e coloque na pasta EFI/CLOVER/ACPI/WINDOWS

 

Coloque o certificado em C:\ e rode no Prompt de Comando (como administrador)

slmgr -ilc C:\NOME.xrm-ms

Pegue uma chave

 

http://forums.mydigitallife.info/thread ... Collection

 

Rode

slmgr -ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

O BCD é instalado em EFI/Microsoft na partição EFI.

 

Instalação do Linux

 

O único detalhe importante é instalar o GRUB legacy na própria partição e não no MBR (por exemplo, selecione /dev/sda5 e nunca /dev/sda).

 

O grubx64.efi é instalado em EFI/"nome da distro" na partição EFI.

 

Créditos: Pernacabeluda

Fonte:  Olarila Forum

Edited by Allan

Olá

Realmente esse guia do pernacabeluda é demais...
Agora só me lembrei da época que visitava e dava suporte ao olarila, acho que desde Fevereiro parei de ir lá... mas pretendo dar umas visitadas por lá

De qualquer forma, fui muito bom ele permitir que o guia dele fosse escrito aqui. Obrigado Allan.

  • 9 months later...

Caro Alan,

há bastante tempo uso Multiboot, já discutimos sobre este assunto em outro momento aqui no forum. Tudo funcionava muito bem: o Grub gerenciava a entrada de todos os sistemas (Win e Ubuntu) e chamava o Clover para os OS X. Tudo em UEFI. Todos os sistemas estão atualizados e este foi o problema. Na atualização do Ubunto do 14.04 para 14.10 apenas o próprio e o Windows 10 funcionam e antes da entrada do Grub aparece a mensagem "insecure boot", uma referência a opção desabilitada na UEFI BIOS. O Clover não sobe nem sosinho. Verificando descobri que o Grub/Ubuntu instalou uma série de arquivos e pastas nas partições EFI de cada HDD bootavel. O que aconteceu com o Ubuntu tanto 14.10 quanto 15.04 que modificou esta relação com os bootloaders. Googleando aparece a existência do SHIM nesta novas versões do Ubuntu, Fedora etc., uma forma de gerenciar o "Secure Boot" do Windows.

O que sabes sobre isto e qual a solução que recomendas?

Fiz como me disseste, fiz os backups zipados e deletei os arquivos. Recuperei o boot dos Windows e a entrada do grub não apresenta mais a mensagem "insecure boot". Porém o Clover não entra de jeito nenhum. Sempre tela preta. Alguma luz?

Sim refiz a opção e não resultou. Revi todas as configurações da UEFI-BIOS e não detectei nada diferente. Tentei o boot direto pelo quick-boot e também não tive resultado. O negócio é ter paciência e retornar e refazer os passos possíveis.

É incrível mas não consigo fazer o Clover UEFI carregar. Revi toda configuração da EUFI-BIOS, formatei o Clover UEFI, repassei a ordem dos HDDs, desistalei o Shim e apaguei as diversas pastas e arquivos que ele grava, assim como troquei os backups que ele cria (bkpbootx64.efi) mas não obtive sucesso. O que mais pode ter havido nesta maldita atualização do Ubuntu?

Pois então, Allan.

Finalmente consegui recuperar o boot do Clover e do Yosemite. Não tenho conhecimento suficiente para dar uma explicação técnica. A instalação ou atualização ocorre posteriormente aos outros OS's instalados. O Ubuntu 14.10 e 15.04 (acredito que seja a partir destas edições) por meio do SHIM fazem alterações não só nas partições EFI (criando novos BOOTX64.EFI e fazendo backups dos originais) assim como nas configurações da UEFI-BIOS. Como o SHIM é um gerenciador do "secure-boot" e os Hackintosh não usam esta opção habilitada é necessário desinstalar o SHIM completamente. Apagar os BOOTX64.EFI criados por ele e renomear os backups para seus nomes originais. Recuperar a configuração da UEFI-BIOS.

No meu caso isto ainda não foi suficiente. Tive que desligar todos os HDD's que não fossem Hackintosh e reiniciar a máquina primeiro no Clover e o Yosemite e depois o Windows e finalmente o Ubuntu. Porque, eu não sei. Mas funcionou.

Abraço!

  • 9 months later...
  • Allan pinned this topic
  • 3 months later...

IMPORTANTE: para instalar o Windows 7 ou 8 no modo UEFI, o esquema de partições deve ser GPT puro, não pode ser hybrid MBR como se usa no modo BIOS, então ao criar as partições pelo Utilitário de Disco, não mude a partição do Windows para o formato MS-DOS (FAT), mantenha todas as partições no formato Mac OS Expandido (Reg. Cronológico), você vai mudar o formato da(s) outra(s) mais tarde.

 

Isto se aplica pra 2 Hds, porque aqui eu tenho Mojave e windows 10, mas no bootloader colver as particão windows nao aparece pra boot!??

×
×
  • Create New...