Jump to content
waldouk

Upgrading from 10.8 to 10.9

8 posts in this topic

Recommended Posts

Hi all,

 

First time poster so please excuse my general lack of knowledge :D

 

I purchased a 'pre-built' Hackintosh around a year ago. It's been pretty smooth sailing, even given my lack of technical skills. I'm now looking at installing a larger SSD and, whilst I'm at it, upgrading to 10.9 Mavericks. 

 

Found a great guide on this here forum which looks relatively straightforward (even for me!) Only thing is, I'm not sure how I go about 'extracting' the customisations that were put in place by my kindly supplier to get the system running on 10.8. In other words, how do I extract the stuff in the 'Extra' folder (and elsewhere) to make the process of installing 10.9 as simple as possible?

 

Any help would be greatly appreciated.

 

 

Cheers,

andy

Share this post


Link to post
Share on other sites
Advertisement

Hi Andy,

 

You need to post your specs of the pc to see what you need in the extra folder.

 

Also worth taking a full backup of your system onto another drive and making sure you can boot from the other drive in case you have to roll back due to issues.

Share this post


Link to post
Share on other sites

Hiya d620osx,

 

Thanks for the reply.  Spec below:

GIGABYTE Z77 chipset - z77-DS3H (http://www.gigabyte.us/products/product-page.aspx?pid=4147#ov)

i7-2600K

Graphics - GIGABYTE GTX 470 Super over Clock (http://www.hardwarecanucks.com/forum/hardware-canucks-reviews/36477-gigabyte-geforce-gtx-470-super-overclock-review-5.html)

8GB RAM

 

Uses a wired net connection so no need for wi-fi (which I understand can be a PITA). 

 

I'll be adding a new hard drive so, worse-case scenario, I can always plug-in the old SSD if I screw things up (sorry, when I screw things up!!)

 

 

Cheers

Andy

Share this post


Link to post
Share on other sites

You should be able to use the extra file from the ssd. You may need new kexts for the gpu. As long as you have the old ssd, no harm in trying a new build to see how it goes.

Share this post


Link to post
Share on other sites

Thanks for that. My experiment was, unfortunately, a failure.

 

I followed the guide here: http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/ 

 

I used the existing contents of the Extra folder from the existing set-up. Install and boot-up went fine but networking didn't work (no ethernet connection shown in System Preferences) and the audio didn't work either. I gave up at that point and reverted to the old SSD with 10.8 running on it. I'll need to do some Googling to see if there are some kexts for the motherboard.

 

If anyone stumbles across this and has the solution to getting Mavericks running on GA-Z77-DS3H (rev. 1.0) it'd be much appreciated!

 

 

Cheers,

Andy

Share this post


Link to post
Share on other sites

This is a bit of a (steep!) learning curve for me... Just found another guide that mentions copying across existing ketxs from System/Library/Extensions - I'm wondering whether, if I did that, I might have fared a little better!   

 

I'll do some more searching later and perhaps give it another shot in a few days once I've mustered the willpower and/or courage!

 

Thanks for the help again d620osx :)

Share this post


Link to post
Share on other sites

As long as you have a good back up all you can do is test and restore if it does not work, read more and try again, that is how I got my one working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By NoEnd
      Hi team,
       
      I'm looking for the best route to achieve this upgrade, so I have been stuck with HS since Nvidia drivers stopped being supported on newer MacOS releases. Now I'm having an AMD 5700 xt on the way and want to plan the upgrade properly. I have added some information below and questions that might help with your recommendation.
       
      Current GPU 1080 ti with Nvidia webdrivers installed. So should I uninstall the webdriver before adding the new GPU? Clover is being used and EFI attached. Any kext must be removed? or parameters adjusted MacOS HS 10.13.6, should I upgrade before using the new GPU? CPU: 9900K Motherboard:ROG MAXIMUS XI HERO (WI-FI) Dual Monitors I have a Time machine backup, Do you recommend a fresh install? and If I did, will I be able to restore my data/apps as-is?  
      Please let yourself free to explore further aspects to considers.
      EFI-20200204.zip
    • By exquirentibus
      Dumb question, but ... if I already have these kexts installed to /L/E:

      AppleALC.kext
      FakeSMC.kext
      IntelMausi.kext
      Lilu.kext
      USBInjectAll.kext
      WhateverGreen.kext
      XHCI-unsupported.kext

      Do I also need to copy them to Clover/kexts/Other when upgrading from 10.14, and then delete them ( as they are not currently in Clover/kexts/Other)?

      And do I need to set config.plist/SystemParameters/InjectKexts=Detect so that Clover will inject all applicable (depending on version) kexts in EFI/Clover/kexts/Other only if FakeSMC.kext is NOT in kernel cache.  
    • By kylon
      Cloud Clover Editor is an open source application that allows you to manage the configuration of various Hackintosh Bootloaders.

      Open Cloud Clover Editor
       
      Cloud Clover Editor Wiki
      Cloud Clover Editor Sources
       
       
      Features
      Supports Clover EFI, Ozmosis, Chameleon, OpenCore GUI and Text Editor Mode CCE Bank Mobile friendly and more...  
      Officially supported browsers
      Chrome 42+ Microsoft Edge 14+ Firefox 39+ Safari 10+ Opera 29+ Opera Mobile 12+ Chrome for Android 75+ Firefox for Android 67+  
       
      Credits
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor  (Discontinued) crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support  
      Please let me know if i forgot you!
    • By ciriousjoker
      TLDR:
      I'm trying to boot MacOS on a Chromebook without UEFI. I'm stuck at getting the bootloader (Chameleon/Clover) to work.  
      My setup / context:
      I have an Acer Chromebook Spin 13.
      Available ports:
      2 x USB-C 1 x USB-A 3.0 MicroSD Slot No USB A 2.0 (I've read that Clover has problems with USB 3.0) Firmware:
      There's no UEFI firmware available and by default, it doesn't even allow booting anything other than ChromeOS. Thanks to MrChromebox (big shoutouts!), I flashed a custom legacy bios that allows me to boot anything linux related. This bios is flashed into the RW_LEGACY section of the existing bootloader (coreboot afaik) and doesn't have any configuration options. If I have to change a setting, I could try compiling his bios payload myself with the specific setting enabled.  
      What I've tried so far:
      Chameleon attempts:
      Only selected setting was "Install chameleon on the chosen path", rest was unselected.
       
      1 - Install chameleon first without restoring the basesystem:
      Output:
      > boot0: GPT
      > boot0: done
      (hangs; pressing power button once shuts down
      Chameleon installation log is attached as "Chameleon_Installer_Log_BEFORE".
       
      2 - Install Chameleon after restoring the base system:
      Output:
      > boot0: GPT
      > boot0: GPT
      > boot0: doneboot1: /boot       <- Exactly like that, no line break in between
      (hangs; pressing power button once shuts down)
       
      I haven't been able to reproduce #2 after wiping the drive and doing the same thing again. Subsequent attempts have resulted in either #1 of either Chameleon or Clover.
      Chameleon installation log is attached as "Chameleon_Installer_Log_AFTER".
       
      Clover attempts:
      I tried multiple settings and configurations, but all of them boiled down to either one of these.
       
      1 - Doesn't do anything, just hangs at "Booting from usb..."
      2 - Boots into the blue/grey mode as shown in the attached images.
      According to MrChromebox, this could be an old Tianocore DUET It doesn't detect anything (cpu frequency, ram, partitions or disks)  
      I've read pretty much every article, github readme and other types of documentation for coreboot, tianocore, clover, chameleon and MrChromebox' rw_legacy payloads and right now, I'm totally clueless as to what to try next...
       
      A few questions that came up:
      Why does chameleon hang? What is it looking for, /boot was clearly written to the disk by the Chameleon installer? What exactly is the blue/grey image? According to MrChromebox, it could be Tianocore DUET Where does it come from? Clover? The mainboard itself? Why does the blue/grey thing not detect my processor frequency or any partitions/drives? Can I use some sort of DUET bootloader to chainload Clover?  
      If you guys could answer any of them or if you have any other guesses or information as to what's happening, I'd be really happy!
      Chameleon_Installer_Log_BEFORE.txt
      Chameleon_Installer_Log_AFTER.txt





×