Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
DK7

Issues in booting Windows 8.1 with clover in UEFI mode

9 posts in this topic

Recommended Posts

I got Windows 8.1 Pro with Media Center and OS X Mavericks 10.9.2 to dual boot in clover. Both are UEFI installations and are on two different hard disks. I got 2 problems while using clover

 

1 . I am trying to set Windows as my default boot option, but it seems to boot Mavericks as default. I have set the UUID (5D8DB1AA-60E0-4145-9F58-CB1EB1039BF5) of Windows under DefaultVolume and "\EFI\Microsoft\Boot\bootmgfw.efi" under DefaultLoader.

Is my setting correct or is there some other setting in clover configurator that I am overlooking?

 

2. Another issue related to booting Windows 8.1 with clover is I lose my boot logo and only see the spinning circle. So basically its a black screen with a spinning circle. Other than that there is no issues while using Windows. But the logo appears if I go to the Boot options and select the clover partition and then use it to boot into Windows.

 

So what are the solutions for my problems?

 

Thanks in advance

Share this post


Link to post
Share on other sites

the first solution is you put your hardware in the signature, no specs, no help!!! :(

Sorry. I thought hardware specs won't be necessary for my problem. I updated my signature with my hardware specs  :)

Share this post


Link to post
Share on other sites

I had a similar problem and it relates to Clover giving preference to the last booted volume recorded in NVRAM over the default boot volume specified in the config.plist.  I fixed it using the latest Clover r2652 to IgnoreNVRAMBoot and also setting the EFI as the Default Boot Volume.

 

In summary

  • Delete your current NVRAM settings...in terminal
     sudo rm /nvram.plist
     sudo nvram -c
  • Place ntfs.efi in EFI/CLOVER/drivers64UEFI
  • Edit your config.plist, entering the Default Boot Volume as EFI and ticking IgnoreNVRAMBoot with Clover Configurator...

post-846696-0-81746200-1397977482_thumb.

  • With the correct config.plist settings, everything works as expected (including timeout countdown!)....

post-846696-0-65500100-1397977703_thumb.

 

Of course for legacy Windows, the Default Boot Volume would usually be "System Reserved".

Share this post


Link to post
Share on other sites

I had a similar problem and it relates to Clover giving preference to the last booted volume recorded in NVRAM over the default boot volume specified in the config.plist.  I fixed it using the latest Clover r2652 to IgnoreNVRAMBoot and also setting the EFI as the Default Boot Volume.

 

In summary

  • Delete your current NVRAM settings...in terminal
     sudo rm /nvram.plist
     sudo nvram -c
  • Place ntfs.efi in EFI/CLOVER/drivers64UEFI
  • Edit your config.plist, entering the Default Boot Volume as EFI and ticking IgnoreNVRAMBoot with Clover Configurator...

post-846696-0-81746200-1397977482_thumb.

  • With the correct config.plist settings, everything works as expected (including timeout countdown!)....

post-846696-0-65500100-1397977703_thumb.

 

Of course for legacy Windows, the Default Boot Volume would usually be "System Reserved".

 

 

"IgnoreNVRAMBoot" is the key in your problem. Stick this and you can set default boot to EFI (Windows)

 

Thanks for the solution guys. It worked out fine and everything boots as I have set it. Except, still the Windows boot is a black screen with a spinner and no boot logo. Is this a common problem or is it only me?

Share this post


Link to post
Share on other sites

Thanks for the solution guys. It worked out fine and everything boots as I have set it. Except, still the Windows boot is a black screen with a spinner and no boot logo. Is this a common problem or is it only me?

Windows 8.1 will use OEM logo in UEFI for boot. My HP laptop will show HP logo if I boot without Clover.

Share this post


Link to post
Share on other sites

Windows 8.1 will use OEM logo in UEFI for boot. My HP laptop will show HP logo if I boot without Clover.

Yeah without clover it boots with my motherboard logo. In UEFI mode. But with clover I don't get the logo. So it seems that's how it works with clover?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×