Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Broadcom BCM4313 using Virtual Machine, possible?

5 posts in this topic

Recommended Posts

Howdy everybody!


I am using BCM4313 -- which is unlucky, because it's not supported by Hackintosh.

I installed Mavericks on my Acer Aspire E1-471G and patched my DSDT, everything works perfect, except ELAN Touchpad and Wi-Fi.


But that's not the main thing.


Can we just simply use Windows Virtual Machine that supports BCM4313 on a Hackintosh that does not support BCM4313.

Means that:


Hackintosh --> (inside Hackintosh) Windows VM (using VMware Fusion) --> (inside Windows) Recognize BCM4313 and use Drivers for Windows --> search for networks inside Windows --> and transfer the internetconnection host-only from Windows VM to Hackintosh.


Now the problem is Windows is not recognizing the BCM4313. Can we just make Windows VM directly check out our laptop specifications without having to read from Hackintosh's system specification (which happened not able to recognize BCM4313) ?


Thanks in advance.

Share this post

Link to post
Share on other sites

I don't think windows inside a virtual machine has access to the actual (physical) wlan card.


I'd recommend you buy another compatible wlan card such as a BCM43224 or AR9285. They're very cheap and easy to install. 

Alternatively, you could buy a USB WiFi adaptor.

Share this post

Link to post
Share on other sites

Dr. Hurt,


Thank you so much for the quick reply. But, my laptop is an Acer Aspire E1-471G. Are those Wi-Fi cards whitelisted or blacklisted by my laptop.

I'm running OS X Mavericks 10.9.0 by the way.


Or, maybe, can we just change BCM4313's device ID to other cards so it can be recognized by Mac?

Or maybe, we could just patch the DSDT for BCM4313 to work?


Has anyone have their BCM4313 work? In my case, mine is Acer Nplify 802.11 b/g/n with BCM4313 chip.

Share this post

Link to post
Share on other sites

Only HP and Lenovo have blacklists, so don't worry.


And no, changing your id or using DSDT will not work. The HARDWARE itself is not supported and will never be.

Share this post

Link to post
Share on other sites

Dr. Hurt,


Thank you so much for the explanation.

By the way, how do I extend the USB Wireless Adapter's scan coverage? The Wi-Fi adapter is so poor, can't get high signals if it's far. If I use my BCM4313 on Windows, even though it's far, it still got 2 or 3 level. Any suggestion?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By szzs
      I have a fully working HP-6460b with 10.13.1. For safety sake I made a clone drive for the 10.13.3. I could not update to 13.3, because it was always rebooted !!! The EFI is here: https://www.dropbox.com/s/d34g3a8uxjrb1n2/EFI_13.1.zip?dl=0 the other problem is with this EFI,  I could not update the clover, because it caused reboot requences again ! 
        So, I made a new EFI,  https://www.dropbox.com/s/viruxewplu2qbck/EFI_13-3.zip?dl=0  which was able to update to 13.3 without rebooting problem.  BUT !   In the 13.3 updated system my WIFI (BCM913224 HMS) is not working (hardware not found...) I tried to fix it dring a week but I could not fix it and not found any solution.     I think 13.3 may need a new patch for my WIFI card...  I am going to crazy, PLEASE help me if there is any solution. I think for the EFI problem there is a sure solution, so please also help me to understand which EFI should be proper for me.    Otherwise almost everything is working: audio, sleep, eSata, USB 2 (USB3 not, but I think this model can not use USB3), WEBCAM, card reader (if firewire is not allowed in BIOS) , firewire (if card reader is not allowed in BIOS) ....     Not working/not tried : WWAN (Ericson F5521) - I don't know how to install....    My detailed specification: HP-6460b / CPU: i7 2760 QM (2.4 Ghz,4/8 core,6M cache,45W) RAM 8GB, screen: 1366x768, webcam, 256 SSD + 1TB HD (in DVD slot) WIFI: BCM913224 HMS WWAN: Ericson F5521    I think many other may problem with bcm943224hms with 10.13.3 ! I can not change the WIFI card, because of this model whitelist problem !  
    • By Twml
      I have an HP Elitebook 8460P running High Sierra 10.13.1
      I'm trying to get wifi working, my internal wifi as far as i can tell is not mac compatible, its a intel centrino wireless
      I also cant change my wifi card, the elitebook i have only accepts a few different cards or it wont boot past post if it is changed.
      Also i have managed to brick the system a few times attempting different kext or pkgs. I cant seem to figure it out for high sierra. 
      I have a WiFi USB RTL8188CUS, that i had working in Yosemite 10.10 using a 10.9 pkg.
      but as far as i can tell 10.11 El Capitan was the last driver support for the card, and doesnt work in 10.13.1. the wifi utility wont open to connect to a network. 
      Is there a possible way to get this card working, or do i need to buy a new wifi usb.
      If i do need a new one what would be a good one to buy? i need it to have 10.13.1 driver support and be usb also not be to expensive, N300 is good enough but i do have an AC1750 router.
      Im fairly new to getting Mac running on Intel Based PCs. 
      any help would be greatly appreciated.

      I got it working but it sometimes randomly disconnects me from wifi and wont reconnect until a reboot.
      The kext i used was for 10.11 El Capitan. i was just using the El Capitan only kext before and not the multi edition kext.
      Attached is the utility and kext i used.
      So i still need help but i have made a little progress
      RTL8188CUS 10.11 WiFi.zip
    • By kolejacik
      hello, if you buyed native OSX ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS Combo Card, here are the drivers for windows 7/8/10. enjoy!
    • By TomZanna
      Sto aiutando un ragazzo ad installare High Sierra su un Asus X550JX. Le specifiche sono: i7 4720HQ
      GTX 950M
      HDD 1TB
      RAM 8GB
      Wi-Fi Atheros AR9462 AR5B22

      Siamo a buon punto. Non funziona audio(forse id errato), wifi(se si riesce, so che nel 90% è un no), percentuale della batteria e bisogna disattivare la dedicata(da BIOS non è possibile). Se viene rimosso l'SSDT per disattivare la dedicata(è quello allegato nella guida di Gengik) il sistema non parte più.
      Se potete dare un occhio al config perché ogni tanto fa qualche glitch grafico.

      Grazie mille
    • By Hervé
      Recompiled v2.3.6 sources in fat-binary mode (Xcode 3.2.6, SDK 10.6, Target OS X 10.6). Fully supported in 32bit and/or 64bit mode under all OS X/macOS versions from Snow Leopard 10.6 to High Sierra 10.13.