Jump to content

HP Compaq DC7100 SSF


8 posts in this topic

Recommended Posts

Hello fellow OSX86 community,


I am Jivi and i want to start a new project since i got a HP Compaq DC7100SSF from a freind of mine and i want to try if OSX will run on this machine i know this machine is kinda old but still i am intresting in what the power of it can be. I am not new whit osx86 since i already got a HP NC6320 running osx pretty well i used IPCOSX10.5.6 for this laptop and i am going to use IAKTOS S3 10.6.3 for the DC 7100. oke so lets start whit the Specification of this DC7100:

  • Processor Intel Pentium 4 2.8 GHz
  • Memory / 2.0 GB DDR2 667MHz Dual Channel SDRAM Kingston Memory
  • Hard Drive 80.0 GB
  • Optical Drive DVD-ROM IDE working installed the osx whit this drive
  • Graphics Processor Intel GMA900 working whit modified GMA950 kexts
  • Cache Type L2 cache
  • Cache Size 1.0 MB
  • Ethernet. BCM 5751 LFB worked whit BCM5751 kext
  • Wireless Ralink USB 150 MBPS came whit drivers for OSX on the cd.

oke so you can find the IAKTOS S3V2 at their forum google it.

i have burned the ISO onto a DVD-R at the lowest speed 4x using imgburn.

the computer booted up whit out using any flags!

i have formated the hard disk OSX Extended Journaled( MBR) this because i will use a litle program EasyBCD to fix the MBR to dual Boot into Windows!


now comes the tricky part here you have to customize your hardware, Boot loaders, kernels, patches,and configure your VGA and Ethernet.


to succeed in this part you will need to know your hardware if you do not start looking into it.

to get the GMA Graphic Card working you can check out these posts they were very helpfull!

i have gotten ethernet working whit the kext found here:

this post was very helpful worth checking into it!


I recently added a Asus Geforce 7500 LE as a Graphics card to the system and i now have wonderful Graphics whit this cards everything works QE/CE resolution up to 1080 tested on my Samsung TV connected trough DVI.


i Updated the system to 10,6,8 trough the software update in OSX it self now i the machine hangs at this message [ PCI configuration begin ] and wont load any further i haven't gotten past this message looking into it still i haven't gotten past this message so i reinstalled Iaktos S3 V2 i used the following options in customize:


  • Boot loader i chose
  1. AsereBLN v1.1.9
  • Bootloader options i chose:
  1. 32 bit boot
  2. ethernet
  • patches i chose:
  1. /extra directory
  2. fake SMC ( this is a Must)
  3. disabler
  4. RTC drop down the menu and choose RTC (32BIT) this is a must because our cpu is not 64bit!
  5. modified kernels i chose: qoopz 10.3.0
  6. UUID select this
  • Drivers i chose:
  2. dis-select the sound we will add these later since these give alot of kernel panics installing the wrong sound driver.
  3. select PS/2
  4. VGA only select these if you know what you need to select otherwise dis-select this i did not select this!

now continue installation this will take up to 30 minutes you do not need to stay whit the computer.

once the installation is done you have successfully installed OSx onto your HP Compaq DC7100 congratulation!

for your first boot up i recommend to boot whit flag -v -f this always worked for me though.

if your computer does not boot try these flags cpu=1 ncpi=0x2000 these might work otherwide try graphics enabler=no


this link is very helpful it has almost all the flags you could use trying to boot your OSX instalation.




So i did some research spent a few nights on the computer dig trough google  and viewing different kind of forums i finaly got to this page:





this is a very straight forward setup to get from 10.6.3 - 10.6.8 i got everything working whit the information provided by this tutorial i did not succeed into getting QE/CE whit the GMA900 card though but i have seen and read that it is possible to get it working. since i am using a PCIE Asus Geforce 7500 LE I didn't need the GMA900 kexts but search the web and you will succeed!

so now that i have an osx 10.6.8 running machine whit almost everything working now my computer wont shut down or restart properly it closes down OSX but the computer PSU stays on whit a black screen i am still looking into fixing this problems if anyone knows how to fix this your help is much appreciated pm me or post it so more people can enjoy this fix.


so this osx build was an success i also build a laptop HP NC6320 if you want to know more about the laptop build let me know and i will push you in the right direction i hope i was able to help some people to give an old machine some life since this machine runs terrible and slow on Windows 7 and windows 8 and windows xp isn't that fine either. i will provide a zipped archive file whit the Kexts i used for this build and i hope they will help you out i did not make these kexts i just found them trough research on the net so do not ask me for any help customizing kexts .


oke so i found the kext for the audio driver wich is an Soundmax AD1981B ICH6 you can find the driver in this post. the kext is included in the attached archive!






Link to comment
Share on other sites

Good stuff.


I would not bother with that old, basic and obsolete GMA900 under SL, stick to your supported PCIe x16 graphics card, you'll get far greater performance.


Re: kernel, you should get very good results with Nawcom's legacy kernels too; he made one for every SL update that got out. I use them on all my legacy systems and they all work great under SL 10.6.8.

Link to comment
Share on other sites

Hey Hervé thanks for the post i was wondering if you could tell me or point me in the right direction why the computer has got an restart/ shutdown porblem i cant seem to get this solved i have done the Evoreboot.kext instal in extra folder using kextwizard what allot of people described this did not work for me, and the computer would shut down properly in osx 10.6.3 hope you can help me out there.

thanks allot though and yeah whit the Geforce 7500 LE i get very good graphics performance for this old machine i am using it now as my Home theater computer to watch movies it works great even whit HD movies.


Hope to hear from you soon mate.

Link to comment
Share on other sites

He herve,


The os shutdown but the screen goes Black and the psu stayes on fans keep running i have done the evoreboot.kext instal in extra folder use kextwizzard did not work for me deleted the kext again. Found this post going to check into it tonight after work




Hope this Will solve the problem i Will post feedback when i have tryed it out thanks again for the help!

Link to comment
Share on other sites

I can tell you, Hervé, these HP systems are not scrap... I'm a proud owner of DC7100 CMT Hackintosh... jivismacosx, upgrade the RAM to 4Gb... It makes os go very smooth. Mine DC7100 has a ASUS EAH6850 DirectCU v2... And BD-RE drive... I hope your PC works as well as mine. Also a SSD would be good performance upgrade for your system. I just have to get da money for a ssd...

My sound works with AppleAC97.kext.

Link to comment
Share on other sites

Hey TheNuutti8,


Thanks for the post mate!


i have now upgraded the memory to 3 gigs of ram and the performance did increase allot thanks for pointing that out a SSD would be amazing for this build but i think its a little to much for what i am using this machine i have now gotten XBMC Eden running on the machine and this works like a charm i can do all my Home theater stuff whit it and no glitches like it would have on windows 7!


but the main question is i have still got the restart and shutdown problem the computer just wont shutdown properly i have done allot of research but have not yet found the solution to this problem can you tell me if you have this too or point me in the right direction that would be great thanks in advance!


overall this machine works like a charm i am writing this post from the build i got my self a PC Remote control which works great whit XBMC no more need for a mouse and keyboard! 


i am now going to try instal IAKTOS 10.6.3 on my laptop HP NC6320 since i got an laptop Sata disk from a friend i will start a new thread for this machine.

Link to comment
Share on other sites

Well... I changed AzureBLN to Chameleon and it suddently stopped from making those errors... I can give you my DSDT.aml and DSDT.dsl via PM.

I think, that your NC6320 just needs new wirelless card like airport extreme form old mac.

I have normal 64-bit RTC and it just works.

Link to comment
Share on other sites


  • Create New...