Jump to content

Can anybody help to fix my Hackintosh?


13 posts in this topic

Recommended Posts


before a start explaining my problem here are my specs:


CPU: Intel Core i5 2500K 

RAM: Corsair Vengeance 8GB (2x4GB) Dual-Channel 1600MHz CL9

GPU: EVGA NVIDIA GTX 560Ti 1GB (Superclocked edition)

HDD: (Please don't laught) WD Caviar (Black) 2000JS 200GB SATA2

MOBO: MSI Z68A-G43 (G3) (Latest BIOS v5.2)

AUDIO: On-board Realtek HDA ALC887

NET: Realtek PCI-E Gigabit Ethernet


Bootloader: Chameleon 2.3 (Latest revision)

OS: OS X Mavericks 10.9.1

Args.: GraphicsEnabler=Yes

Ethernet Built In

Kexts: VoodooHDA 2.8.4

Lnx2Mac Realtek driver

NullCPUPowerManagement or Patched AppleIntelCPU…

FakeSMC (Latest i found was 5.xxx)

SMBIOS: tried MacPro3,1; iMac12,1; iMac12,2


BIOS has been set-up as it should be


I made also other build that are working like charm.

I don't had any problems with installation or anything like that, its fully working except 1 thing.

So i have same problem from first day I'm using OS X on my PC. (ML 10.8.4 till now)

This happens randomly, daily about 10 times:

All windows freeze, also main panel, clock, but i can move mouse cursor.


I really don’t know why this happens if its kext problem or need DSDT.

I also made own DSDT, used fixes as one user with very similar MOBO (SB LPC, New HPET, … just system/cpu oriented)

It booted, its really loaded, but i don’t see any difference.

I tried installation using Uni*****, myHack, and also own vanilla installer (now).

Its every time same.


If you know anything that can cause this problem please help.


Thanks very much for any help.

Link to comment
Share on other sites


Your hardware is good and compatible ...

I believe that these freezes happen because of a lack of proper configuration ...

You have already installed Uni ***, Myhack and many other all-in-one, your system is a mess, so I recommend re-installing OSX and perform post-installation manually ... I'll help you with that ...

Now I just ask you to re-install the system ...

After re-installing the system, comes the post-installation.

Install Chameleon: http://www.insanelymac.com/forum/files/download/59-chameleon-22-svn/...

Link to comment
Share on other sites


No... A hack isn't only maked of kext, but of settings...

Install Chameleon(i think you done it)

Create 2 main files(create them with help app Chameleon Wizard)
(iMac 12,2 is the ideal model to you)

Install FakeSMC and enable graphic card....

Now most important step. Adjust your power management like i taught in here: http://www.insanelymac.com/forum/topic/291549-you-knew-it-was-coming-p8p67-pro-install-guide/?do=findComment&comment=1981820

sudo ./ssdtPRGen.sh 95 3800

You need see your Max TDP(95 in example) and Max Frequence(3800Mhz in example)... check in intel site: http://ark.intel.com

Good Luck!

  • Like 1
Link to comment
Share on other sites



u should boot


-v and when frezes or kp it say where


post also


u loaded kext






copy and past


pastebin.com  and post the link


also with chameleon wizard post u bdmesg ( some thing like u gona do for kext )


and u don't have native powermanagement if u use nullcpupowermanagement.kext


probably u major problems came from graphics ( so many freezes in nvidia graphics )


good hack

Link to comment
Share on other sites


NullCPUPM like you said, it'll disable power management... but.. i gave to you a solution to get natively power management... so forgot NullCPUPM, delete it if you have it.


GraphicEnabler=Yes to graphic.... use Chameleon Wizard to put it in org.chameleon...



Link to comment
Share on other sites

Okay i made another clean install, with kexts FakeSMC.kext and NullCPUPowerManagement.kext, then deleted kexts AppleGraphicsControl.kext, AppleTyMCEDriver.kext, AppleUpstreamUserClient.kext. used another driver for LAN and used patched AppleHDA instead of VoodooHDA. Also "installed" freeze fix.app from omarabu61, patched AppleIntelCPUPowerManagement.kext and SSDT like PimentelX86, removed NullCPU... and recreated kext cache. System seems to be stable but sleep isn't still working. Its also depends on my bios config:


With resume state S1 - OS X will turn off screen, fans are on, but when i press keyboard it resumes. - Sleep isn't working but don't crash.

S1 with Windows7 - It stops almost all fans (i think PSU is still cooling), my water pump is on, power button led is on. - Sleep work

S3 - OS X will turn off screen, after 15 seconds PC shut down (no fans, no pump, no led). When i power it on, it will power on for 3 secs, turn off, power on for 3 secs, turn off, power on for 10 secs, turn off, power on normally.


Any sugesstions? Need extra boot flags or problem is caused by USB?


Working, installed directly on 2 disk RAID0.

Edited by Snoop05
Link to comment
Share on other sites


  • Create New...