Jump to content
Sign in to follow this  
Followers 0
crump

Sleep/Wake issue with dual Radeon HD 7850 cards

5 posts in this topic

Recommended Posts

Hi

 

I used to have P8P67 / 2600K / HD6970 / Apple Cinema Display, system running 10.9, everything was working with dsdt i dumpped with everest under windows. generated ssdt with revogirl's script.

iMac 12,1 smbios.plist

 

sleep / wake works just fine. I can use power button to sleep/wake, also wake with keyboard and mouse. it's nearly perfect.

 

recently, I replaced my video card with Two  MSI R7850 Twin Frozr 2GD5/OC Radeon HD 7850 2GB crossfired. and added the device id into retail kext, then video card is working. to make it 'perfect' I also inject rampagedev's 7xxx dsdt patch into my DSDT, in IORegExplorer, under PEG0/PEPG, it show up under display@0.

 

however i'm starting to have sleep & wake problem after this. it looks like it will go to sleep, ether with power button or waiting, however after it went to sleep like 2,3 minutes, the computer will wake up when i press keyboard or mouse, yet the display will not wake up. And I have to power cycle (unplug the power cord from tower) in order to get display back. reset button will reboot the computer but I won't get any video on display.

 

I attached my /Extra..I did some clean up in DSDT.aml, but there are still tons of junks in there, probably not gonna affect anything...what do I need to patch to resolve this problem?

 

Thank you for helping.

 

Extra_12192013.zip

and IOReg

imac.zip

Share this post


Link to post
Share on other sites
Advertisement

thank you rampage.

 

My 2 video cards in ioreg are under, RP01/PXSX and PEG0/PEGP, it's a little different than your injection guide.

without injecting anything into DSDT, patching the AMD7000.kext and AMDX4000.kext with correct device-id, the card works and accelerated. however,

"AAPL,slot-name", 
Buffer (0x07)
{
"Slot-1"
}, 

I changed "Slot-1" to "PCIEX1_1" which I got from IORegexplorer, the driver will not load. and in system profiler, it will show whatever I injected into DSDT for :

"model", 
 Buffer (0x13)
     {
       "AMD Radeon HD 7850"
     }, 

I am just trying to understand how it works. do I get values from ioreg and copy them into DSDT? or something else?

Share this post


Link to post
Share on other sites

Slot-1 is how a real mac displays it. You look in your case and count 1,2,3.... 

 

The Slot internally that it is installed say slot 4 you would change 1 to 4. 

Share this post


Link to post
Share on other sites

I see.

the driver not loading problem was caused by not having correct framebuffers. 

"@0,name", 
Buffer (0x0E)
    {
       "ATY,Futomaki"
    }, 

and @1, @2, @3 to change to the same framebuffers then the driver loaded correctly, and "model" in system profiler is showing correctly.

 

however this doesn't fix my sleep/wake issue. 

 

in my ioreg, I don't see UHC2-8, EHC1 under IOService. only EHCI, EHC2 are there as my USB port. does that mean I don't have these devices? but in my dsdt they are there, what is going on?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Lord Kamina
      Hello there everyone. I recently put together a CL hackintosh for a somebody else and it mostly works fine; however, he's been having a problem that I (so far) haven't been able to replicate. He sometimes gets odd beachballs that end up freezing the computer into needing a cold shutdown and boot; which usually in turn freeze halfway through the boot process only for a reboot to work.
       
      Recently he mentioned this happened after several hours of sleep (left the computer sleeping during the night), so I'll try reproducing it later.
       
      However, I'm trying to figure out what the actual problem might be. I've got a theory: Wake-up issues with the NVME controller. Why? I've been experiencing similar issues on my real MBP (2011) because the secondary HD ribbon cable has been coming loose. Of course, since it's just a secondary drive, it's a large inconvenience but it doesn't completely shut the computer down. It would certainly be different if this was happening with the primary drive, though.
       
       
      What do people think about this? It's the first time I've built a hackintosh with modern hardware (my own is Ivy Bridge) and I'd never tried NVME before, so there's been plenty of trial and error involved in this build.
       
      Stats:
       
      CPU: i7-8700
      MB: Gigabyte Z370-HD3P
      RAM: 32 GB DDR4
      Video: Asus RX580
      Drives: Samsung 940 EVO, 2x 1TB HDDs.
      Wifi/BT: BCM94331
       
       
      Other than this issue, pretty much everything seems to be working fine on 10.13.2 (with the exception of the CPU saying Unknown on "About this Mac" but I guess that's cosmetic and expected)
    • By theosxnoob
      Hi All,
      I am currently running on OS X 10.13.1 (High Sierra) and everything works perfectly, besides sleep... I've scoured the internet for an answer but can't figure out how to force my computer to stay asleep (seriously, it's like an infant that's consumed too much sugar). Keeping the computer on 24/7 is wasting so much energy.
       
      Here are my specifications:
      CPU: I7-4790k (Haswell) Memory: 32gb DDR3 GPU: Nvidia 1080ti Gigabyte Motherboard: Gigabyte GA-Z97X-SLI  Network Card: TP-Link Archer T9E (PCI-E Wireless AC) Cooler: Corsair H110i GTX (Corsair Link Connected to USB Header) HDD: 4 SSD's Other Accessories: Oculus Rift, C920 Webcam, Yeti USB Microphone Here are the Kexts/items I've installed into the computer:
      Clover (UEFI Boot Mode), Drivers (VoodooHDA V2. 9.0d10), 3rd Party SATA, FakeSMC, FakeSMC Plugins, 3rd Party USB 3.0, 7/8/9 Series USB Support, NVIDIA Web Drivers Boot Flag Here is the output of "pmset -g assertions":  https://imgur.com/a/Zo4kG
       
      Here is what I've done so far:
      Changes Standby, Autopoweroff, StandbyDelay values Went to BIOS, disabled Wake on Lan Option Changed the darkwake settings to darkwake = no and darkwake = 8,9.. Cried myself to sleep out of frustration At the moment, I turned the hibernatemode to 25 and that seems to shut the computer down automatically. The downside to this is, I need to wait for the computer to completely boot up each time it goes into Hibernate..
    • By hezten
      Hi
       
      I hope om in the right subforum here.
       
      Yesterday i accedently upgrade my hackingtosch to latest sierra version. After reboot it had switched back to the osx display driver, which looks awfull. I vent to the nvidia driver settings and updated the driver and changed the display driver to the nvidia web driver.
       
      After reboot just where the login screen used to appear the screen goes black. I can remember when i installed it i ran some kind of nvidia / graphics hack / fix, but i cant remember exactly how i did it.
       
      i this a common problem with black screen after upgrade, and is there a fix for this ?
       
      Hardware is core i7 7700, asus z270p
       
      Let me know if you need any further information to help out.
       
      Any help is much apriciated :-) Have a great weekend everyone :-)
    • By JasonC
      I recently updated my T520 hackintosh to macOS High Sierra, works great with one exception; sleeping/waking.
      I've noticed that if I have the bluetooth switch on the laptop turned on, it'll kernel panic when waking from sleep mode, otherwise it'll work fine.
       
      Any suggestions for getting sleep mode to work with bluetooth being turned on? It used to work in Sierra..
       
      Ill attach a copy of the kernel panic that seems to occur.
       
      Note: I get the same result with darkwake=0
×