Jump to content

HP DV4-2154ca - Mavericks - {{Boot problem}}

12 posts in this topic

Recommended Posts

Hi guys,


I have recently received a gift from a friend - his old hp dv-2154ca and I was surprised and happy that it has Intel Core 3-330m cpu, so I decided to release another hackintosh for my family use. I prepared a bootable usb with the orfficial Mavericks install application and chameleon bootloader. Unfortunately right after the kext loading I got to a black screen after what the notebook reboted and started booting from the USB again. Later, I decided to give another bootloader a try and another approach for making the usb installation drive. So I have used myHack as well as UniB..st (I do not know is it OK to use the name here as it might be considered as restricted advertising, however you can guess what was it.). Well I got exactly the same problem - loading kexts after what the notebook reboots with no kernel panics, no error messages nor nothing.


Decided that it might be because of the usb drive, so tried with 8, 16 and 32GB flash drives from different companies with all available approaches to create a bootable usb. None of them worked as expected so I cannot even pass to the stage of hardware recognition. The rebooting is fast and no messages can be read, so I had to take my camera and record a video so to find out at what stage the computer reboots. So far the last messages I can see before the reboot are as follows:


FADT: Restart fix applied!
Starting Darwin x86_64
Here are the notebook specs if that would help you point me to some directions:
Manufacturer Part Number: WA689UAR#ABA
Brand Name: HP
Product Line: Pavilion
Product Series: dv4-2100
Product Model: dv4-2154ca WA689UAR
Product Name: Pavilion dv4-2154ca WA689UAR Notebook
Product Type: Notebook
Processor Manufacturer: Intel
Processor Type: Core i3
Processor Model: i3-330M
Processor Speed: 2.13 GHz
Processor Core: Dual-core (2 Core)
Cache: 3 MB
64-bit Processing: Yes
Standard Memory: 4 GB
Memory Technology: DDR3 SDRAM
Number of Total Memory Slots: 2
Hard Drive Capacity: 500 GB
Optical Drive Type: DVD-Writer
Screen Size: 14.1"
Display Screen Type: Active Matrix TFT Color LCD
Display Screen Technology: BrightView
Aspect Ratio: 16:9
Screen Mode: WXGA
Screen Resolution: 1280 x 800
Graphics Controller Manufacturer: Intel
Graphics Controller Model: Graphics Media Accelerator HD
Graphics Memory Capacity: Up to 1.65 GB
Ethernet Technology: Fast Ethernet
Wireless LAN Standard: IEEE 802.11n
Webcam: Yes
Total Number of USB Ports: 3
eSATA/USB Combo: Yes
Pointing Device Type: TouchPad
Number of Cells: 6-cell
As you can see in the box we are talking about Core 3 i3-330m (code name Arrandale) with Intel HD Graphics (First generation) built into the chip. No additional video cards are present.
At first I thought that it is a problem of the video card and deleted all AppleIntelHD* files from /S/L/E of the USB installation stick. Booted with: -v cpus=1 busratio=16 (that is for Arrandale) graphicsenabler=no -f . Well I wish I could say that this worked, but it gave me no changes at all. Also tried to replace the AppleIntelHD* kexts with another that have worked and enabled full QE/CI for many people in this board. Used graphicsenabler=yes with cpu and busratio options, in combination with everything I could think of (npci=0x3000 , pcirootuid=1/0 etc.) well stil nothing.
On the next day of my journey I have found a topic in Internet were a visitor had different notebook but similar problems with my video card (only) and my cpu. So far I understood from that topic that it might be a bad combination of CPU & Kernel. Considering the fact that CPU & GPU are all together it is only making it more difficult for me to troubleshoot, but I decided to not give up without a fight.
I went to an earlier version of Mac OS X using iAtkos, iDeneb, Niresh and many others I have found in Internet. None of them worked my way to the installer as  minimum.
Posted here in another topic where the discussion is aboout Intel HD Graphics, however was advised from a member that this looks not as a graphic device problem so I decided to open a new topic so if anyone have similar or the same configuration to use it as a know-how (if we can manage to solve the problem together).
I have also tried to put Macbook pro 6.1 ioreg but it gave me nothing. Started thinking again and I realized that I did not checked the BIOS for updates. There was one, so I did updated it and set the default values (not that there are any things to set but the boot order and the cooling fan latency). Tried to boot again, nothing.
Going back to reading I discovered a topic, where a user stated that with Snow Leopard it was easy to escape from such problem by just deleting the *IntelHD* kexts. That made me think that at the time of testing SL I did not knew about the trick with the kext deletion so now I am buildinig SL usb and will report did it work or not.
So this is almost the end of my story (for now) and it took me one entire night and day to troubleshoot and read thousands of posts and instruction pages. If anyone have the skills and knowledge to help, I am willing to donate a few bucks as a matter of appreciation (and I am serious about it!)
So if there are any files you would need, feel free to ask me and I can provide them. For now I have a patched version of the frame buffer kext where I downloaded the GPU info under linux and patched the original untouched kext, Also I extracted ny DSDT information however I am not finding any information about patches (what and where from) so I am unable to build dsdt.aml . 
So far this is the entire story but the questions are stil there and are looking for somebody to point to an idea/trick etc.
Thanks everyone in advance for the support. Without you guys, I would never have had Lenovo y580 notebook fully working (with external wireless usb dongle) nor a 100% QE/CI P5g45m-LE with Nvidia GT220. Hopefully someone can help me turn this machine into one more Mac Drive as I am really tired of working in Windows, but Linux is OK but lacks tons of applications that I need and use. Hope I did not miss anything in the info and tries as they were so many and still keep on trying ;)



Link to comment
Share on other sites

Yesterday I decided to start all over and went back straight to Snow Leopard thinking that I can boot with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] (which states works with my CPU) and official SL installation image. Unhided the hidden files and folders, went straight to /S/L/E and removed all AppleIntelGM* , ATI*, NV*  & geforce kexts and rebooted. Well again I had absolutely no luck but to get the reboot exactly on the same stage - right after starting Darwin. This time I have tried the flags: -v graphicsenabler=no busratio=16 npci=0x2000 cpus=1 and even arch=i386 (in combinations or separately) but still nothing.


Anybody can guess where is my problem? Btw, I have notticed that I have problems while installing some of the Linux distributions I use too where I should use 'nomodeset' during GRUB load so to have the screen fired up and showing the desctop. But atleast there It is just a matter of a single option and that is all. With Mac OS X it is a whole new story and a loong journey for me (as it appears :( )

Link to comment
Share on other sites

Well I think I made a HUGE progress... Now I have FINALLY managed to pass that reboot stage and hit Still waiting for root device even though I used for booting pcirootuid=1. Well that is not that scary now as it is a matter of finding the SATA versions and kext. Right now I am creating another usb with Mavericks to see how it will go :)

Link to comment
Share on other sites

Yes, now I can confirm that Mavericks is booting with no problems and I have passed the reboot stage as well. Now it is only a matter of some tweaking to get to the installer window ;) Actually I think I have made it but I do not see the image on my screen so... I am sure this is definitely now an issue of the graphics interface so a few AppleIntelHD* patched kexts should fix it as well as my patched AppleIntelHD frameburer file i prepared by extracting the information via linux and supplying the FrameBuffer patcher. Hmm it is interesting to check whether I really see the screen on another monitor or not. Will know in a minute and continue digging until I reach a successful installation. What is important is that the notebook would work mostly out of the box as soon as the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is used and MacBookPro6.1 smbios is loaded with some boot parameters. I guess the audio might cause problems, so for now I will try with VoodoHDA despite the quality of the sound but later would try to modify the dsdt and see how will it go from there. About the wireless - I am prepared even if I do not manage to get the Atheros chipset to work as I have at home Belkin N300 mini that is sure to work with absolutely no problems on Mac as far as Realtek provides official drivers for it so for now sounds better than expected and it took me only a week to reach to here :) Only one god knows how more should I walk before starting to really use my new Mavericks that is waited long time for me :)

Link to comment
Share on other sites

OK, removing AppleIntelHD* from /S/L/E fixed that problem so I can see and even hear the welcome screen. So far so good, but right after selecting the English for the installation pops up a window where it is written that Mac OS X installer cannot continue due to an error and beneath I can see a huge log of nothing meaning to me informations. All I have managed to filter was about running out of memory (available 38.1 needed 39M for loading libraries). Well that is not the exact message but I think you can get my point. So the saga continues and I have decided to try instead of using myH..k to try with U*iB**t and to stick to the traditional Mavericks image untouched by any additional tweaks etc. myH**k may have placed there and can be causing the error. Booting now, so stay tuned :)

Ok, with standart PURE & UNTOUCHED installer + bootloader and smbios it works and installs now with no problem. Will see what will hapen in 20 minutes or less as for now I did not use SSD. If it works fine, the notebook will receive one Christmas gift earlier this year ;)

Link to comment
Share on other sites

Alright, Sparky, we got a winner this evening and it is HP 2154ca with Internet, Video Camera &  USB (out of the box), Full QE/CI with Framebuffer patching and providing the correct Intel HD Graphics kexts. So far everything works but the sound and I did noticed that my USB mouse started acting weird so maybe I have lost the USB functionality but that would also be fixed as I know it is caused by the AppleIntelHDFB kext and will search for alternatives (if it does cause problem). So far the system is perfectly recognized, cpu cores appear correct, the memory slots and video memory so nothing more to desire on that front. Starting to digg for the sound and I think this might be all or just to fix (if possible) the card reader. It might even work out of the box, however I will try it when I go back home later tonight.

Link to comment
Share on other sites

Ok. It is time to mention that I was a bit wrong as the USB ports are working only when I boot in safe mode (-x). When I boot normally, my usb's are not working, so I am about to try with Mult*B..t and see how would that go. If anyone has an idea what can I use to let my USB's working fine, I can freely move forward...


So far:




Video works on full QE/CI

Video Camera works (out of the box)

Touchpad works

Ethernet works (out of the box)

USB 2.0 USB-Esata 


Sound (working with VoodooHDA, but trying to set its natural support ;) )

Card reader



After all not bad for now, but the usb's are needed. For the wireless I can change the adapter internally with a suitable one from Ebay for 5$ or use my USB Dongle so that is not a problem for now. Sound - well if nothing shows up will have to use VoodooHDA for now. Card reader - not really necessary as I have external USB one, so ...


Continue to digg, but everybody is free to join if any information is available about what is left to have the fully working laptop, afterwhat I will summerize the entire process and provide all the used kexts for the next owners of the same machine.


P.S. The usb was fixed with Zenith432's GenericUSBXCI.kext included in latest MultiB...t

Link to comment
Share on other sites

Well it turns out that after I used the GenericUSBXCI.kext and rebooted with no problems the laptop, after booting I have lost my Internet connection via Ethernet. Now I have to troubleshoot the reason and fix it before I move forward... Any ideas??? Common , guys, I see lots of people just reading but no opinions at all.. I am trying to help others, so have some mercy? :)

Link to comment
Share on other sites

Ok, A bit of report now again:


Camera - working

Video - Full QE/CI and optimal resolution

Wireless - working with the appropriate kext (dev 168 vendor 2b)

LAN - working out of the box with Realtek driver

Sound - voodoohda 2.84


Stil fighting:

USB (they are lost after installing the Intel HD Graphics kexts)

Battery indicator

Sleep & Wake (need to patch DSDT but haven't started searching info yet ;) )

Card reader

Fn buttons


Well that is all for now, and I still see nobody likes to join and share their knowledge so that we can together accomplish my goal. Please, if anyone knows what and how to do, do not torture me, but just give a friendly hand to a Mac newbie ;)

Link to comment
Share on other sites

Hi Marius.


Yes, to make the loader I used UniB* 3.01 but after that I had to use ##### Easy fix so to be able to boot. Without ##### I was able to boot, but not see the X graphical window but a black screen.


So here is how I did it:


1. Download official Maverics App from AppStore (DO NOT USE DMG OR ANY PATCHED FILES, JUT GO AND DOWNLOAD FROM APPLE!)

2. Download latest #####

3. Downoad latest #####

4. Prepare 8GB or bigger USB flash drive by formatting it to Mac OS X Extended. Name it something so you do not mess up with other drives (USB)

5. Start UniB* and point the installer to the USB (flash drive)

6. Wait a lot (20-30 minutes until it is over).

7. Start ##### and use EasyBoot. (top left option). Then go to drivers and select if any match your hardware - with mine I had RTL8169 LAN so it worked like a charm. Surf around the options for audio, usbs (if 3.0) etc. Choose the bootloader Chimera 2.2.1 and select the latest available theme (I liked it the most). After that go and install the ##### on your flash drive.

8. Do not try to boot but go to /S/L/E in the USB and remove from there any AppleIntelHD* (if you do not see folders, then they are hidden so you have to use unhide tool or search for the command in google to show hidden files and folders).

9. After doing the USB, fixing it with ##### and removing all AppleIntelHD starting kexts, just insert the usb to your working 2.0 (if any available) slots and boot with options: 


-v -f graphicsenabler=no


You should boot now perfectly fine and if your USB's are recognized, you can use external ones but if not, you should use touchpad. Follow up the install as usual (partitions, drives etc) and install for good 20 minutes.


10. Boot again from the USB drive, but this time instead of choosing to boot the USB Installer, choose your newly installed partition with the options:


-v -x


11. You should boot fine and continue from there to finalize the install etc.


12. Once logged in, install the Intel HD Graphics (first generation) files for Mavericks using Kext helper or any other tool and just make sure to update kesh (rebuild etc.).


13. Now you can boot and start digging for the rest of the hardware.


For me this method worked and I have almost fully working HP dv4-2154ca . I say almost, because I did not tweak yet the sleep option and the card reader, but all the rest is perfectlu recognized (wireless, keyboard, ps2, usbs, full QE/CI etc.)

Link to comment
Share on other sites

  • 2 years later...

Hi Marius.

Thank You for the guide. I have a Dell 1749 which has the EXACT same issue you have. I get to the clover or chameleon bootloader and than I get a instant reboot. I will try to build my install like yours and see I get any further. From my multiple tries before I had the same results as you.


Removing the kest has not worked for me on its own. ##### will not run a 2nd time. After removing intelhd kext I have to skip this step. I tried adding -s to the boot up and still i get panic on launchd (this time). I need more detailed steps to how you got where you got. My system is very similar and I know im close. Can you add more detail to the steps?


i have confirmed that my laptop uses the LVDS connector so I should be good there. Its just getting past the install screen without a panic that is my issue. Do you have any additional tips for me to try looking at my specs? I am really not sure what is causing my install to panic like it does & reboot. I actually get into the install a lot of times and than panic on the install bar. I know its graphics but Im not sure what else i can try. Also I have gotten freezes on waiting for root device and panic right after dsmos has arrived but its not consistently the same spot that it panics, sometimes i get to the install and it starts and than it panics.


Here are my specs:

Dell studio 1749

2.26 core i3-350m

NO ATI or Nvidia graphics only intel



Technology : TrueLife WLED 900p(standard)

Dell Wireless 1520

Link to comment
Share on other sites


  • Create New...