Jump to content

USB Problem while installing on Gigabyte H55N-USB3


14 posts in this topic

Recommended Posts



I'm having problems getting my USB keyboard and mouse to work in setup.

Keyboard and mouse work until it goes into Darwin

I have tried using legacy and non-legacy USB in the BIOS. Both USB2 and USB3 ports don't work. Also used USBBusFix=Yes and No.



  • Gigabyte H55N-USB3
  • Intel Core i3 540 (with Integrated Graphics)
  • 8GB RAM


I used myHack to create the installer, and used the guide below for the integrated graphics.



Integrated graphics:

  • sudo intel_reg_dumper shows that PCH_LVDS is disabled, hence I went for only Core Image.
  • Deleted everything with AppleIntelHDGraphics from System/Library/Extensions
  • Added AppleIntelHDGraphics.kext, AppleIntelHDGraphicsGLDriver.bundle, AppleIntelHDGraphicsVADriver.bundle to the Extra/Extensions folder

BIOS Settings:

  • AHCI on
  • Legacy USB on (tried it off as well)
  • HPET 64bit


Chameleon Settings:

  • Used the -v -f bootflags
  • Kernel: mach_kernel
  • Ethernet Built In (both on/off)
  • Restart Fix
  • USB Bus Fix (both on/off)
  • Graphics Enabler (both on/off)
  • Graphics Mode (1024x768x32)
  • PCIRoot=1 (0 works, 1 does not)

Extra/Extensions folder:

  • AppleIntelHDGraphics.kext, AppleIntelHDGraphicsGLDriver.bundle, AppleIntelHDGraphicsVADriver.bundle
  • FakeSMC.kext
  • lspcidrv.kext
  • NullCPUPowerManagement.kext
  • Patched_10.7_AppleRTC.kext

I've tried only having FakeSMC and NullCPUPowerManagement and it makes no difference.

Link to comment
Share on other sites

I've deleted the kexts that have AMD*, NVDA*

The rest don't exist.

IntelHD* has been deleted before.


And also removed all the kexts in the Extra/Extensions folder except for FakeSMC, NullCPUPowerManagement


Both -v -f -x and -f -v -x npci=0x2000 boots up into the installer, but keyboard and mouse still don't work.

Link to comment
Share on other sites

  • 1 month later...

  • Create New...