Jump to content

Gigabyte Z77-DS3H + Clover


7 posts in this topic

Recommended Posts

Alright, so, I got Mavericks installed on my build:



8Gb DDR3-1333 RAM OC'd to 1600

i7-3770k (OC'ng shortly to 4.2)


250GB Crucial M500 SSD

1TB Seagate 7200RPM HDD

Vantec FireWire 800/400 UGT-FW210


Using this thread/tutorial by A.I.Ghost


I followed it pretty closely and made a few changes for my specific build as follows:


After following all his steps I got everything except the HWMonitor package to work, so I installed FakeSMC v5.3.820 via MultiB**** to the USB installer, then booted perfectly using "-v -f npci=0x2000".


Installed, deleted AppleKextExcludeList.kext, copied FakeSMC back, rebooted into OSX using "-v -f npci=0x2000"


Ran MultiB**** again and selected FakeSMC v5.3.820 + Plugins/HWMonitor App,

under Audio I selected Realtek ALCxxx>Without DSDT>Optional 3 Port Audio Enabler,

under Disk I enabled 10.9.0 TRIM Patch (for the 250Gb M500 SSD),

under Network I selected Atheros - Shailua's ALSEthernet v1.0.2 so it would be injected directly into the IONetworkingFamily.kext instead of alt-loaded by Extra,

then installed Chameleon from the installer A.I.Ghost suggested and dropped in his org.chameleon.plist, taking out the -v npci=0x2000 flags


After that I got a warning that kexts from unkown developers were installed, so I went to:
System preferences>Security and privacy>Unlock (password needed)>Allow apps downloaded from:Anywhere


Rebooted into an almost perfect installation with everything almost fully functional.


Tried Clover for awhile.

Used this to go to Clover



Boots damn quick, but I keep getting two errors in Console that are a little unsettling:

PM kernel[0]: FireWire GUID 0000000000000000 is invalid!

PM plugin-container[952]: AVF error: AVF_VirtualAcceleratorCreate: fail to create QT accelerator


If anyone knows how to help with either issue please comment asap.


Ran VDADecoderChecker and got:

AVF info: hasOfflineRenderer, board-id check : true
AVF info: Successfully connected to the Intel plugin, offline Gen6 
AVDCreateGPUAccelerator: Error loading GPU renderer
An error was returned by the decoder layer. This may happen for example
because of bitstream/data errors during a decode operation. This error may
also be returned from VDADecoderCreate when hardware decoder resources are available
on the system but currently in use by another process.
VDADecoderCreate failed. err: -12473

I feel like it might be ignoring my nVidia card for some reason or another, even thought the only display in use is hooked into the GTX570 HD.


I'll share my Clover zip below. I'm sure something is a little off, but it boots my above mentioned rig in about 14sec and everything, aside from the two errors mentioned, works perfectly. All you need to do to apply it is format your EFI partition to FAT32 and unzip contents to it, then change BIOS to boot from UEFI EFI partition.


You can test it first by formatting a USB drive to FAT32 and copying the contents of the ZIP there instead, then setting BIOS to boot from the UEFI USB drive.


If you're using ATI/Intel graphics you'll need to change the Inject keys in EFI>Clover>config.plist to "false" for nVidia and "true" for what you use. I think my problems stem from the DSDT section of this same config.plist or from the actual DSDT within EFI>Clover>ACPI>patched>DSDT.dsl.


The added Z77-DS3H folder just has different config.plist's I've tried along the way.


Now I just need a few things from the community. I need a solution for WiFi via normal PCI or USB, preferably OOB, most likely not, please advise if you come across a definite solution. I also need a solution to my above mentioned errors.


Attached Files


So, I installed Enoch instead of Clover and:
sleep can now be woken by USB (previously would only wake from power button)
Firewire doesn't report error UNTIL after sleep, then same "FireWire GUID 0000000000000000 is invalid!" console every 10sec
No longer seeing PM plugin-container[952]: AVF error: AVF_VirtualAcceleratorCreate: fail to create QT accelerator


So I'm led to believe that I screwed up the DSDT part of Clover. I'd really like to make this thing completely Mac'cy and able to do major updates without rehaxin, so if anyone could look at my Clover arrangement and tell me what to change I'd be super appreciative. I installed Enoch with nothing but the above mentioned MuiltiB kexts and a tweaked SMBios to add a serial number to my machine. No DSDT.

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 6 months later...

Sadly I also saw this, looked into it, and was let down.  When I attempt to run an iTunes DRM video I still get the ol "AVF error: AVF_VirtualAcceleratorCreate: fail to create QT accelerator" error in the log.  When I run VDADecoder Checker I don't get the error, tried Enoch as well.  

Link to comment
Share on other sites

OK, I just don't understand why this isn't that big of a deal to anyone. If a Hackintosh can't play movies from iTunes I don't feel like it is a viable alternative to a real Mac :(

I agree, on Windows it works, so I end up spending most of my time in Windows.  It completely undermines, for me at least, having a Hackintosh.  I may as well run Linux.  Without the iTunes tie-in I'm driven back to Windows or to a real Mac.  


I've seen your posts in other areas too, not a single developer has acknowledged this problem nor has any of the major devs even indicated looking into it.  I've considered starting a bounty, but, one of the problems I think is that so many people just haven't jumped to a Haswell CPU yet so many people are content.  This problem will expand as people change CPU's, so, I'm just as surprised as you are.

Link to comment
Share on other sites

I think is that so many people just haven't jumped to a Haswell CPU yet so many people are content.  This problem will expand as people change CPU's, so, I'm just as surprised as you are.


I'm not even on Haswell, I built an IvyBridge Hackintosh ;)

Link to comment
Share on other sites


  • Create New...