Jump to content

installing Mavericks on Dell Latitude D830 - need help


ghaliloo
 Share

5 posts in this topic

Recommended Posts

Hi,

I wanna know if Mavericks 10.9 can be installed on a Laptop with the following configuration in 64bit mode, and what additional things to be done (kexts, patch, DSDT or kernel) in order to have at least Audio + Graphics to work properly, I actually have iDeneb 10.5.2 installed on my laptop, but unfortunately no Audio, Graphics is not top and the Wireless card doesn't work at all, add to this some new applications versions like Adobe CC requires at least v10.7, so I decided to go far and jump to 10.9 directly (I hope :D ) :

 

Dell Latitude D830

 

CPU : Intel Core 2 Duo T93000 2.5 Ghz 6Mo Cache L2 (Originally sold with T7250)

 

RAM : 4 Go DDR2 (Sumsung 2  Go + Hynix 2 Go)

 

Chipset : Intel 965GM with Intel  onboard graphics

 

Graphics : integrated Mobile Intel GMA X3100 ( Ven_8086&dev_2A02&subsys_01ff1028&rev_0c )

 

Wirless : Intel Pro Wirless 3945ABG ( Ven_8086&dev_4222&subsys_1021886&rev_02 )

 

Ethernet : Broadcom NetXtreme Gigabit Ethernet B5755M ( VEN_14E4&DEV_1673&SUBSYS_01ff1028&REV_02 )

 

Sound :  SigmaTel High Definition Audio CODEC ( VEN_8384&DEV_76A0&SUBSYS_102801FE&REV_1002 STAC 92XX C-Major HD Audio (Present on Latitude D830 - D630 & and Dell Precision M4300))

 

Smartcard Reader : O2Micro OZ776/777 USB CCID Smartcard Reader ( usb\vid_0B97&pid_7772&rev_0110 )

 

Fireware IEEE 1394 Open Host Controller Interface ( Ven_1217&dev_00F7&subsys_01FE1028&rev_02 )

 

Trackpad : ACPI\PNP0F13

 

 

N.B : I have the OS_X_Mavericks_10.9_DP1.dmg.

 

 

Thanks in advance  :)

 

I succeeded to install Mavericks 10.9 using myHack see my guide.

Edited by ghaliloo
Link to comment
Share on other sites

Thanks arthur-pt for your quick replay  :)

I tried to install iATKOS L2 last weekend and it always freezes when arriving to the [Custom/install] interface, all things go well but suddenly the Trackpad freezes and the Keyboard too, here is the different combinations I tried :

 

I in the BIOS :

SATA = AHCI

Enabling all core 2 Duo futures.

VIrtualizalion : Enabled

....

...

..

I disabled all things related to Wireless and Bluetooth, because it doesn't let the installer to boot.

 

F8 here I tried hundred of combinations :

-v -x USBBusFix=Yes -f -F graphicsEnabler=No/Yes UseKernelCache=Yes/No ...

 

and the only one that goes to the graphical interface is -v, there I can chose Language, create HFS+ partition, and if I don't do it quickly  (and have to move mouse pointer continuously) the system freezes at all suddenly, then I have to reboot  :(

 

Thanks again

Link to comment
Share on other sites

  • 1 month later...

Hi,

I hope, I am not breaking the rules now, but for nearly perfect guide and help look for osxlatitude site.

Those guys helped me with not throwing aways my old D830. It runs now Mavericks.

 

I installed additionaly battery and vodoo audio kextx. 

 

The only thing - before you start enable in BIOS the AHCI mode for the HDD and disable all unneeded devices like on-board modems, LPT and COM ports.

 

Best,

FM

Link to comment
Share on other sites

Intel GMA X3100 is not supported in 64bit kernel'ed ML or Mavericks, so no point in proceeding with installation; it'll succeed but run like {censored} as soon as graphics are involved.

 

Stick to Lion or 32bit ML with MLPF hack on that D830.

Link to comment
Share on other sites

 Share

×
×
  • Create New...