Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
danathor2

Boot OS X Samsung NP370

16 posts in this topic

Recommended Posts

Hello,

 

I have a Samsung a NP370R5E-S02FR laptop (samsung serie 3) with the following specs :

- intel core i5 3210M

- AMD Radeon HD 8750

- SSD samsung 840

 

System infos :

4wdb.png

 

I'm trying to install moutain lion, but i can't pass the boot step...

I have the message "Still waiting for root device"

 

My bios setup :

Execute Disable Bit : Enabled

AHCI mode control: Manual, set AHCI Mode = Enabled

Secure Boot: Disable, OS Mode Selection: CSM OS

 

I have tried some boot flag (-v, -x, -f)

Without -x, i have a kernel panic

I tried some combinaisons with PCIRootUID, npci 0x2000 0x3000, graphicsEnabler...

 

I tried delete extension in E/E, but always the same mesage "Still waiting for root device".

 

The same message is present with all sytems I tested : #####, myhack, iaktos...

 

I have an other hackintosh which works perfectly, but on my laptop I don't know what do...

 

I listen all ideas, thanks :)

Share this post


Link to post
Share on other sites

Thanks to reply. I have add this kext in E/E.

 

No more "Still waiting", but block on "IOBluetoothHCIController start -- completed".

And before, 10 lines of "Refusing new kext comp...IOPCIFamily : A loaded with a different executable UUID is already present."

 

mini_532177IMG20130922153144.jpg

 

And when I replace IOPCIFamily.kext to yours kext in system/library/E, i return to the "still waiting" message.

Share this post


Link to post
Share on other sites

hello

 

take a good read here

 

Intel HD 4000

 

to boot the installer try to remove appleintelhd*capri

 

and my idea is not to put the kext in E/E

 

that is not used anymore .. after lion mac os x use kernel cache.. so all kext in S/L/E

 

good hack

Share this post


Link to post
Share on other sites

I removed :

- ATI2400Controller.kext

- ATI2600Controller.kext

- ATI3800Controller.kext

- ATI4600Controller.kext

- ATI4800Controller.kext

- ATI5000Controller.kext

- ATI6000Controller.kext

 

And always "Still waiting for root device...", with or without GraphicsEnabler=No and/or npci=0x2000/0x3000

Share this post


Link to post
Share on other sites

hello

 

have u try the 2 way, GUID 

 

MBR ?

 

some laptop only install in MBR

 

see again bios config

 

sorry no more ideas

 

good hack

Share this post


Link to post
Share on other sites

hello

 

try to boot with Clover

 

in uefi mode

 

what image are u using to try to boot ?

 

google for Mac OS X 10.8.5 Mountain Lion bootable USB for Intel PCs

 

good hack

Share this post


Link to post
Share on other sites

Hm, the same image that i have used for my desktop PC.

 

 

 

google for Mac OS X 10.8.5 Mountain Lion bootable USB for Intel PCs

I'll try, thanks. (with a 60kb/s bandwidth...)

I never boot in uefi, I'll search wich Clover.

Share this post


Link to post
Share on other sites

Okay, it's much better!

 

I boot only in safe mode but i can install mac os.

(And i have deleted all video kexts to avoid a black screen...).

 

I can boot on mountain lion installed, in safe mode only again...

(800x600, no touch pad, no sounds, no battery indicator...)

 

My screen without safe mode :

mini_990398IMG20130923223537.jpg

 

 

(And how can i add some flag option with clover ?)

 

Thank you!

Share this post


Link to post
Share on other sites
Update.

 

After some tests, i can't boot without -x.

 

With all video kexts : black screen during boot, with or without "-x"

Without video kexts : screen freeze (see capture above), OK with "-x"

 

Without "-x", i'm flood by many "SMC ERROR" lines. It's important ?

 

With -x,

I boot in 800x600 with chameleon, and i boot in native resolution with clover (but graphics are laggy).

 

I have read many threads on hd4000, but no results.

 

I don't know what can i do.

Work to boot the installer without safe mode or work in post installation ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×