Jump to content

ML on Thinkpad t430s


11 posts in this topic

Recommended Posts



I`m trying install ML on my ThinkPad t430s (i5 3210M@2.5 Ghz/Intel HD 4000 + NVS 5200M). Trying many "how-to", like myHack, all-in-one, iAtkos and other, but i can`t run install process. My laptop reboot no matter what flag i used. The error is: 

ACPI table not found: DSDT.aml

ACPI table not found: SSDT.aml

FADT: Restart Fix applied!


I make DSDT file with DSDT Editor, and create smbios (Chameleon Wizard, macbook pro retina 9.2, because it have same cpu) but still no luck. 

In BIOS optimus, usb 3.0, Virtualization VT-d Feature  - all this disable.

I'm confused what to do.



Link to comment
Share on other sites



that are common msg from the boot loader ...


it don't load mach_kernel ?


insert in boot


wait=yes kernel=mach_kernel


what mac os x version are u trying to install ?


and make a default in u bios


only hd in ahci


good hack


what are u using to install ?

Link to comment
Share on other sites

Well, i download os x 10.8.4 ML bootable usb and copy .raw using Suse image writer,

i have Vmware Mac OS 10.8.4, so i download last Clover_v2_1995 and install it to my usb, and 

copy fakesmc, nullcpupower and ps2controller to S/L/E also copy this kext to Extra folder.

I remove video kext and kernelcache.

My laptop still reboot... maybe i missed something?


Link to comment
Share on other sites

well somehow i can install OS X whit this image http://olarila.com/forum/viewtopic.php?f=27&t=3101 using Chameleon, 

after change some bios settings. now i can but using GraphicsEnabler=No flag,  i know i must enable HD 4000.

but MacOS think that my laptop is iMac... is it normal? what about battery, laptop lid and other stuff? or maybe all i need is 

create in SMbios on Chameleon Wizard?

Link to comment
Share on other sites

  • 2 months later...

Hi I am also having ThinkPad t430s (i5 3320M@2.60 Ghz/Intel HD 4000 + NVS 5200M) config. with windows 8 pre installed.


I am new to here. I would really appreciate help from moderators here clarifying few thing.


1> As per the above post as well as http://olarila.com/forum/viewtopic.php?f=27&t=3101 i got the raw file.

2> I sucssesfully burned raw file in windows to usb drive using win32diskimager then using TransMac  I moved out required kext for Graphics and kernelcache.

3> But now when I boot to usb drive it shows me Clover bootloader menu ui.


Upon selecting Install Mac option system hang after DSMOS Arrived error.

I checked clicking gear like menu in clover it has default boot options as " -v npci-0x2000 "

After searching thro' forums I tried " -v -f npci-0x2000 GraphicsEnabler=no" and "cpus=1", "-s" combinations 

but each time it stops at DSMOS Arrived error.



Am I missing something here?

I believe FakeSMC.kext required postinstallation so may not be the reason?

I don't have running mac with me :( Is it compulsory here to have running mac in this case? If so is it impossible to install Mac w/o Mac?  

I tried pressing 1 as soon as computer boots to check if Chameleon present but nothing happens and Clover bootloader menu comesup.


Any help please?

Link to comment
Share on other sites


  • Create New...