Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Picasso

Haswel i7 4770k + ga-z87x-ud5h + gtx 650 ti Works! 10.8.4

113 posts in this topic

Recommended Posts

My hardware is:

 

ga-z87x-ud5h (bios F7) F8 - RUNNING MAVERICKS 10.9.2

i7 4770K

GTX 660ti 2GB (Gigabyte)  Change: GTX 770 Gigabyte 4GB.

16 GB RAM GSKILL 2400 MHZ

SSD VERTEX 4

HDD 3 x 1 Tb Western Digital Black (RAID)  + 3 GB SEAGETE CABIAR BLACK (BACK UP).

NZXT 750 Watts

 

 

Instalation

 

- BIOS: default settings. D

 

- With My Hack BETA 8 I prepared 10.8.4 FULL and change mach_kernel from 10.8.5 I PREPARE Mavericks 10.9.0

- Install Chamaleon 227X.

- f  GraphicsEnabler=No

- I installed 10.8.5 F36 - I Installed Last Combo Update Mavericks from App Store.

- CHamaleon Wizard: SMBIOS 14.2

- Power Management from http://www.insanelymac.com/forum/topic/295587-power-management-for-sandyivy-bridgehaswell-cpus/

 

Results

 

- Video GTX Native

- Video On Board HD 4600 in system preference with No hardware Acceleration ( I tried all the stuff about IntelAzul and find platform id but I don´t know how people get work this)

- Sleep native

- Both Network works

- ICloud - DaVinci Resolve Works - Final Cut X works perfect!

CPU Power Managment Native - (800Mhz - 3500 - 3900) But I think could be better in the future. - Thanks COBRA03 !

- DVD RW works Native!

- DON"T FORGET PUT TRIM ENABLE IF YOU USE SSD

 

Non Working (SOLVED)

- Audio Thanks FUSSEL for Vodoo and Veddernick for HDA (files in this thread).

- For Mavericks: HDA by Toleda. Look at his thread the kext up to date.

 

NOT SOLVED

- HD 4600 No hardware acceleration.

 

Software used:


Kext Utility - works perfect.

- Chamaleon Wizard (In my case wasn't very important with Smbios, I change different models and nothing happens).

- My Hack. 

Share this post


Link to post
Share on other sites

hi. Can you gave me the Audio kext or a link to kext? I'm having the same config. Are you using chameleon or clover?

 

Are you using a DSDT? (if yes, can you gave it to me, too?)

 

thanks.

 

sleep is working perfectly. autosleep not working

 

i used chameleon, FakeSMC.kext + Plugins

 

this is my org.chameleon.Boot.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>No</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string>darkwake=0 npci=0x3000 PCIRootUID=0</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
</dict>
</plist>

this is my smbios.plist:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>SMfamily</key>
	<string>MacBookAir</string>
	<key>SMproductname</key>
	<string>MacBookAir6,2</string>
	<key>SMboardproduct</key>
	<string>Mac-7DF21CB3ED6977E5</string>
	<key>SMserial</key>
	<string>G8031788GWR</string>
	<key>SMbiosversion</key>
	<string>0815</string>
</dict>
</plist>

i used for the 2 Intel LAN Ports:

 

for Intel i210AT

http://sourceforge.net/projects/osx86drivers/files/Kext/Snow_Lion/AppleIGB.kext.zip/download

 

for Intel i217V

http://sourceforge.net/projects/osx86drivers/files/Kext/Snow_Lion/AppleIntelE1000e.kext.zip/download

 

attached File: used kernel for 10.8.4

kernel.zip

Share this post


Link to post
Share on other sites

ALC 889

try with APPLE HDA

 

New beta at date: http://blog.shade.sh

with the toleda version of alc889 it's not working 

 

can you post your patched applehda, hdaenabler and your patched dsdt as a zip-zile here?

 

windows said: DEV_0899, Subsys 1458A092

Edited by FusselFux

Share this post


Link to post
Share on other sites

tested the betaupdate. pc not booting. any troubles with fakesmc-plugins. if not working i'll install it again 10.8.3 with combo to 10.8.4 with the patched 10.8.3 or the original 10.8.5 kernel

Share this post


Link to post
Share on other sites

tried again with lastest beta to start with different bootflags. updated and downgraded fakesmc, deleted the fakesmc-plugins. tried different bootflag... not starting (pci-configuration begins)

Share this post


Link to post
Share on other sites

New version of 10.8.5 I think in hours should be the final new one: http://blog.shade.sh/index.php/archive/1178

 

Have you update your bios. In my mobo yesterday have the F7

 

double heck your bios: intel video disable, network disable, achi, hot plug enable...

now after updating bios to f7 and osx to12f30 the usb isn't working after sleep

 

 

edit:

Mainboard shows before turning into sleep 03 after pressing the powerbutton for sleep.

after returning from sleep theres 03 there

 

12f26 / 12f30:

autosleep: not working.

 

edit2:

12f30

with GenericUSBXHCI.kext for 10.7/10.8 the system wasnt bootable

with GenericUSBXHCI.kext for 10.9 the system is bootable (without the USB not working after sleep)

 

10.8.4 os x + 10.8.5 kernel does not need GenericUSBXHCI.kext

----------------------

12f26:

both network cards are working

 

12f30:

only the AppleIGB.kextis working

 

but not

AppleIntelE1000e.kext

 

 

audio:

 

voodoohda 2.8.4: worked only after adding my ALC 898 ID with a very very silent voice.

applehda: need a working kext

Share this post


Link to post
Share on other sites

Fussel

Wich video card do you have? Brand an type:

 

- CHeck System preferences, Audio out, Line in, etc, twice!

 

 I think we have to wait for final release from 10.8.5 - hours or days - I'm not going to work with Maverick after Final Cut X and Da Vinci Resolve works perfect - I use this program for my job.

Share this post


Link to post
Share on other sites

Gigabyte GTX 650 Ti OC 2GB

for audio i tried many different solutions. at some i had the hardware shown at soundcontroll preferences, but no sound. at systeminformation i had different audio-IDs 1, 2, 3, 12, 99, but most 0

 

complete hardwareID from windows:

 

Graphic Card: PCI\VEN_10DE&DEV_11C6&SUBSYS_35541458&REV_A1

Audio: HDAUDIO\FUNC_01&VEN_10EC&DEV_0899&SUBSYS_1458A092&REV_1000

Network 1 (I217-V): PCI\VEN_8086&DEV_153B&SUBSYS_E0001458&REV_04

Network 2 (I210): PCI\VEN_8086&DEV_1533&SUBSYS_E0001458&REV_03

Share this post


Link to post
Share on other sites

once youre done with it, can you please post a full step by step installation guide?

installing a kext: download the tool kext utility from here: http://cvad-mac.narod.ru/index/0-4

 

drag and drop the kextfile on this software. enter your password. wait a bit. installed.

 

but before you are trying different kext make a backup of kext (they are at /System/Library/Extensions/) at desktop. the kext utility makes a backup at extension folder and entering *.bak as suffix. restart your pc/mac. kext is working.

Share this post


Link to post
Share on other sites

the AppleHDA + toledas HDAEnabler1.kext and also tested with HDAEnabler2.kext was not working at 10.8.4 with 10.8.5 kernel and at 10.8.5 12F30 was not working...

 

 

do you have a dsdt.aml (at the folder /Extras/ on your HDD you've installed osx)

do you also have a HDAEnabler kext at /S/L/E/?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×