Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ATI HD5870, issues when changing resolution

5 posts in this topic

Recommended Posts

Hello, i've got an Alienware M17x R2 with a ATI HD5870.

It seems to work well, the main issue is that, when it changes resolution or when it stops (and resume) the monitor, it stops working. I see a full black screen that turns to red, green etc.

I have no idea on how to solve this, because everything else seems to work well (it's hardware accellerated, windows and animations are smooth).


Do you have any idea? Or anything i can provide to understand what happens when i change resolution or i stop the monitor?

Share this post

Link to post
Share on other sites

Finally fixed it! You need a dual link fix for your dsdt. Just google that as I cannot put the link as it goes to "the site that shall be named" and I will not post someone else's work without attribution.

Share this post

Link to post
Share on other sites

Hello, thanks for replying and giving me some hope :D

I found a thread about the Alienware M17x R3 and there's a code for the dual link fix, but i can't manage to really fix my issue; i extracted my DSDT, then it has lots of errors when compiling and used DSDTFixer to make it compilable (bad idea probably).

Then i added this code and the DTGP one, put the DSDT.aml file in /Extra and rebooted, but still same issue.

I'm quite new to DSDTs (didn't have any before extracting it right now).


Just to be sure, that's the issue i'm having: 


Do you  (did you) have the same?

In the video i open a game because it changes resolution when it starts, when i change it from Settings it's the same (but i'm scared it'll save settings with wrong resolution)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.