Jump to content

Installing OS X on non-AHCI drive. ( Laptop )


10 posts in this topic

Recommended Posts



Configuration of my laptop:


 I have oldy Asus F80s laptop, with 'not-so-low' specs.

   - ATI Mobility Radeon 3470 HD ( working on Snow Leopard )

   - Intel Core2Duo 2.0 ghz

   - Atheros AR5007EG ( working )

   - 3 GB RAM

   - 250 GB HD


You will need:


   - Another computer with Macintosh OR any file explorer ( too see hfs+ files ).



I had one big problem - OS X installer won't see my HDD drive..... but what i should to do when there's no AHCI mode in BIOS ? 

Let's solve it.



Those kexts i was needed to make my OS X see Serial ATA harddrive (attached)

 - IOATAFamily.kext

 - AppleNForceATA.kext

 - AppleVIAATA.kext


First method.


1.  Write your OS X image to any flash drive. 

2.  Then drop kexts to '<flashdrive>/System/Library/Extensions' OR just use kext installer ( recommended ).

 If you don't see 'System' folder on your Mac then just open Terminal and type: 'defaults write com.apple.Finder AppleShowAllFiles TRUE' and then 'killall Finder' to restart Finder... but if you use another file explorer then just drop those kexts.

3. Try to install now. You will see your SATA Drive in device list.



If first method WON'T work or install fails then try next ( harder procedure ).


1. Disconnect your SATA Harddrive.

2. Get USBtoSATA controller. ( Uses in portative hdds )

3. Write your OS X image to any flash drive. ( DO NOT DROP KEXTS THERE )

4. Connect your HDD which is connected via USBtoSATA controller... Your installer will see your HD without any kexts.

5. Install it on yours HDD which connected via usbtosata controller... When install finishes, it can stuck at 'Still waiting for root device' or 'USBF' log. Shut down your computer. 

6. Disconnect USB HDD, connect it to any computer.

IF YOU USE MACINTOSH - then show all hidden files, and drop kexts which i attached to 'System/Library/Extensions'.

IF YOU USE ANOTHER FILE EXPLORER or OS - then just drop those files to same directory.

7. Safe disconnect your USB HDD.

8. Disconnect your HDD from USB2Sata controller.

9. Connect your HDD back to 'original place'.



Try to launch it.... Ta-Da! OS X should start without any errors.

Tested on Mountain Lion ( 10.8.4 ) and Snow Leopard ( 10.6.6 - 10.6.8 )!









  • Like 6
Link to comment
Share on other sites

Nothing different :thumbsup_anim:

But thanks for your post :wink_anim:

Link to comment
Share on other sites

  • 2 months later...
  • 3 weeks later...

Thank you so much, I've been at this for hours - It was so exciting to finally see the NTFS drives appear in disk utility :)


My machine is an ASUS F83Se,

SiS 671 chipset

Radeon Mobility HD 4570 graphics,

running 10.9 mavericks prepared by the myHack app.


I had to tweak a few other things to get the usb installer to boot however,


At first it would with 'still waiting for root device', this was fixed by passing USBBusFix=Yes alongside -v -f when starting up
Second, bluetooth kexts caused the boot to hang, I just deleted all 3 bluetooth kexts to solve.

Lastly, it seemed to stick at DSMOS has arrived, passing GraphicsEnabler=No solved this one.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...

I'm trying on a Hp dv5 with:

- AMD Turion x2 ultra dual core mobile am-82

- ati Radeon 3400

-atheros ar5007

-Realtek rtl8168c

-4gb ram

I tried with iNeko method because I was stuck on PCI root uuid xxxxx

And it start to give me a lot of point till after some line I reach a series of little cross and kernel panic, than I tried Geo877 suggestions but with no results.

Link to comment
Share on other sites

  • 6 months later...
  • 5 months later...

BEAUTY. I used this to get my drives to show in Mavericks 10.9.5 on an ASROCK Alivesata2-glan. Didn't need the nforce kext , but FINALLY! The drives showed up before I even rebooted. Much Love iNeko. I thought it had smegged my RTL net drivers, but it was my dumb router hanging on me. I have been looking for days on end to get my ide drives to show up. Nothing else worked. Love it. Thank you so much.


Link to comment
Share on other sites


  • Create New...