Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


My Guide to Getting Better Sound/Video Playback in vmWare

3 posts in this topic

Recommended Posts

Distorted, crackling video and audio playback in vmWare?

I did too...


Here's how I fixed it...




Step 1) Update the host audio driver to most stable/updated version.


Step 2) Shut down your VM, edit your VMX configuration file to add these entries:


sound.virtualDev = "es1371"

pciSound.playBuffer = "80"

sound.maxLength = "2048"

sound.smallBlockSize = "1024"

sound.highPriority = "TRUE"

sound.bufferTime = "100"


Step 3) Start up your VM, disable hardware acceleration in Adobe Flash plugin.

(Right click any Flash video and uncheck hardware acceleration)


Step 4) Test your new settings with a fresh YouTube video or MP3 file.




For even better quality playback adjust the value of "pciSound.playBuffer" to different values between 60 and 100 until you get the results you want. 


If for any reason this crashed your sound driver in OS X... try removing the "sound.virtualDev" line from the config.


Questions? I will help answer.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.