Jump to content

Hackintosh ML INSTALL SUCCESS but No app store?

4 posts in this topic

Recommended Posts

I've been experimenting for a few weeks with my PC/HACK on which I have Win 7 Ultimate on one drive and Mountain Lion on another.


I have found that this is the most stable or least complicated arrangement in establishing that the OSX system is booting and working normally.


I have encountered an issue that there seems to be a lot of information about but none of it has really helped me. It has to do with the logging into the MAC App store, completely different from logging into iTunes or the section of the app store that deals with iphones and other personal Apple devices. From my Hackintosh, I am unable to log in to the app store. I get the infamous "an unknown error has occurred" message but my ID and password are fine. I can verify my credentials all day long on the Apple site, make purchases from iTunes but getting to the MAC app store to purchase is another thing.


The information I have seen so far is that for any software purchases, Apple checks the MAC address of the ethernet E0 device as well as other coding that any real MAC can report back to the mothership, sort of a triple credential verification, that if not completed, the above error will be generated at purchase.


Previous to the ML install I started out with Snow Leopard. I encountered the same situation but with the workaround using EFI studio and copying the serial HASH of my E0 device into the boot loader, be it Chamelion or Chimera, that worked to avoid getting the store error. So I purchased ML ESD from Apple and installed it. As I was working through the little optimizations, I encountered the log in issue again with ML and have not been able to get past it.


Dose anyone here know a workaround with ML installed that will allow a log in to the app store?


Really would appreciate any assistance, I think many others have encountered this and is stuck like me.


Thanks in advance!!

The Apple app store REQUIRES that you have at least one Ethernet marked as built-in (even if not used). I ran across this same issues quite some time ago. Once you fix that, the app store will work properly.

SOLVED----What worked for me was the boot flag PCIRootUDI=1 mentioned by site moderator. Once this worked with a manual insert in the boot as a flag, I added it to the boot file so that it was inserted as a boot condition for every boot. Everything else was completely working and normal I tried so many of the suggestions to correct this problem, this is the only one that worked.


Thanks so much

  • 3 years later...

In Clover Configurator or the config.plist






In Chameleon/ENROCK/ 


As stated above.   TYPE in EthernetBuiltIn=Yes


same goes for wifi has Apple Has to see these as 'Built' In.


Your Ethernet.




  • Create New...