Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Tyler Worth

Tosiba Qosmio X875-Q7380 ML Install failed

14 posts in this topic

Recommended Posts

For some reason i can run ML on VMware with this machine but I cant install for the life of me.


I followed this Tut: Click here

For some reason I am getting stuck at Still waiting for device. (picture attached)



My Rig:

CPU: Intel® Core™ i7-3630QM Processor

Graphics: NVIDIA® GeForce® GTX 670M with Optimus™ Technology 3GB GDDR5

Memory: 12GB DDR3 1600MHz memory

HDD: 1.0TB: 500GB (7200rpm, Serial ATA) + 500GB (7200rpm, Serial ATA)

Optical: DVD-SuperMulti drive (+/-R double layer)

Wifi: Intel® Wi-Fi® Wireless networking (802.11b/g/n + WiDi Capable)

Bluetooth: Bluetooth® V4.0

USB:4-USB (3.0) ports

Any one help me PLEASE!




So I was able to Boot and install ML using a boot CD which was from OSX86.net But I cant boot into the OS I have tried the following boot flags;

-v -F -x maxmem=4084 busratio=18 npci=0x3000 PCIRootUID=0 and 1

This is what I get



Instead of getting Still waiting.... Error I get a Kernel Panic. But I myself cant figure this out.

Any help would be awesome.

Share this post

Link to post
Share on other sites



Those screens are hard to read.

Well, copy the following kexts to the Extra folder of the USB installer you have created.


Boot with -f -v


Okay I tried this copied them both to the Extra Folder on my USB installer.

Booted with -f -v

and got this


Hopfully this image isnt as blurry, I get the same reaction from my system, I am going to try booting with PCIRootUID=0 npci=0x3000 -x -v -f see if that changes any other is appreciated.

Share this post

Link to post
Share on other sites

Well, this shouldn't be happening. You need to know which AHCI SATA controller your system uses, Boot Windows, if you still have it, and get this info from the Control Panel/Device Manager or using Everest.exe, then post it here.


Best regards!

Share this post

Link to post
Share on other sites

@theconnactic - You helped me in the AMD forums, Nice I got a Toshiba intel! but its a {censored}! haha


I tried UseKernelCache but no luck


Here is a report from everest:



And also A screen shot its the same as befre with UseKernel.... I just didnt wait for the Still waiting error....


Share this post

Link to post
Share on other sites

Well, your chipset is intel: Intel® 7 Series Chipset Family SATA AHCI Controller.


That means high compatibility with OSX. This issue should not be happening, and you should be getting your installer to work without any issues and modifications. But laptops are always harder to sort out. You'll have to start over. Use the same guide: i used it a lot of times with 100% of success. Take it slow: a single misstep and you'll have issues. Please report back here when you're done.


Best regards!

Share this post

Link to post
Share on other sites

I redid it twice now. but i May have a Solution. To be honest I didnt buy the ML app becuase I didnt want to waste the money if it didnt work, but i got my commision check so I am going to buy it now even if it doesnt work. so i will report back when its done

Share this post

Link to post
Share on other sites

Okay! Good luck!

Alright I got it working!

I got a legit copy of Mac OSX this time booted with Just "GraphicsEnabler=No" (provided by grim90210) and bam it worked. Now I am stuck at DSDT. I have no idea what to do or what Im doing wrong and I am Flipping tried. I work at Verizon so I need to go to bed to open the store tomorrow!

If anyone can point me in the right direction that would be awesome! Im uploading a screen shoot of all the errors Im getting after hitting compile that won't fix.


DSDT (Copied and pasted to Text Edit)



Screen Shot of Errors



I am posting this from the Mac using my phone as a USB wifi Card :P still do'nt know how to find kext for my stuff either. Please point me in the right direction. All help is much appreciated If I can get some help I will make a Guide for this computer and give all credit to those who helped!

Share this post

Link to post
Share on other sites

Good News!

After several hours of work I now have -

Working Ethernet

Usable resolution ex 1600 900


Trackpad and Keyboard support

Along with a Mountain Lion install !

If you havent gotten this far yet let me know and Ill post the steps :D

Share this post

Link to post
Share on other sites

I have my DSDT fixed but trackpad keyboard sound and havnt got the intel 4000 working correctly. I put down mac for the end of the quarter at college. I do have working Ethernet.

Share this post

Link to post
Share on other sites

The HD4000 and the intel Centrino wireless are not supported , you can buy a wireless card that will work for around 20 $ but it involves opening up the laptop and replacing the chip , not hard at all but yea. for the resolution fix just find the chameleon.plst and add the graphics mode tag and the desired resolution ex 1600x900x32 then it will display correctly no gpu acceleration tho. If you download ##### it contains the drivers for the trackpad and sound and keyboard.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.