Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

[solved] SystemId, SMsystemid not working

3 posts in this topic

Recommended Posts

Sorry if I posted this on wrong section, but I trying to change my system-id to get imessage working, and I found out that there is an option called "SystemId" for org.chameleon.boot.plist, to change the system id manually.


My system id now: 0000000000000000000000XXXXXXXXXX (XXXXXXXXX = my MAC address)


This looks odd with the many zeros, I thought that maybe this is the problem and this is the reason why imessage doesn't working for me.


I tried to make a "SystemId" key into my org.chameleon.boot.plist file and generated an own uuid and set that up, but my system-id stays the same with the zeros. It just ignores this setting...


I also tried "SMsystemid" in smbios.plist, but it's ignored too.


Anyone knows how to change the system-id value? Is it possible?

(I'm using chameleon 2181)


Edit: I changed the org.chameleon.boot.plist > "SystemId" from Windows (macdrive), and since then, I can change my systemid to anything. (from osx too)

Share this post

Link to post
Share on other sites

Chameleon's automatic System ID injection (and its manual override) doesn't work for everybody, it's a rare occurence but you're not the first person to report this issue.


Also apparently some PCs have their UUID set as all zeros from the factory. I don't know what Chameleon does with that. That might be the case with your PC, but that doesn't explain why you're not able to override it. Maybe a syntax error. Have you tried setting it both with - between the numbers and without?


Use this page to generate a random UUID for your override.


For future forum searchers I'll confirm here that the correct flag (like you say) is "SystemId" in org.chameleon.Boot.plist


SMsystemid doesn't seem to exist.


Another important thing to remember is that the "Hardware UUID" that you see in System Profiler is generated from the "System ID" you set, or the System ID Chameleon sets for you automatically. They are not and will never be identical:



Make sure that all three files that make up the Chameleon boot loader (boot, boot1h, boot0/boot0md or whatever you use) are from the same version. Some "upgrade" Chameleon just by replacing /boot, but that is a bad idea.


Make sure your plist files aren't corrupt, that can cause all sorts of unpredictable behavior. Recreate them from scratch, you can use Library/Preferences/SystemConfiguration/com.apple.Boot.plist as a template.

Share this post

Link to post
Share on other sites

Thanks for the reply, I tried it with "-" between the numbers and tried without it, but it doesn't change. I checked everything multiple times already, and everything seems okay, but "SystemId" flag is just not working.

Is it need to be "string" if I set it like "<key>SystemId</key><string>UUIDNUMBER</string>", or it should be "number" or "data" maybe?


edit: I tried again the same thing as before, and now it works as should :|

But imessage still not working... so it didn't change anything...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.