Jump to content

CLOVER bootloader...


179 posts in this topic

Recommended Posts

la guida: collegamento rimosso

grazie Fabio, ma non ho idea di come si fa a cambiare il config.plist, e perdona, ma cos'è un flag?

Il config.plist lo trovi all'interno della cartella EFI del boot di Clover

Per modificarlo cerca Clover Configuration

Le flag sono per es. -v quello che vuoi modificare

 

Fabio

Scusatemi tutti per l'assoluta ignoranza e perché forse si è già parlato  degli stessi argomenti. Ho installato mavericks con clover da chiavetta usb seguendo le istruzioni trovate qui:  mi funziona quasi tutto. Ho due ssd uno per mac e uno per win e due hard disk di archivio uno per mac e uno per win. Il boot di cover innanzitutto parte sempre in modalità -v e preferirei che partisse in -s ma non so dove settarlo, ma soprattutto nella scelta che il boot offre di avviare da win o da mavericks parte solo da mavericks, se scelgo windows si pianta e dà schermo nero con trattino lampeggiante, come se fosse in attesa, ma dopo 30 minuti è ancora li. qualcuno può aiutarmi?

Se Windows è installato su Mbr in legacy mode  con Clover non lo avvii.......Windows per avviarsi con Clover deve avere la sua cartella nella ESP e per averla deve essere installato in modalità Uefi.

  • Like 1

Se Windows è installato su Mbr in legacy mode  con Clover non lo avvii.......Windows per avviarsi con Clover deve avere la sua cartella nella ESP e per averla deve essere installato in modalità Uefi.

ecco friscos questa è una cosa che volevo sapere

ecco friscos questa è una cosa che volevo sapere

Ciao Carlo.
Per essere precisi Clover secondo le opzioni di installazione può essere installato anche sulla root principale di osx dove genera una cartella, ma anche in questo caso se non ricordo male windows su Mbr non si avvia.
Puoi sempre fare delle prove..
 
Basta non spuntare le prime due caselle:
clover10.png

Bene...anzi benissimo....ognuno ha suoi metodi, ma che "c'azzecca" :drool:  con le problematiche legate al dual-boot di Clover?

 

Io come tanti altri usiamo osx e windows in alternanza sullo stesso disco/Pc.....

Perdonami forse non so bene cosa sia il dual boot? In caso di errore correggimi pure. Dual boot significa poter avviare qualsiasi cosa da dispositivi diversi con lo stesso bootloader o no?  :)

Quello che intendi tu ovvero un un solo disco e' Multiboot non Dual (lo dice il termine stesso) scusami ma l'inglese lo conosco molto bene

Non credo sia necessaria una conoscenza approfondita dell'inglese per intendersi in questo thread sul significato specifico di dualboot, ad ogni modo fonti attendibili lo riconduco a una precisa funzionalità:

 

http://it.wikipedia.org/wiki/Dual_boot 

 

:yes:

  • 2 months later...

Ovvio ....se hai un DSDT personale lo devi inserire in ACPI / Patched

Quello che fai tu ....da come ho capito , gli stai dicendo a clover di applicare patch on fly ...quindi ad ogni riavvio sei costretto a fare sempre questa trafila.

Ti consiglio di metterlo nella sua destinazione

 

Origin sta per originale ..cioè clover ti da la possibilità di estrarre il tuo Dsdt originale

 

 

non prende nulla ne in origin

 

 

Non hai capito in Origin ..non avrai mai niente fin quando non premerai il ditino sulla tastiera F4 , ma solo quando stai sulla GUI .( e li troverai tutte le tabelle estratte )

 

 

 


Mi spiego originale o patchato con o senza se nel config.plist selezionavi Debug DGTP e poi questo o quello te lo teneva

Passami il config.plist

  • 2 months later...

ciao ragazzi, ho provato ad installare clover uefi tramite pandora su una pendrive... inizialmente sembrava proprio installarsi e al riavvio mi dava disk error al boot... adesso ho in parte risolto l'arcano... praticamente pandora invece di installare clover sulla partizione efi lo installa sulla partizione primaria... ho montato la partizione efi e buttato dentro le cartelle installate sull'altra partizione ed il boot loader adesso è partito... l'unico problema è che appena do l'invio sulla mia partizione rimane a schermo nero e non va avanti...

come posso risolvere?

ciao ragazzi, ho provato ad installare clover uefi tramite pandora su una pendrive... inizialmente sembrava proprio installarsi e al riavvio mi dava disk error al boot... adesso ho in parte risolto l'arcano... praticamente pandora invece di installare clover sulla partizione efi lo installa sulla partizione primaria... ho montato la partizione efi e buttato dentro le cartelle installate sull'altra partizione ed il boot loader adesso è partito... l'unico problema è che appena do l'invio sulla mia partizione rimane a schermo nero e non va avanti...

come posso risolvere?

Elenca le cartelle che hai messo nella EFI

 

Fabio

  • 3 weeks later...

Premetto che ho una configurazione un pò anomala: Yosemite su ssd sata con partizione EFI, Windows (installato come EFI) su ssd pci senza partizione EFI. Avviando da Windows boot manager win8 non si avvia dando l'errore 225, mentre avviando win8 da clover nessun problema.... fin qua tutto ok e mi va bene cosi  ;)

 

Quello che volevo segnalare è che questo "trucchetto" è valido fino a versione 3156 di clover, se aggiorno alla versione 3176/3185 il "giochetto" salta e Windows non si avvia piu dando sempre l'errore 225. Cosa hanno cambiato nelle ultime versioni che mi sega Windows?

Questi sono gli aggiornamenti dalla 3156 alla 3185

What's New in Version 3185 (See full changelog)
[3185] use recent versions
[3184] possibility to choose embedded and random themes by pref panel
[3183] dont inject snb-id automatically if there is no criteria
[3182] mistake in macmini name
[3181] implement snb-platform-id
[3180] correct mistake of 3178
[3179] restrict cycles in smbios
[3178] increase cycle to check ram slots
[3177] -low-ebda will be default as it works for all
[3176] sync OmvfPkg with recent edk2
[3175] sync AtaAtapi with edk2-16863
[3174] framebuffers for AMD8000 controller
[3173] restore sumo2
[3172] new framebuffers names
[3171] one flea
[3170] new data for ATI
[3169] update compatibility for fakeid
[3168] change config name in menu should affect settings
[3167] new haswell legacy regions

Qui : http://www.insanelymac.com/forum/files/file/347-clover-efi-bootloader/

 

Fabio

Questi sono gli aggiornamenti dalla 3156 alla 3185

What's New in Version 3185 (See full changelog)
[3185] use recent versions
[3184] possibility to choose embedded and random themes by pref panel
[3183] dont inject snb-id automatically if there is no criteria
[3182] mistake in macmini name
[3181] implement snb-platform-id
[3180] correct mistake of 3178
[3179] restrict cycles in smbios
[3178] increase cycle to check ram slots
[3177] -low-ebda will be default as it works for all
[3176] sync OmvfPkg with recent edk2
[3175] sync AtaAtapi with edk2-16863
[3174] framebuffers for AMD8000 controller
[3173] restore sumo2
[3172] new framebuffers names
[3171] one flea
[3170] new data for ATI
[3169] update compatibility for fakeid
[3168] change config name in menu should affect settings
[3167] new haswell legacy regions

Qui : http://www.insanelymac.com/forum/files/file/347-clover-efi-bootloader/

 

Fabio

 

Bisognerebbe pero' capire cosa impedisce alla mia installazione di Windows di avviarsi  ;)

Bisognerebbe pero' capire cosa impedisce alla mia installazione di Windows di avviarsi  ;)

Win 8 in UEFI è installabile con la chiavetta creata con Rufus

Scusa, mi ero perso qualcosa...

Ti dico la mia esperienza con Clover e Win8:

2 dischi diversi, installato OS X con clover nel primo disco

Staccato il disco di OS X ed instalato Win8 sul 2° disco creando la EFI

Riconnesso e settato primario il disco con OS X che gestisce il boot di entrambi

 

Versione di Clover 3185

Scusa, mi ero perso qualcosa...

Ti dico la mia esperienza con Clover e Win8:

2 dischi diversi, installato OS X con clover nel primo disco

Staccato il disco di OS X ed instalato Win8 sul 2° disco creando la EFI

Riconnesso e settato primario il disco con OS X che gestisce il boot di entrambi

 

Versione di Clover 3185

La tua e' una situazione "tipica" e giustamente funziona. La mia e' particolare, perche mi sono ostinato ad installare windows sulla revodrive pcie ;-) e la prima cosa che ho dovuto fare e' spostare la partizione efi su un'altro disco, e visto che c'ero ne ho fatta una per entrambi gli Os.

 

Il tutto funziona alla perfezione, almeno fino alla versione 3156 di clover....

  • 2 weeks later...

Scusa, mi ero perso qualcosa...

Ti dico la mia esperienza con Clover e Win8:

2 dischi diversi, installato OS X con clover nel primo disco

Staccato il disco di OS X ed instalato Win8 sul 2° disco creando la EFI

Riconnesso e settato primario il disco con OS X che gestisce il boot di entrambi

 

Versione di Clover 3185

Solito procedimento tranne il fatto che ho usato il metodo Legacy per O.S.X, infine Win8.1 installato senza usare Clover come Bootloader ma bensì  il suo in MBR

 

Clover v2.3k r3168

  • 3 weeks later...
  • 6 months later...

Scusate, sapete per caso come fare ad avere dark boot logo su clover? per capirci meglio quello con lo sfondo nero e la mela bianca, ho provato a cambiare tema ma nulla da fare.

Dovrebbe essere di default, a meno che non sia flaggato "custom logo" nel config.plist

×
×
  • Create New...