Jump to content

CLOVER bootloader...


morfy
 Share

179 posts in this topic

Recommended Posts

Mi sono espresso male vorrei installare Mavericks in uefi lasciando stare linux .......

Clover per me è complicato per questo chiedevo a voi un piccolo aiuto ..... ma non esiste un Chameleon per l'installazione in uefi?


Linux non te lo tocca nessuno, se hai creato una partizione per Mavericks o hai un Hd  a parte (cosa che non ho capito) fai la tua installazione di osx  e basta.

L'installazione di mavericks è sempre uguale, non ha senso dire installare in uefi mode, è il bootloader che cambia.

Se ti trovi meglio con Chameleon  usa quello e cmq se linux   è stato installato con un boot uefi non saprei dirti se chameleon è in grado di dargli l'input.

Clover come sottolineava Carbo può essere installato anche in partizione ma le complicazioni sono le stesse.

 

Se potessi postare uno screen su come è partizionato il tuo hdd sarebbe meglio.


Dicamo cosi, Linux è un altro discorso non lo devo installare partiamo dall'installazione di Mavericks selezionando dal bios la funzione UEFI.

Come posso far partire l'installazione di Mavericks in UEFI mode?????

devo per forza avere Clover perchè per ora, o almeno credo, chameleon supporta ancora l'avvio in efi .....

Se volessi utilizzare un immagine di mavericks, gia pronta con clover , dove devo mettere i miei kext, dsdt ssdt e configurare il config.plist?

 

Se utilizzo una chiavetta usb creata con myhack, pandora etc e seleziono dal bios del mio samsung EFI, queste non partono devo per forza cambiare in bios mode ......


Se hai fatto con myHack l'installer hai chameleon, non so come sia messo il tuo bios, ma se selezioni Uefi e legacy compatibile con csm abilitato la chiavetta viene vista.

Se invece sei con il CSM disabilitato con chameleon non avrai il boot e dovrai usare Clover.

Questo non ti cambia l'installazione di osx e spostando successivamente le opzioni del bios sarà sempre avviabile a seconda dei casi con entrambi i bootloader.


Nel mio PC se seleziono dal bios il boot in Uefi la chiavetta usb creata con myhack e con chameleon non parte ..... quindi devo utilizzare Clover, quindi una vola preparata la usb con clover nella partizione EFI della chiavetta, in che directory devo mettere i miei kext e i miei dsdt ssdt ? e come devo configurare il config.plist visto che con clover non legge ne il smbios.plist ne l'org.chameleon.Boot.plist .....


La cartella predefinita per ssdt e dsdt è EFI/CLOVER//ACPI/Patched.

Config.plist lo puoi configurare con Clover Configurator (in questo modo puoi decidere anche smbios da iniettare). Se usi SSDT o DSDT ad hoc ricorda di non mettere nulla nella parte ACPI del config.plist; se nel dsdt hai la grafica iniettata togli qualsiasi opzione nella sezione grafica del config.plist.

La cartella dove mettere i kext è EFI/CLOVER/kexts/10.9.

Ti consiglio di scaricare EFI Mounter per montare la partizione EFI della pendrive e visualizzarne il contenuto


Giusto, ma in teoria lo mette in automatico quando rileva il file nella cartella patched (almeno a me è successo così)


Ciao a tutti, sono riuscito ad installare Mavericks + clover in uefi anche se ancora non mi funzionano alcune cose ....... 

comunque se poi installo linux in uefi questo crea una cartella nella partizione efi del mac MA installa anche il bootloader grub quindi al riavvio parte grub e non clover; anche avviando poi il pc con la usb con clover linux non viene rilevato ......

Continua a smanettare ......


AlexAMD credo che durante l'istallazione di linux tu debba istallare grub nella stessa partizione di linux

seno grub prende il sopravvento 


Pero questo succede con Chamaleon ma credo sia la stessa cosa

 

prova

 

a me boottano 4 sistemi uno dei quali è ubuntu e ho sempre fatto così', l'unico inconveniente (riparabile) che quando avvii linux ti si avvia grub,

a quel punto basta mettere il Timeout di grub a 0  qui vedi come fare

http://askubuntu.com/questions/148095/how-do-i-set-the-grub-timeout-and-the-grub-default-boot-entry


il problema è che quando installo Manjaro o linux Mint questi non mi permettono di scegliere la partizione dove installare grub mentre se nel pc non è presente hack installato e installo solo più distribuzioni linux posso scegliere la partizione per grub......

 

Mentre se installo Mavericks con MBR  posso scegliere la partizione per grub ma non mi fà installare altri sistemi operativi ... sbaglio qualcosa forse come partiziono?


 Uffaa!!   :D Se c'è una partizione EFI/fat32 di boot quando installi linux in uefi mode (cioè facendo partire dal supporto UEFI: xx) il bootloader si piazza nella ESP senza che glielo dici, poi sposti l'ordine nel bios.

Grub resta tale e quale, in quanto clover non fa partire direttamente linux ma ti rimanda al Grub,

 

1405.jpg

Troverai nel bios anche la voce di Linux, ma Clover gestisce tutto anche windows in triple boot

c4c5fe87612cde4d3a477345bf63ea4f.png

Sul tuo samsung la grafica del bios sarà molto diversa ma le voci ci devono essere. 

 

PS

Quando si installa in uefi non si può scegliere la partizione di boot, cioè la partizione di destinazione del boot sarà sempre la EFI /Fat32 contrassegnata col flag "boot"

  • Like 1

GRAZIE! Ora ci sono ho capito un pò di cose ..... devo solo riuscire a far funzionare i kext riguardanti la batteria per il resto tutto ok ..... poi farò un istallazione pulita ..... 

Vi ringrazio tanto per la pazienza .....  :P


  • 3 weeks later...

Ciao a tutti,

avrei bisogno di un aiutino...

con Clover (r2747 installato in legacy mode) non riesco a far partire il boot di windows 7 in NTFS... mi appare un quadrato al centro dello schermo e non fa niente.

Ho installato anche da Clover Configurator il driver ntfs ma niente da fare.

Qualche consiglio??

Grazie.


  • 4 weeks later...

Si carbo ma da come ho potuto capire è stata fatta una istallazione in uefi ( per me è una cosa molto strana, un bootloader innovativo che ha queste carenze, con chamaleon era un altra storia)

 

il punto è: si puo avviare in legagy una istallazione precedente senza ristallare tutto windows che per me sarebbe una tragedia, eppure osx li avvia anche se erano vecchie istallazioni

è bastato togliere la cartella Extra e il file boot dalla root

poi ho trovato un altro problema che non si avviano più' le usb con Pandora istaller e non capisco proprio come mai

 

devo provare solo a fare un flash del bios perché sicuramente la colpa è di clover che lo ha intaccato 

 

spero che qualcuno possa darmi notizie in merito


Una tragedia

 

le istallazioni da usb di Pandora non partono più' 

boot0 error

l'ho ricreata un altra credendo che fosse corrotta ma nada

boot0 error

 

@Fabio le porte usb fungono ci ho provato di tutto e si aprono tutte sulla scrivania

stampante riconosciuta anche le card sd funzionano

 

clover ha compromesso o a insediato qualcosa che non le fa partire perché hanno il chamaleon bios l'ho rifleshato quindi non dipende da quello

sto in mezzo a una cosa marrone che puzza :hysterical:  :hysterical:  :hysterical:

 

ho pensato anche che fosse comunque la scheda video r9 270 a dare questo casino, in effetti le altre istallazioni prima erano state fatte con le vecchie schede ati 5770 montate

 

 

carlo_67


  • 1 month later...

Scusatemi tutti per l'assoluta ignoranza e perché forse si è già parlato  degli stessi argomenti. Ho installato mavericks con clover da chiavetta usb seguendo le istruzioni trovate qui:  mi funziona quasi tutto. Ho due ssd uno per mac e uno per win e due hard disk di archivio uno per mac e uno per win. Il boot di cover innanzitutto parte sempre in modalità -v e preferirei che partisse in -s ma non so dove settarlo, ma soprattutto nella scelta che il boot offre di avviare da win o da mavericks parte solo da mavericks, se scelgo windows si pianta e dà schermo nero con trattino lampeggiante, come se fosse in attesa, ma dopo 30 minuti è ancora li. qualcuno può aiutarmi?


Scusatemi tutti per l'assoluta ignoranza e perché forse si è già parlato  degli stessi argomenti. Ho installato mavericks con clover da chiavetta usb seguendo le istruzioni trovate qui:  mi funziona quasi tutto. Ho due ssd uno per mac e uno per win e due hard disk di archivio uno per mac e uno per win. Il boot di cover innanzitutto parte sempre in modalità -v e preferirei che partisse in -s ma non so dove settarlo, ma soprattutto nella scelta che il boot offre di avviare da win o da mavericks parte solo da mavericks, se scelgo windows si pianta e dà schermo nero con trattino lampeggiante, come se fosse in attesa, ma dopo 30 minuti è ancora li. qualcuno può aiutarmi?

Dovresti indicare la guida che hai seguito.

per i flag in avvio devi modificare il config.plist

 

Fabio


 Share

×
×
  • Create New...