Jump to content

VoodooHDA with fix for random KP


38 posts in this topic

Recommended Posts

Glad to see that work is being done on the VoodooHDA driver. I'm still running v0.2.62 with my ALC888 chip, as that is the only version (so far) in which the volume levels are not distorted and – more importantly – the S/PDIF port is working with.

 

However, when I attempt to download the most recent 0.8.2 build mediafire throws an error.

 

Why not include the driver as an attachment to the forum post for members to download directly?

 

 

Archive Download Blocked

 

 

The file you attempted to download is an archive that is damaged or possibly encrypted. MediaFire does not support unlimited downloads of broken or encrypted archives and the limit for this file has been reached. This file may only be distributed from a premium account.

 

We have informed the owner that sharing of this file has been limited and how they can resolve this issue.

Still have questions, or think we've made a mistake? Please contact support for further assistance.

  • Like 1
However, when I attempt to download the most recent 0.8.2 build mediafire throws an error.
For some reason, mediafire has stopped liking tar.bz2 files. I've reuploaded it as a tar.gz file. Try the link in post #1 again (on 2.8.2d6.)

Ok, thanks - the 2.8.2d6 download works now. And yeah, I noticed they had tagged the bzipped tar-file file as "encrypted" or "damaged". Gotta love these lame file-sharing sites. (who actually pays for this service anyway?) ;)

 

I seldom get KPs on my Shuttle SH67H7 system with VoodooHDA, but they do occur. Hopefully the volume levels and S/PDIF port will be working with this recent driver (unlike the 0.7.x revisions which all had sound distortion/clipping issues with this codec.) I must have tried 10 different versions before finding the (older) 0.2.62 revision which worked the best...

@Zenith432 - just wanted to let you know that your audio driver is working perfectly. I've now tested it on two systems; one using the ALC888 codec (Shuttle SH67H7) and an old Core2 Duo system (Dell Dimension 8200) using the Intel 82801H on-board audio.

 

ALC888: The S/PDIF port is working (currently outputting 96kHz / 24-bit, stereo) and the volume levels using the analog audio ports are correct. Sweet. The only thing I noticed - and this is the same with all VoodooHDA drivers I've previously tested - is that the 5.1 output is missing with the optical/toslink. HDMI reports 8 channels; but I haven't been able to test this yet. Nevertheless, I am plenty happy to be able to use the optical for 2-ch stereo, and with a high sampling rate. (Actually, the prior VoodooHDA versions were reporting 4 channels for S/PDIF, but in actuality had no working output at all.)

 

82801H (vendor ID: 8086, device ID: 284b): This chip has not been working on _any_ of the recent VoodooHDA's previously tested. I've had to use an ancient 0.2.1 version with it in order to produce anything other than crackling audio output.

 

So major kudos! Glad someone who knows what they are doing is maintaining the source code for these drivers.

 

Now if only there was a permanent solution for the HD3000 ring stall issue ("apparent hang in main graphics engine") I'd be a happy Hackintosh camper. ;) My last crash actually corrupted the main hfs+ partition, not recoverable with Disk Util.

@Zenith432,

 

Great progress!

 

I have few suggestions, if you don't mind:

 

- iMix value should be controlled by "Input volume" slider as volume one does;

- On HD4000 it adds all 3 HDMI found, we need a way to find which one is used(apple use jack detect), aslo display port/HDMI detection is incorect;

- On multi channel setup we need Headphones to mute them on jack detect, and also auto select, IMHO the implementation of heaphones jack detect is all wrong, it should be like this, if headphones, check if jack is inserted, if yes show and enable plus mute rest, if not hide and mute it.

 

Overall, very pleased with your branch,

 

Thanks! :)

  • Like 1
  • 4 months later...

A follow-up to my previous comment regarding multichannel 5.1 (bitstream/encoded) audio: this now works perfectly on both systems I am currently using (with ALC888 & ALC862); so the information I provided earlier was incorrect. Your driver is also stable as hell–I have yet (after probably 40 reboots and a system running ~50 days) experienced any crashes for which the VoodooHDA driver was the culprit. *knock wood*

 

I've also been running the latest XBMC (12.2) using your driver and have so far not experienced any issues at all (using DD5.1 / DTS5.1 & PCM output), audio sync is perfect & no audio dropouts.

 

The only real problem I've encountered with the driver appears on my Ivy Bridge system, which has the ALC862 chip: static is heard if using 24-bit or 32-bit sampling width. The audio is being heard faintly in the background, and the static disappears if switching to 16-bit in Audio MIDI Setup. Upon booting the system it defaults to 32 bit, which made this issue immediately apparent.

(I haven't found any way of setting this permanently to something else using Audio MIDI Setup, btw.)

 

Under Linux (ALSA) 24-bit audio output appears to be fine. Unsure if this is a trivial fix or not, but since it's the only real fault I've found with it I thought I'd let you know.

 

Again, big kudos for a VoodooHDA branch which is miles ahead of what is being provided elsewhere.

  • 1 month later...

... aaand back from the dead, 8 months later.. I've been busy recording so i decided not to experiment with the drivers..

Thanks Zenith for your work - I now tried 2.7.6d2, 2.8.1 and 2.8.2d6, and they all seem to get rid of the KP, but unfortunately they also get rid of my onboard sound card...

 

I'm using an HDTV for my screen and it's connected via HDMI.. Using the updated kexts only allow me to select those digital out, but no HD audio with line in/outs - which is what i need. Mixing through an old LG 37LD450's speakers is far from optimal ;]

 

I rolled back to my random KP inducing kext, which i can live with since once started it's running fine. Thanks a lot anyway, and glad I could help a little!

  • 2 weeks later...
  • 4 weeks later...
  • 4 weeks later...
  • 1 month later...

I just installed latest VoodooHDA driver but it doesn't seem to work with Intel High Definition Audio (8086, 1e20). I only have HDMI on the settings panel, no speakers. Any ideas how to get this working?

 

Edit:

Nm, had to add my Device ID.

  • 2 weeks later...

I just installed latest VoodooHDA driver but it doesn't seem to work with Intel High Definition Audio (8086, 1e20). I only have HDMI on the settings panel, no speakers. Any ideas how to get this working?

 

Edit:

Nm, had to add my Device ID.

Take version 2.8.4. It works with your chipset

#define HDA_INTEL_CPT         HDA_MODEL_CONSTRUCT(INTEL, 0x1c20)
#define HDA_INTEL_PATSBURG    HDA_MODEL_CONSTRUCT(INTEL, 0x1d20)
#define HDA_INTEL_PPT1        HDA_MODEL_CONSTRUCT(INTEL, 0x1e20)
#define HDA_INTEL_82801F			HDA_MODEL_CONSTRUCT(INTEL, 0x2668)
#define HDA_INTEL_63XXESB			HDA_MODEL_CONSTRUCT(INTEL, 0x269a)
#define HDA_INTEL_82801G			HDA_MODEL_CONSTRUCT(INTEL, 0x27d8)
#define HDA_INTEL_82801H			HDA_MODEL_CONSTRUCT(INTEL, 0x284b)
...
×
×
  • Create New...