Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

[SOLVED] no Power off after shutdown

7 posts in this topic

Recommended Posts

Hi everyone,


Altho my iHack works just fine there is one thing that occupy my mind for some time. Sometimes for no reason at all system refuses to power down.

OS X shuts down but PSU stays on and I'm forced to press power button >4 sec to power off. Most of the time it's powering off completely.

Sins there are no changes to the OS X nor peripherals it doesn't make any sense to me. I've tested my hardware and found no defects at all.

Also my second similar machine, shows same problem. They both run 10.8.2


Can anyone confirm this erratic issue or maybe point me in to right direction how to solve this.


Reason I'm writing this topic is that I'm pretty much done googling and have no idea where to look any more.

Share this post

Link to post
Share on other sites

Sounds similar to the default behavior when a UPS is installed. Booting verbose can also help to see what process are being terminated at shutdown. To test a bit and see what exactly is the cause, you can initiate shutdown from terminal, and pass different options as well. For a basic, no frills shutdown, type:

sudo shutdown -h now

For more info on some of the other options check the man page by typing

man shutdown

And my favorite line from the man page:

At intervals, becoming more frequent as apocalypse approaches and starting at ten hours before shutdown, warning messages are displayed on the terminals of all users logged in.


Share this post

Link to post
Share on other sites

Thanks, I've tried your suggestion but shutdown screen is too quick to read it all. Is there a way to capture it?


few last lines are:


umount of /home failed error (45)

umount of /net failed error (45)


CPU halted


after this screen goes black and sometimes system actually powers off

Share this post

Link to post
Share on other sites

That's all perfectly normal and sounds like a good, proper shutdown, those two unmount failures are normal too. If it was hanging up you'd be able to read it. Do you have Evoreboot.kext installed or shutdown fix in your DSDT? You can access the shutdown logs, but they are super long.

Share this post

Link to post
Share on other sites

Thanks again,


I never had a shutdown hang at that point. Any way as far I can see, shutdown verbose screen looks the same every time even when system actually powers off.

There are no non apple kext installed except RealtekRTL81xx.kext , SleepEnabler.kext and FakeSMC.kext.

DSDT is generated by DSDT Patcher GUI sins there is no known DSDT patch for my mobo and I'm not familiar with manual DSDT patching.

Same mainboard worked fine with 10.6.x 10.7.x and same method of creating dsdt.aml file.


Sleep still works perfectly so I'm using it until I've found a solution for this shut down issue.


Is there any log file or screen shot I shod post to give you a better look at whats going on here?

Share this post

Link to post
Share on other sites

Try easiest thing first which would be to install evoreboot.kext, shutdown logs are in /var/logs/, just look through there and you'll find them, not at home and only have iPad at the moment so can't double check the exact file path

Share this post

Link to post
Share on other sites

Using Kext Wizard I've installed and loaded EvoReboot.kext repaired permissions and rebuild cache.

First shut down as following two worked perfectly. I've also tested sleep and reboot. Works fine.

Long story short, I have a perfect iHack again!


Thanks again eep357!


@ other readers:


/var/log/shutdown_monitor.log is hidden and in ML empty too


To show hidden files in Finder run the following command in Terminal


defaults write com.apple.finder AppleShowAllFiles TRUE


And reload Finder by running the following command in Terminal


killall Finder


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.