Jump to content
InsanelyMac Forum
SS01

Get rid of "The disk you inserted was not readable"?

Recommended Posts

I have OS X tri-booted with Windows and Linux. It is on the same drive as Linux's /home, with Windows being on a seperate 160GB drive and Linux applications on a 60GB SSD. Whenever I boot up, I get "The disk you inserted was not readable by this computer" twice, once for each of the two Linux disks. Is there a way to make OS X stop "seeing" these disks? Thanks

Share this post


Link to post
Share on other sites
Advertisement
or choose the hide option in chameleon setup
If I'm not mistaken (then apology), "Hide" option hides a disk from Chameleon's own boot disk selection menu. While the question was about OS X trying to mount disk with filesystem it can't read (when OS X is already booted and running).

Share this post


Link to post
Share on other sites

I'm sorry that I'm bringing back this old 'thread', anyway my situation is that.

I do have two volumes, one with Lion and one with an ext4 partition.

Unfortunately I cannot get the UUID through 'diskutil' (same story for 'disk utility'):

$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Hackintosh              499.8 GB   disk0s2
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk1
   1:                      Linux                         999.0 GB   disk1s1
   2:                 Linux_Swap                         1.2 GB     disk1s2
$ diskutil info disk1
   Device Identifier:        disk1
   Device Node:              /dev/disk1
   Part of Whole:            disk1
   Device / Media Name:      Hitachi HDS721010CLA332

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      FDisk_partition_scheme
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified

   Total Size:               1.0 TB (1000204886016 Bytes) (exactly 1953525168 512-Byte-Blocks)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                No

   Whole:                    Yes
   Internal:                 Yes
   OS 9 Drivers:             No
   Low Level Format:         Not supported

Do you have any hint on how I can prevent 'disk1' to be automatically mounted?

Share this post


Link to post
Share on other sites

diskutil info $(df / | tail -1 | cut -d' ' -f 1)

 

from terminal

 

This is the result:

   Device Identifier:        disk0s2
   Device Node:              /dev/disk0s2
   Part of Whole:            disk0
   Device / Media Name:      Hackintosh

   Volume Name:              Hackintosh
   Escaped with Unicode:     Hackintosh

   Mounted:                  Yes
   Mount Point:              /
   Escaped with Unicode:     /

   File System Personality:  Journaled HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended (Journaled)
   Journal:                  Journal size 40960 KB at offset 0xe8e000
   Owners:                   Enabled

   Partition Type:           Apple_HFS
   OS Can Be Installed:      Yes
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              A9EDEAAA-5F50-323E-AA07-F7BE21C30BE0

   Total Size:               499.8 GB (499763888128 Bytes) (exactly 976101344 512-Byte-Blocks)
   Volume Free Space:        435.2 GB (435241730048 Bytes) (exactly 850081504 512-Byte-Blocks)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         No
   Ejectable:                No

   Whole:                    No
   Internal:                 Yes

I can get the UUID of the HFS+ partition even with "disk utility", but I need to prevent the other disk from mounting (ext4) or I'll get the "disk you inserted is not readable by this computer" message anytime I boot on Lion. Thanks tho.

Share this post


Link to post
Share on other sites

one option is to install a third party filesystem-driver that has Linux filesystem support so you'r able to r/w disks in Mac OS, then you'r able to get the UUID and put that inside /etc/fstab so it doesn't auto mount on each boot. There is a better option when using MBR / Fdisk scheme type disks with linux installed onto them and this involves creating a additional FAT32 partition just before the linux 'slice' so OSX will not complain on every boot, but I'm unsure about how to do this with hybrid type disks layouts  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×